aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-03-04 19:18:53 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-03-04 19:18:53 +0000
commit0d3d9251931685f982b3541a906c729fe2aced81 (patch)
tree82ec4e6adc839d26ac4d717a455cff44ae9c0e05 /biology
parent8475985698fa6e66b8307319e206df2ad0dd19dc (diff)
downloadports-0d3d9251931685f982b3541a906c729fe2aced81.tar.gz
ports-0d3d9251931685f982b3541a906c729fe2aced81.zip
biology/spoa: fix build on non-x86
In file included from /wrkdirs/usr/ports/biology/spoa/work/spoa-4.0.7/src/dispatcher.cpp:7: /usr/local/include/cpuinfo_x86.h:228:2: error: "Including cpuinfo_x86.h from a non-x86 target." #error "Including cpuinfo_x86.h from a non-x86 target."
Notes
Notes: svn path=/head/; revision=567333
Diffstat (limited to 'biology')
-rw-r--r--biology/spoa/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/biology/spoa/Makefile b/biology/spoa/Makefile
index 41bdf70f51f7..6a1908b3ff73 100644
--- a/biology/spoa/Makefile
+++ b/biology/spoa/Makefile
@@ -25,11 +25,17 @@ USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= rvaser
-CMAKE_ON= BUILD_SHARED_LIBS spoa_optimize_for_portability spoa_build_executable spoa_use_simde spoa_use_simde_nonvec spoa_use_simde_openmp spoa_generate_dispatch
+CMAKE_ON= BUILD_SHARED_LIBS spoa_optimize_for_portability spoa_build_executable spoa_use_simde spoa_use_simde_nonvec spoa_use_simde_openmp
CMAKE_OFF= spoa_optimize_for_native
LDFLAGS+= -lz -lcpu_features
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == amd64 || ${ARCH} == i386
+CMAKE_ARGS+= -Dspoa_generate_dispatch:BOOL=ON
+.endif
+
do-test:
@cd ${BUILD_WRKSRC} && \
${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -D${PORTNAME}_build_tests:BOOL=ON ${CMAKE_SOURCE_PATH} && \