aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2022-02-03 12:37:38 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2022-02-03 12:37:38 +0000
commit2b1ef5b34e0ee73661c0b9755f4e6806de1095d5 (patch)
treeda40f8a2a0bd5f486a12436651fc0899ab0ebced /biology
parent714d30ce9a6a72a515e6e3a243450c7a576e8e2a (diff)
biology/py-dna-features-viewer: Python lib to visualize DNA features
DNA Features Viewer is a Python library to visualize DNA features, e.g. from GenBank or Gff files. DNA Features Viewer can plot sequence maps linearly or circularly, with or without nucleotide sequence and amino-acid sequences. The plotter automatically produces clear plots even for sequences with many overlapping features and long labels. The library plays well with Matplotlib and Biopython, and the figures can be saved in different formats (PNG, JPEG, SVG, PDF), e.g. for report generation or LIMS interfaces.
Diffstat (limited to 'biology')
-rw-r--r--biology/py-dna-features-viewer/Makefile20
-rw-r--r--biology/py-dna-features-viewer/distinfo3
-rw-r--r--biology/py-dna-features-viewer/pkg-descr12
3 files changed, 35 insertions, 0 deletions
diff --git a/biology/py-dna-features-viewer/Makefile b/biology/py-dna-features-viewer/Makefile
new file mode 100644
index 000000000000..7ea1d63d46e6
--- /dev/null
+++ b/biology/py-dna-features-viewer/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= dna-features-viewer
+DISTVERSION= 3.1.0
+CATEGORIES= biology python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= dna_features_viewer-${PORTVERSION}
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Python library to visualize DNA features, e.g. GenBank or Gff files
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENCE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=3:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}biopython>0:biology/py-biopython@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/biology/py-dna-features-viewer/distinfo b/biology/py-dna-features-viewer/distinfo
new file mode 100644
index 000000000000..8131a2c7de96
--- /dev/null
+++ b/biology/py-dna-features-viewer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1643841661
+SHA256 (dna_features_viewer-3.1.0.tar.gz) = 1430bbd861b4fa4a1855fb9554577bc1b2e969a6d1921882bb2de56902cd63ca
+SIZE (dna_features_viewer-3.1.0.tar.gz) = 34795
diff --git a/biology/py-dna-features-viewer/pkg-descr b/biology/py-dna-features-viewer/pkg-descr
new file mode 100644
index 000000000000..367dce2c930c
--- /dev/null
+++ b/biology/py-dna-features-viewer/pkg-descr
@@ -0,0 +1,12 @@
+DNA Features Viewer is a Python library to visualize DNA features, e.g.
+from GenBank or Gff files.
+
+DNA Features Viewer can plot sequence maps linearly or circularly, with
+or without nucleotide sequence and amino-acid sequences. The plotter
+automatically produces clear plots even for sequences with many
+overlapping features and long labels. The library plays well with
+Matplotlib and Biopython, and the figures can be saved in different
+formats (PNG, JPEG, SVG, PDF), e.g. for report generation or LIMS
+interfaces.
+
+WWW: https://pypi.python.org/project/dna-features-viewer/