aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2023-07-28 15:41:58 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2023-07-28 15:41:58 +0000
commit505bb0df2b00b2e9a65545764cf39855eab6bfa5 (patch)
tree07de74943e0439ab1c01386274e3522011b806e8 /biology
parent4a76a74959d94be943e91b2921e2d555f381b031 (diff)
downloadports-505bb0df2b00b2e9a65545764cf39855eab6bfa5.tar.gz
ports-505bb0df2b00b2e9a65545764cf39855eab6bfa5.zip
biology/py-htseq: Python library for sequence analysis
HTSeq is a Python library to facilitate programmatic analysis of data from high-throughput sequencing (HTS) experiments. A popular component of HTSeq is htseq-count, a script to quantify gene expression in bulk and single-cell RNA-Seq and similar experiments.
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/py-htseq/Makefile30
-rw-r--r--biology/py-htseq/distinfo3
-rw-r--r--biology/py-htseq/pkg-descr4
4 files changed, 38 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index ecb49b10cc6c..dc020b1fd61e 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -171,6 +171,7 @@
SUBDIR += py-goatools
SUBDIR += py-gtfparse
SUBDIR += py-hits
+ SUBDIR += py-htseq
SUBDIR += py-libnuml
SUBDIR += py-libsedml
SUBDIR += py-loompy
diff --git a/biology/py-htseq/Makefile b/biology/py-htseq/Makefile
new file mode 100644
index 000000000000..2c5ff14011da
--- /dev/null
+++ b/biology/py-htseq/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= HTSeq
+DISTVERSION= 2.0.3
+CATEGORIES= biology python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Python library to facilitate programmatic analysis of sequence data
+WWW= https://pypi.python.org/project/htseq/
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}pysam>0:biology/py-pysam@${PY_FLAVOR}
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}pysam>0:biology/py-pysam@${PY_FLAVOR} \
+ ${PKGNAMEPREFIX}matplotlib>=1.4.3:math/py-matplotlib@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scipy>1.5.0:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=1.1.0:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=1.4:math/py-matplotlib@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist cython distutils pytest
+
+post-stage:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/HTSeq/_StepVector.cpython-39.so
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/HTSeq/_HTSeq.cpython-39.so
+
+.include <bsd.port.mk>
diff --git a/biology/py-htseq/distinfo b/biology/py-htseq/distinfo
new file mode 100644
index 000000000000..88554006d541
--- /dev/null
+++ b/biology/py-htseq/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1690498174
+SHA256 (HTSeq-2.0.3.tar.gz) = c7e7eb29bdc44e80d2d68e3599fa8a8f1d9d6475624dcf1b9644285a8a9c0fac
+SIZE (HTSeq-2.0.3.tar.gz) = 394178
diff --git a/biology/py-htseq/pkg-descr b/biology/py-htseq/pkg-descr
new file mode 100644
index 000000000000..afafda9c12f4
--- /dev/null
+++ b/biology/py-htseq/pkg-descr
@@ -0,0 +1,4 @@
+HTSeq is a Python library to facilitate programmatic analysis of data
+from high-throughput sequencing (HTS) experiments. A popular component
+of HTSeq is htseq-count, a script to quantify gene expression in bulk
+and single-cell RNA-Seq and similar experiments.