aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-06-10 18:42:48 +0000
committerSteve Wills <swills@FreeBSD.org>2012-06-10 18:42:48 +0000
commit63d09c9c9b84669faec2c94444cb4ba43ca65ec0 (patch)
tree897864e11191cee1fd0515a4af0b3aa5ab400840 /biology
parent17363b49d179d9fa2c2ddac86f2a984508354712 (diff)
downloadports-63d09c9c9b84669faec2c94444cb4ba43ca65ec0.tar.gz
ports-63d09c9c9b84669faec2c94444cb4ba43ca65ec0.zip
- Convert all remaining instances of BUILD_DEPENDS=${RUN_DEPENDS} or
RUN_DEPENDS=${BUILD_DEPENDS} to use := which portlint has warned about for a while. PR: ports/168208 Approved by: portmgr (miwi)
Notes
Notes: svn path=/head/; revision=298970
Diffstat (limited to 'biology')
-rw-r--r--biology/p5-AcePerl/Makefile2
-rw-r--r--biology/p5-Bio-Das/Makefile2
-rw-r--r--biology/pycogent/Makefile2
-rw-r--r--biology/t_coffee/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/biology/p5-AcePerl/Makefile b/biology/p5-AcePerl/Makefile
index b0652bd68dcd..bf670c57184f 100644
--- a/biology/p5-AcePerl/Makefile
+++ b/biology/p5-AcePerl/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 interface to the ACEDB genome database system
RUN_DEPENDS= p5-Cache-Cache>=0:${PORTSDIR}/devel/p5-Cache-Cache
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS:= ${RUN_DEPENDS}
MAKE_JOBS_UNSAFE= yes
diff --git a/biology/p5-Bio-Das/Makefile b/biology/p5-Bio-Das/Makefile
index 60b25424aa24..50beef43c54e 100644
--- a/biology/p5-Bio-Das/Makefile
+++ b/biology/p5-Bio-Das/Makefile
@@ -18,7 +18,7 @@ COMMENT= Client-side library for Distributed Genome Annotation System
RUN_DEPENDS= p5-HTML-Parser>=3:${PORTSDIR}/www/p5-HTML-Parser \
p5-bioperl>=0:${PORTSDIR}/biology/p5-bioperl \
p5-libwww>=5:${PORTSDIR}/www/p5-libwww
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= YES
diff --git a/biology/pycogent/Makefile b/biology/pycogent/Makefile
index ef1263c13d53..91e85b355e42 100644
--- a/biology/pycogent/Makefile
+++ b/biology/pycogent/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${PYNUMPY} \
${LOCALBASE}/bin/cython:${PORTSDIR}/lang/cython \
${LOCALBASE}/bin/sphinx-build:${PORTSDIR}/textproc/py-sphinx \
${PYTHON_PKGNAMEPREFIX}sqlalchemy06>=0.5:${PORTSDIR}/databases/py-sqlalchemy06
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
diff --git a/biology/t_coffee/Makefile b/biology/t_coffee/Makefile
index 6bc30c0b47ea..dc4f15eef490 100644
--- a/biology/t_coffee/Makefile
+++ b/biology/t_coffee/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= fernan@iib.unsam.edu.ar
COMMENT= A multiple DNA or protein sequence alignment package
BUILD_DEPENDS= clustalw:${PORTSDIR}/biology/clustalw
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
BUILD_WRKSRC= ${WRKSRC}/t_coffee_source
MAKE_ENV= MV=${MV} USER_BIN=${PREFIX}/bin \