aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-27 04:13:57 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-27 04:24:05 +0000
commit64e4fe193ce5a65a0369fc14c94d2d00aa51d32c (patch)
tree1c0aca8d602129ac16925c6ec3896c2b422a3c61 /biology
parentd80f50246cbf0cafe274057987c9f34811ce21f5 (diff)
downloadports-64e4fe193ce5a65a0369fc14c94d2d00aa51d32c.tar.gz
ports-64e4fe193ce5a65a0369fc14c94d2d00aa51d32c.zip
biology/libsedml: Fix build with libsbml 5.20.0
===> Performing out-of-source build /bin/mkdir -p /wrkdirs/usr/ports/biology/libsedml/work/.build -- The CXX compiler identification is Clang 13.0.0 -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Check for working CXX compiler: /usr/local/libexec/ccache/c++ - skipped -- Detecting CXX compile features -- Detecting CXX compile features - done -- Check for working CXX compiler: /usr/local/libexec/ccache/c++ - skipped -- Detecting CXX compile features -- Detecting CXX compile features - done -- Looking for BZ2_bzCompressInit in /usr/lib/libbz2.so -- Looking for BZ2_bzCompressInit in /usr/lib/libbz2.so - found -- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) CMake Error at /usr/local/share/cmake/Modules/Internal/CheckSourceCompiles.cmake:51 (message): check_source_compiles: C: needs to be enabled before use. Call Stack (most recent call first): /usr/local/share/cmake/Modules/CheckCSourceCompiles.cmake:76 (cmake_check_source_compiles) CMakeModules/FindLIBXML.cmake:115 (CHECK_C_SOURCE_COMPILES) /usr/local/share/cmake/Modules/CMakeFindDependencyMacro.cmake:76 (find_package) /usr/local/lib/cmake/sbml-static-config.cmake:14 (find_dependency) /usr/local/share/cmake/Modules/FindLIBSBML.cmake:42 (find_package) CMakeLists.txt:338 (find_package) -- LIBXML_LIBXML_TEST = CMake Error at /usr/local/share/cmake/Modules/Internal/CheckSourceCompiles.cmake:51 (message): check_source_compiles: C: needs to be enabled before use. Call Stack (most recent call first): /usr/local/share/cmake/Modules/CheckCSourceCompiles.cmake:76 (cmake_check_source_compiles) CMakeModules/FindLIBXML.cmake:125 (CHECK_C_SOURCE_COMPILES) /usr/local/share/cmake/Modules/CMakeFindDependencyMacro.cmake:76 (find_package) /usr/local/lib/cmake/sbml-static-config.cmake:14 (find_dependency) /usr/local/share/cmake/Modules/FindLIBSBML.cmake:42 (find_package) CMakeLists.txt:338 (find_package) -- LIBXML_LIBXML_TEST2 = CMake Error at CMakeModules/FindLIBXML.cmake:132 (message): Unable to compile a test executable against LIBXML LIBXML_INCLUDE_DIR = /usr/local/include/libxml2 LIBXML_LIBRARY = /usr/local/lib/libxml2.so Call Stack (most recent call first): /usr/local/share/cmake/Modules/CMakeFindDependencyMacro.cmake:76 (find_package) /usr/local/lib/cmake/sbml-static-config.cmake:14 (find_dependency) /usr/local/share/cmake/Modules/FindLIBSBML.cmake:42 (find_package) CMakeLists.txt:338 (find_package) -- Configuring incomplete, errors occurred! *** Error code 1 Stop.
Diffstat (limited to 'biology')
-rw-r--r--biology/libsedml/files/patch-CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/biology/libsedml/files/patch-CMakeLists.txt b/biology/libsedml/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..d3511e327290
--- /dev/null
+++ b/biology/libsedml/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2022-06-07 11:34:09 UTC
++++ CMakeLists.txt
+@@ -73,7 +73,7 @@ set(LIBSEDML_DOTTED_VERSION ${LIBSEDML_VERSION})
+ set(PACKAGE_NAME "libSEDML")
+
+ project (libsedml VERSION "${LIBSEDML_VERSION_MAJOR}.${LIBSEDML_VERSION_MINOR}.${LIBSEDML_VERSION_PATCH}"
+- LANGUAGES CXX)
++ LANGUAGES C CXX)
+
+ set(CMAKE_CXX_STANDARD 11)
+ set(CMAKE_CXX_STANDARD_REQUIRED YES)