aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2018-04-24 14:16:46 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2018-04-24 14:16:46 +0000
commit6c102b8c64d9fffde755102268f249c4d825bebc (patch)
tree72ae7460506a9b04d5602d9aa4e0824ee795dcc0 /biology
parent2e6ea034ad9b3f9e00cefdf215668f52396f929f (diff)
downloadports-6c102b8c64d9fffde755102268f249c4d825bebc.tar.gz
ports-6c102b8c64d9fffde755102268f249c4d825bebc.zip
biology/unanimity: Pacific Biosciences consensus library and applications
Reviewed by: jrm Differential Revision: https://reviews.freebsd.org/D15172
Notes
Notes: svn path=/head/; revision=468214
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/unanimity/Makefile40
-rw-r--r--biology/unanimity/distinfo3
-rw-r--r--biology/unanimity/files/patch-CMakeLists.txt11
-rw-r--r--biology/unanimity/files/patch-cmake_uny-config.cmake10
-rw-r--r--biology/unanimity/files/patch-cmake_uny-gitsha1.cmake11
-rw-r--r--biology/unanimity/files/patch-include_pacbio_genomicconsensus_Input.h16
-rw-r--r--biology/unanimity/files/patch-include_pacbio_genomicconsensus_Output.h19
-rw-r--r--biology/unanimity/files/patch-src_CMakeLists.txt15
-rw-r--r--biology/unanimity/files/patch-src_Recursor.h12
-rw-r--r--biology/unanimity/pkg-descr8
11 files changed, 146 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 996d7f82218c..5cef59a1bcbe 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -128,6 +128,7 @@
SUBDIR += trimadap
SUBDIR += trimmomatic
SUBDIR += ugene
+ SUBDIR += unanimity
SUBDIR += vcftools
SUBDIR += vcflib
SUBDIR += velvet
diff --git a/biology/unanimity/Makefile b/biology/unanimity/Makefile
new file mode 100644
index 000000000000..e114b0e2495b
--- /dev/null
+++ b/biology/unanimity/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= unanimity
+DISTVERSION= g20180307
+CATEGORIES= biology
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Pacific Biosciences consensus library and applications
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+# Sensitive to dependency versions, use latest commit for everything
+BUILD_DEPENDS= pbseqan==g20171002:biology/pbseqan \
+ pbbam==g20180416:biology/pbbam \
+ pbcopper==g20180413:biology/pbcopper
+LIB_DEPENDS= libhts.so:biology/htslib \
+ libboost_regex.so:devel/boost-libs
+
+USES= cmake pkgconfig python
+USE_GITHUB= yes
+GH_ACCOUNT= PacificBiosciences
+GH_TAGNAME= 6f11a13e1472b8c00337ba8c5e94bf83bdab31d6
+
+CMAKE_ARGS+= -DHTSLIB_INCLUDE_DIRS:STRING=${LOCALBASE}/include/htslib \
+ -DHTSLIB_LIBRARIES:STRING="-L${LOCALBASE}/lib -lhts" \
+ -DPacBioBAM_INCLUDE_DIRS:STRING=${LOCALBASE}/include/pbbam \
+ -DPacBioBAM_LIBRARIES:STRING="-L${LOCALBASE}/lib -lpbbam" \
+ -DSEQAN_INCLUDE_DIRS:STRING=${LOCALBASE}/include/PacBio \
+ -Dpbcopper_INCLUDE_DIRS=${LOCALBASE}/include \
+ -Dpbcopper_LIBRARIES="-L${LOCALBASE}/lib -lpbcopper"
+CFLAGS_i386= -msse2 -Wno-c++11-narrowing
+
+PLIST_FILES= bin/arrow bin/ccs bin/gcpp lib/libcc2.a lib/libunanimity.a
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/src/libcc2.a ${WRKSRC}/src/libunanimity.a \
+ ${STAGEDIR}${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/biology/unanimity/distinfo b/biology/unanimity/distinfo
new file mode 100644
index 000000000000..b8204cecf16a
--- /dev/null
+++ b/biology/unanimity/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1524324354
+SHA256 (PacificBiosciences-unanimity-g20180307-6f11a13e1472b8c00337ba8c5e94bf83bdab31d6_GH0.tar.gz) = 20ed61c46afcfe86403a564136b96f909149208c51fde16f608e924ad4c59e38
+SIZE (PacificBiosciences-unanimity-g20180307-6f11a13e1472b8c00337ba8c5e94bf83bdab31d6_GH0.tar.gz) = 6492231
diff --git a/biology/unanimity/files/patch-CMakeLists.txt b/biology/unanimity/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..77e1825a21f3
--- /dev/null
+++ b/biology/unanimity/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2018-03-07 23:10:34 UTC
++++ CMakeLists.txt
+@@ -37,7 +37,7 @@ include(uny-ccache)
+ include(uny-releasewithassert)
+ include(uny-dependencies)
+ include(uny-compilerflags)
+-include(uny-gitsha1)
++# include(uny-gitsha1)
+ include(uny-config)
+
+ # Build library
diff --git a/biology/unanimity/files/patch-cmake_uny-config.cmake b/biology/unanimity/files/patch-cmake_uny-config.cmake
new file mode 100644
index 000000000000..33ec308164a4
--- /dev/null
+++ b/biology/unanimity/files/patch-cmake_uny-config.cmake
@@ -0,0 +1,10 @@
+--- cmake/uny-config.cmake.orig 2016-09-12 19:55:43 UTC
++++ cmake/uny-config.cmake
+@@ -1,6 +1,6 @@
+ # Config generation
+
+-find_git_sha1(UNANIMITY_GIT_SHA1)
++# find_git_sha1(UNANIMITY_GIT_SHA1)
+
+ file (STRINGS "${UNY_RootDir}/CHANGELOG.md" UNANIMITY_CHANGELOG)
+
diff --git a/biology/unanimity/files/patch-cmake_uny-gitsha1.cmake b/biology/unanimity/files/patch-cmake_uny-gitsha1.cmake
new file mode 100644
index 000000000000..0ebc1a0afcf2
--- /dev/null
+++ b/biology/unanimity/files/patch-cmake_uny-gitsha1.cmake
@@ -0,0 +1,11 @@
+--- cmake/uny-gitsha1.cmake.orig 2018-03-07 23:10:34 UTC
++++ cmake/uny-gitsha1.cmake
+@@ -7,7 +7,7 @@ set(__find_git_sha1 YES)
+ function(find_git_sha1 _GIT_SHA1)
+ find_package(Git QUIET REQUIRED)
+ execute_process(COMMAND
+- "${GIT_EXECUTABLE}" "describe" "--always" "--dirty=-dirty"
++ echo 6f11a13e1472b8c00337ba8c5e94bf83bdab31d6
+ WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}"
+ RESULT_VARIABLE res
+ OUTPUT_VARIABLE out
diff --git a/biology/unanimity/files/patch-include_pacbio_genomicconsensus_Input.h b/biology/unanimity/files/patch-include_pacbio_genomicconsensus_Input.h
new file mode 100644
index 000000000000..89e43e082aff
--- /dev/null
+++ b/biology/unanimity/files/patch-include_pacbio_genomicconsensus_Input.h
@@ -0,0 +1,16 @@
+--- include/pacbio/genomicconsensus/Input.h.orig 2018-03-07 23:10:34 UTC
++++ include/pacbio/genomicconsensus/Input.h
+@@ -25,7 +25,12 @@ namespace GenomicConsensus {
+ class Input
+ {
+ public:
+- explicit Input(const Settings& settings) : settings_{settings} {}
++ // Original
++ //explicit Input(const Settings& settings) : settings_{settings} {}
++ // Probably OK
++ //explicit Input(const Settings& settings) { settings_ = settings; }
++ // https://forums.freebsd.org/threads/compile-error-with-clang-3-4.65595/#post-385293
++ explicit Input(const Settings& settings) : settings_(settings) {}
+
+ Input() = delete;
+ Input(const Input&) = delete;
diff --git a/biology/unanimity/files/patch-include_pacbio_genomicconsensus_Output.h b/biology/unanimity/files/patch-include_pacbio_genomicconsensus_Output.h
new file mode 100644
index 000000000000..b17a496397aa
--- /dev/null
+++ b/biology/unanimity/files/patch-include_pacbio_genomicconsensus_Output.h
@@ -0,0 +1,19 @@
+--- include/pacbio/genomicconsensus/Output.h.orig 2018-03-07 23:10:34 UTC
++++ include/pacbio/genomicconsensus/Output.h
+@@ -80,8 +80,15 @@ inline void PrintVcfLite(const Variant&
+ << "\tPASS\n";
+ }
+
+-inline Output::Output(const Settings& settings) : settings_{settings}
++// Original
++//inline Output::Output(const Settings& settings) : settings_{settings}
++// Probably OK patch
++//inline Output::Output(const Settings& settings)
++// https://forums.freebsd.org/threads/compile-error-with-clang-3-4.65595/#post-385293
++inline Output::Output(const Settings& settings) : settings_(settings)
+ {
++ // Probably OK patch
++ //settings_ = settings;
+ // initialize maps
+ PacBio::BAM::FastaSequenceQuery fasta{settings_.referenceFilename};
+ for (const auto& seq : fasta) {
diff --git a/biology/unanimity/files/patch-src_CMakeLists.txt b/biology/unanimity/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..b15b0949b992
--- /dev/null
+++ b/biology/unanimity/files/patch-src_CMakeLists.txt
@@ -0,0 +1,15 @@
+--- src/CMakeLists.txt.orig 2018-03-07 23:10:34 UTC
++++ src/CMakeLists.txt
+@@ -53,11 +53,11 @@ configure_file(
+
+ # includes
+ set(UNY_INCLUDE_DIRS
++ ${SEQAN_INCLUDE_DIRS}
+ ${UNY_IncludeDir}
+ ${CMAKE_BINARY_DIR}/generated
+ ${Boost_INCLUDE_DIRS}
+ ${HTSLIB_INCLUDE_DIRS}
+- ${SEQAN_INCLUDE_DIRS}
+ ${CPPOPTPARSE_IncludeDir}
+ ${PacBioBAM_INCLUDE_DIRS}
+ ${pbcopper_INCLUDE_DIRS}
diff --git a/biology/unanimity/files/patch-src_Recursor.h b/biology/unanimity/files/patch-src_Recursor.h
new file mode 100644
index 000000000000..4c880356c882
--- /dev/null
+++ b/biology/unanimity/files/patch-src_Recursor.h
@@ -0,0 +1,12 @@
+# Type mismatch on 11.0 i386
+--- src/Recursor.h.orig 2018-03-07 23:10:34 UTC
++++ src/Recursor.h
+@@ -708,7 +708,7 @@ size_t Recursor<Derived>::FillAlphaBeta(
+ size_t J = tpl.Length();
+ int flipflops = 0;
+ size_t maxSize =
+- std::max(100ul, static_cast<size_t>(0.5 + REBANDING_THRESHOLD * (I + 1) * (J + 1)));
++ std::max(100ul, static_cast<unsigned long>(0.5 + REBANDING_THRESHOLD * (I + 1) * (J + 1)));
+
+ // if we use too much space, do at least one more round
+ // to take advantage of rebanding
diff --git a/biology/unanimity/pkg-descr b/biology/unanimity/pkg-descr
new file mode 100644
index 000000000000..fa2abdd88c6f
--- /dev/null
+++ b/biology/unanimity/pkg-descr
@@ -0,0 +1,8 @@
+Unanimity is a C++ library + applications to generate and process accurate
+consensus sequences from Pacific Biosciences sequence data.
+
+The core binary, CCS (circular consensus calling) takes multiple reads of the
+same SMRTbell sequence and combines them, employing a statistical model, to
+produce one high quality consensus sequence.
+
+WWW: https://github.com/PacificBiosciences/unanimity