aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /biology
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadports-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=488341
Diffstat (limited to 'biology')
-rw-r--r--biology/avida/Makefile2
-rw-r--r--biology/bamtools/Makefile2
-rw-r--r--biology/diamond/Makefile2
-rw-r--r--biology/hyphy/Makefile2
-rw-r--r--biology/iqtree/Makefile2
-rw-r--r--biology/libsbml/Makefile2
-rw-r--r--biology/seqan-apps/Makefile2
-rw-r--r--biology/unanimity/Makefile2
8 files changed, 8 insertions, 8 deletions
diff --git a/biology/avida/Makefile b/biology/avida/Makefile
index f68e54a6b9d3..9a549c532fc7 100644
--- a/biology/avida/Makefile
+++ b/biology/avida/Makefile
@@ -20,7 +20,7 @@ BROKEN_mips64= invokes x86 assembler
BROKEN_sparc64= missing atomics implementation
BROKEN_powerpc64= fails to compile: sibling call optimization does not allow automatic multiple TOCs
-USES= cmake:outsource ncurses
+USES= cmake ncurses
USE_CXXSTD= gnu++98
CMAKE_ARGS= -DAPTO_UNIT_TESTS:BOOL=OFF \
-DAVD_UNIT_TESTS:BOOL=OFF \
diff --git a/biology/bamtools/Makefile b/biology/bamtools/Makefile
index 02f454bb79b2..ae18f4c0ae1b 100644
--- a/biology/bamtools/Makefile
+++ b/biology/bamtools/Makefile
@@ -12,7 +12,7 @@ LICENSE= MIT
LIB_DEPENDS+= libjsoncpp.so:devel/jsoncpp
-USES= cmake:outsource
+USES= cmake
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= pezmaster31
diff --git a/biology/diamond/Makefile b/biology/diamond/Makefile
index ae5b5ef753d5..7c2313831d8c 100644
--- a/biology/diamond/Makefile
+++ b/biology/diamond/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
ONLY_FOR_ARCHS= amd64
-USES= cmake:outsource
+USES= cmake
USE_GITHUB= yes
GH_ACCOUNT= bbuchfink
diff --git a/biology/hyphy/Makefile b/biology/hyphy/Makefile
index 929337990983..cdd5437dca2a 100644
--- a/biology/hyphy/Makefile
+++ b/biology/hyphy/Makefile
@@ -16,7 +16,7 @@ ONLY_FOR_ARCHS= amd64 i386
LIB_DEPENDS= libcurl.so:ftp/curl
-USES= compiler:c++14-lang cmake:outsource localbase:ldflags ssl
+USES= compiler:c++14-lang cmake localbase:ldflags ssl
USE_GITHUB= yes
GH_ACCOUNT= veg
diff --git a/biology/iqtree/Makefile b/biology/iqtree/Makefile
index 0dc1ee7e86d3..bfd89f04639d 100644
--- a/biology/iqtree/Makefile
+++ b/biology/iqtree/Makefile
@@ -16,7 +16,7 @@ BROKEN_armv6= fails to compile: unrecognized command line options '-m32' and '-
BROKEN_armv7= fails to compile: unrecognized command line options '-m32' and '-msse3'
BROKEN_powerpc64= fails to build: GCC version must be at least 4.8!
-USES= cmake compiler:openmp eigen:3
+USES= cmake:insource compiler:openmp eigen:3
USE_GITHUB= yes
GH_ACCOUNT= Cibiv
GH_PROJECT= IQ-TREE
diff --git a/biology/libsbml/Makefile b/biology/libsbml/Makefile
index 947c7afe0708..cb5d73912b8b 100644
--- a/biology/libsbml/Makefile
+++ b/biology/libsbml/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING.txt
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= cmake:outsource iconv:build
+USES= cmake iconv:build
USE_CXXSTD= c++98
USE_GNOME= libxml2
USE_LDCONFIG= yes
diff --git a/biology/seqan-apps/Makefile b/biology/seqan-apps/Makefile
index f516828857c7..fc557b6d35ec 100644
--- a/biology/seqan-apps/Makefile
+++ b/biology/seqan-apps/Makefile
@@ -15,7 +15,7 @@ LICENSE_COMB= multi
BUILD_DEPENDS= boost-libs>0:devel/boost-libs
-USES= cmake:outsource compiler:openmp # once #199603 is resolved, add c++14-lang
+USES= cmake compiler:openmp # once #199603 is resolved, add c++14-lang
USE_GITHUB= yes
GH_ACCOUNT= seqan
GH_PROJECT= seqan
diff --git a/biology/unanimity/Makefile b/biology/unanimity/Makefile
index 455e46550ab5..5719e1b5ab28 100644
--- a/biology/unanimity/Makefile
+++ b/biology/unanimity/Makefile
@@ -21,7 +21,7 @@ BUILD_DEPENDS= pbseqan>=g20171002:biology/pbseqan \
LIB_DEPENDS= libhts.so:biology/htslib \
libboost_regex.so:devel/boost-libs
-USES= cmake compiler:c++14-lang pkgconfig python
+USES= cmake:insource compiler:c++14-lang pkgconfig python
USE_GITHUB= yes
GH_ACCOUNT= PacificBiosciences