aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-07-26 05:43:48 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-07-26 06:20:26 +0000
commit8221f161dcf785939e3766a00ab19caba308386d (patch)
tree7ea27e300e46ce1ffa49d64c51b07c9a1f004227 /biology
parent5ad8fdc333eab0540ab38a925fee17868de68b64 (diff)
downloadports-8221f161dcf785939e3766a00ab19caba308386d.tar.gz
ports-8221f161dcf785939e3766a00ab19caba308386d.zip
biology/py-python-libsbml: Parallelize build
Diffstat (limited to 'biology')
-rw-r--r--biology/py-python-libsbml/Makefile1
-rw-r--r--biology/py-python-libsbml/files/patch-setup.py22
2 files changed, 23 insertions, 0 deletions
diff --git a/biology/py-python-libsbml/Makefile b/biology/py-python-libsbml/Makefile
index 11c225fd511b..d54f69ade095 100644
--- a/biology/py-python-libsbml/Makefile
+++ b/biology/py-python-libsbml/Makefile
@@ -16,6 +16,7 @@ BUILD_DEPENDS= cmake:devel/cmake-core \
USES= python:3.8-3.9
USE_PYTHON= autoplist distutils # autoplist produces incomplete plist, missing files are in pkg-plist. Reported to the upstream author fbergman@caltech.edu on 2021-08-17
+MAKE_ENV= FREEBSD_MAKE_JOBS=${_MAKE_JOBS}
post-install:
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/libsbml/_libsbml*.so
diff --git a/biology/py-python-libsbml/files/patch-setup.py b/biology/py-python-libsbml/files/patch-setup.py
new file mode 100644
index 000000000000..17bdf70eb9ed
--- /dev/null
+++ b/biology/py-python-libsbml/files/patch-setup.py
@@ -0,0 +1,22 @@
+- workaround for https://github.com/sbmlteam/python-libsbml/issues/36
+
+--- setup.py.orig 2023-05-25 10:49:17 UTC
++++ setup.py
+@@ -248,7 +248,7 @@ class CMakeBuild(build_ext):
+ '-DWITH_LIBXML=OFF',
+ ]
+ )
+- self.spawn(['cmake', '--build', '.', '--target', 'install'] + build_args)
++ self.spawn(['cmake', '--build', '.', '-j', os.getenv('FREEBSD_MAKE_JOBS'), '--target', 'install'] + build_args)
+ os.chdir(cwd)
+ DEP_DIR = dep_inst_dir
+
+@@ -297,7 +297,7 @@ class CMakeBuild(build_ext):
+ os.chdir(build_temp)
+ self.spawn(['cmake', SRC_DIR] + cmake_args)
+ if not self.dry_run:
+- self.spawn(['cmake', '--build', '.', '--target', 'binding_python_lib'] + build_args)
++ self.spawn(['cmake', '--build', '.', '-j', os.getenv('FREEBSD_MAKE_JOBS'), '--target', 'binding_python_lib'] + build_args)
+
+ # at this point the build should be complete, and we have all the files
+ # neeed in the temp build_folder