aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-18 05:33:25 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-18 06:57:12 +0000
commita5b5a22ade5713b3b2f9bddcb6fa95fe4aa51b9c (patch)
tree5de7e2e39a7ec2e833c5ae763354be45e7f1c51b /biology
parentf38937674201a98755d450b3b4d04607762bd863 (diff)
downloadports-a5b5a22ade5713b3b2f9bddcb6fa95fe4aa51b9c.tar.gz
ports-a5b5a22ade5713b3b2f9bddcb6fa95fe4aa51b9c.zip
biology/mothur: Fix build on 14
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'biology')
-rw-r--r--biology/mothur/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/biology/mothur/Makefile b/biology/mothur/Makefile
index 8c2bde5c481e..2d16bf482f08 100644
--- a/biology/mothur/Makefile
+++ b/biology/mothur/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= bash:shells/bash
USES= compiler:c++11-lang gmake localbase readline
USE_GITHUB= yes
-USE_CXXSTD= c++11 # not all C++ files are compiled with -std=c++11 which causes failure in addtargets2.cpp due to a collision of the 'byte' symbol with std::byte
+#USE_CXXSTD= c++11 # not all C++ files are compiled with -std=c++11 which causes failure in addtargets2.cpp due to a collision of the 'byte' symbol with std::byte
MAKE_ARGS= INSTALL_DIR=${STAGEDIR}${PREFIX}/bin
@@ -24,6 +24,15 @@ BINARY_ALIAS= g++=${CXX}
PLIST_FILES= bin/${PORTNAME}
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+USES+= llvm:max=15
+CC= clang${LLVM_VERSION}
+CPP= clang-cpp${LLVM_VERSION}
+CXX= clang++${LLVM_VERSION}
+.endif
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}