aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-13 17:07:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-13 17:08:56 +0000
commitcea0bdfd08136dacc2aa9f14aa340718acca4cb2 (patch)
tree47036f4f4ac4ce2ed87c81f830c9e7dd89529ff6 /biology
parentf144df14bfe776cfb1c3dd510a3721df03fb3836 (diff)
downloadports-cea0bdfd08136dacc2aa9f14aa340718acca4cb2.tar.gz
ports-cea0bdfd08136dacc2aa9f14aa340718acca4cb2.zip
biology/seqan3: Add the 'test' target (currently broken due to lacking clang support)
Diffstat (limited to 'biology')
-rw-r--r--biology/seqan3/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/biology/seqan3/Makefile b/biology/seqan3/Makefile
index d731c45f36af..c4a9e6453274 100644
--- a/biology/seqan3/Makefile
+++ b/biology/seqan3/Makefile
@@ -20,9 +20,17 @@ USE_GITHUB= yes
GH_ACCOUNT= seqan
GH_TUPLE= xxsds:sdsl-lite:9a0d567:sdsl_lite/submodules/sdsl-lite
+TEST_WRKSRC= ${WRKSRC}/.test
+
NO_ARCH= yes
post-install:
@${RM} -r ${STAGEDIR}${DOCSDIR}
+do-test: # fail: https://github.com/seqan/seqan3/issues/2643
+ @${MKDIR} ${TEST_WRKSRC} && cd ${TEST_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} ${WRKSRC}/test/unit && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ctest
+
.include <bsd.port.mk>