aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2018-10-23 12:51:20 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2018-10-23 12:51:20 +0000
commitd201617835c8980e81a1077aa902097b996f447e (patch)
tree13ea95f14aa33bb1165ee7bc0d5f51658fcf8c7a /biology
parentd73ac6dfb6c97152ea50872a58226298cd66999d (diff)
downloadports-d201617835c8980e81a1077aa902097b996f447e.tar.gz
ports-d201617835c8980e81a1077aa902097b996f447e.zip
biology/p5-transdecoder: Upgrade to 5.4.0
Minor clean up to silence portlint Approved by: jrm (mentor, implicit)
Notes
Notes: svn path=/head/; revision=482836
Diffstat (limited to 'biology')
-rw-r--r--biology/p5-transdecoder/Makefile25
-rw-r--r--biology/p5-transdecoder/distinfo5
-rw-r--r--biology/p5-transdecoder/pkg-descr8
-rw-r--r--biology/p5-transdecoder/pkg-plist36
4 files changed, 44 insertions, 30 deletions
diff --git a/biology/p5-transdecoder/Makefile b/biology/p5-transdecoder/Makefile
index 244f4b7b8bae..f5a7bc62e9dc 100644
--- a/biology/p5-transdecoder/Makefile
+++ b/biology/p5-transdecoder/Makefile
@@ -1,9 +1,8 @@
# $FreeBSD$
PORTNAME= transdecoder
-PORTVERSION= 2.1.0
-PORTREVISION= 1
-DISTVERSIONPREFIX=v
+DISTVERSIONPREFIX= TransDecoder-v
+DISTVERSION= 5.4.0
CATEGORIES= biology perl5
PKGNAMEPREFIX= p5-
@@ -15,31 +14,35 @@ LICENSE= BSD3CLAUSE
RUN_DEPENDS= cd-hit>=4.6.1:biology/cd-hit \
p5-URI>0:net/p5-URI
-NO_BUILD= yes
-NO_ARCH= yes
USES= perl5 shebangfix
+USE_GITHUB= yes
+
+GH_PROJECT= TransDecoder
SHEBANG_FILES= sample_data/cufflinks_example/runMe.sh \
sample_data/pasa_example/runMe.sh \
sample_data/simple_transcriptome_target/runMe.sh \
util/pfam_mpi.pbs
-USE_GITHUB= yes
-GH_PROJECT= TransDecoder
+NO_BUILD= yes
+NO_ARCH= yes
PERL_MOD_DIR= ${PREFIX}/${SITE_PERL_REL}/${PORTNAME}
PERL_UTIL_DIR= ${PREFIX}/libexec/${PORTNAME}
+SCRIPTS= ${WRKSRC}/TransDecoder.LongOrfs \
+ ${WRKSRC}/TransDecoder.Predict
post-patch:
- ${REINPLACE_CMD} \
+ @${REINPLACE_CMD} \
-e 's|$$FindBin::RealBin/PerlLib|${PERL_MOD_DIR}|g' \
-e 's|$$FindBin::Bin/../PerlLib|${PERL_MOD_DIR}|g' \
-e 's|$$FindBin::RealBin/util|${PERL_UTIL_DIR}|g' \
- ${WRKSRC}/TransDecoder* ${WRKSRC}/util/*.pl
+ ${SCRIPTS} \
+ ${WRKSRC}/util/*.pl
do-install:
- ${MKDIR} ${STAGEDIR}${PERL_MOD_DIR} ${STAGEDIR}${PERL_UTIL_DIR}
+ @${MKDIR} ${STAGEDIR}${PERL_MOD_DIR} ${STAGEDIR}${PERL_UTIL_DIR}
${INSTALL_SCRIPT} ${WRKSRC}/PerlLib/* ${STAGEDIR}${PERL_MOD_DIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/TransDecoder* ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${SCRIPTS} ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/util/*.pl ${STAGEDIR}${PERL_UTIL_DIR}
.include <bsd.port.mk>
diff --git a/biology/p5-transdecoder/distinfo b/biology/p5-transdecoder/distinfo
index bf42546af4c0..fdf185b1cb55 100644
--- a/biology/p5-transdecoder/distinfo
+++ b/biology/p5-transdecoder/distinfo
@@ -1,2 +1,3 @@
-SHA256 (transdecoder-TransDecoder-v2.1.0_GH0.tar.gz) = 681a8dd72e482cb322d74d8431ddcda61f25c53ad5453d0e22c02c92b2157b24
-SIZE (transdecoder-TransDecoder-v2.1.0_GH0.tar.gz) = 11500688
+TIMESTAMP = 1540225907
+SHA256 (transdecoder-TransDecoder-TransDecoder-v5.4.0_GH0.tar.gz) = a6fa776c6eac30922632df1a5362b7564bfcb05728daeb53d0c2c3a9dc899df5
+SIZE (transdecoder-TransDecoder-TransDecoder-v5.4.0_GH0.tar.gz) = 15748557
diff --git a/biology/p5-transdecoder/pkg-descr b/biology/p5-transdecoder/pkg-descr
index 7cb7ca555079..a3ad8cc244d6 100644
--- a/biology/p5-transdecoder/pkg-descr
+++ b/biology/p5-transdecoder/pkg-descr
@@ -1,6 +1,6 @@
-TransDecoder identifies candidate coding regions within transcript
-sequences, such as those generated by de novo RNA-Seq transcript
-assembly using Trinity, or constructed based on RNA-Seq alignments
-to the genome using Tophat and Cufflinks.
+TransDecoder identifies candidate coding regions within transcript sequences,
+such as those generated by de novo RNA-Seq transcript assembly using Trinity,
+or constructed based on RNA-Seq alignments to the genome using Tophat and
+Cufflinks.
WWW: http://transdecoder.github.io/
diff --git a/biology/p5-transdecoder/pkg-plist b/biology/p5-transdecoder/pkg-plist
index d394d7fa2914..8ec718231222 100644
--- a/biology/p5-transdecoder/pkg-plist
+++ b/biology/p5-transdecoder/pkg-plist
@@ -1,22 +1,23 @@
bin/TransDecoder.LongOrfs
-bin/TransDecoder.LongOrfs.bak
bin/TransDecoder.Predict
-bin/TransDecoder.Predict.bak
+%%SITE_PERL%%/transdecoder/DelimParser.pm
%%SITE_PERL%%/transdecoder/Fasta_reader.pm
%%SITE_PERL%%/transdecoder/Fasta_retriever.pm
-%%SITE_PERL%%/transdecoder/GFF3_utils.pm
+%%SITE_PERL%%/transdecoder/GFF3_utils2.pm
+%%SITE_PERL%%/transdecoder/GTF.pm
+%%SITE_PERL%%/transdecoder/GTF_utils2.pm
%%SITE_PERL%%/transdecoder/Gene_obj.pm
-%%SITE_PERL%%/transdecoder/Gene_obj_indexer.pm
%%SITE_PERL%%/transdecoder/Longest_orf.pm
%%SITE_PERL%%/transdecoder/Nuc_translator.pm
-%%SITE_PERL%%/transdecoder/TiedHash.pm
+%%SITE_PERL%%/transdecoder/Overlap_piler.pm
+%%SITE_PERL%%/transdecoder/PWM.pm
+%%SITE_PERL%%/transdecoder/Pipeliner.pm
+%%SITE_PERL%%/transdecoder/Process_cmd.pm
+%%SITE_PERL%%/transdecoder/overlapping_nucs.ph
libexec/transdecoder/cdna_alignment_orf_to_genome_orf.pl
libexec/transdecoder/compute_base_probs.pl
-libexec/transdecoder/create_start_PSSM.pl
-libexec/transdecoder/cufflinks_gtf_genome_to_cdna_fasta.pl
-libexec/transdecoder/cufflinks_gtf_to_alignment_gff3.pl
-libexec/transdecoder/cufflinks_gtf_to_bed.pl
-libexec/transdecoder/extract_FL_subset.pl
+libexec/transdecoder/exclude_similar_proteins.pl
+libexec/transdecoder/fasta_prot_checker.pl
libexec/transdecoder/ffindex_resume.pl
libexec/transdecoder/gene_list_to_gff.pl
libexec/transdecoder/get_FL_accs.pl
@@ -24,9 +25,18 @@ libexec/transdecoder/get_longest_ORF_per_transcript.pl
libexec/transdecoder/get_top_longest_fasta_entries.pl
libexec/transdecoder/gff3_file_to_bed.pl
libexec/transdecoder/gff3_file_to_proteins.pl
-libexec/transdecoder/index_gff3_files_by_isoform.pl
+libexec/transdecoder/gff3_gene_to_gtf_format.pl
+libexec/transdecoder/gtf_genome_to_cdna_fasta.pl
+libexec/transdecoder/gtf_to_alignment_gff3.pl
+libexec/transdecoder/gtf_to_bed.pl
libexec/transdecoder/nr_ORFs_gff3.pl
libexec/transdecoder/pfam_runner.pl
+libexec/transdecoder/refine_gff3_group_iso_strip_utrs.pl
+libexec/transdecoder/refine_hexamer_scores.pl
libexec/transdecoder/remove_eclipsed_ORFs.pl
-libexec/transdecoder/score_CDS_liklihood_all_6_frames.pl
-libexec/transdecoder/seq_n_baseprobs_to_logliklihood_vals.pl
+libexec/transdecoder/score_CDS_likelihood_all_6_frames.pl
+libexec/transdecoder/select_best_ORFs_per_transcript.pl
+libexec/transdecoder/seq_n_baseprobs_to_loglikelihood_vals.pl
+libexec/transdecoder/start_codon_refinement.pl
+libexec/transdecoder/train_start_PWM.pl
+libexec/transdecoder/uri_unescape.pl