aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-07-19 11:04:13 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-07-19 11:04:13 +0000
commitf899c758a653ca8ff2f8a63aafcb2519a0b524ed (patch)
treebe6eebf3e77ddf9fcf383081091d8b8b336dd71c /biology
parent74d26774f830684ae21247061aa4bd7dabbe6527 (diff)
downloadports-f899c758a653ca8ff2f8a63aafcb2519a0b524ed.tar.gz
ports-f899c758a653ca8ff2f8a63aafcb2519a0b524ed.zip
When there is a do-install target, do not use a post-install target, do
everything at once. Sometime, rename post-install into a options helper target. I did not fix ports that were such a mess that I could not figure out what they really wanted to do. I also did not change ports that had some version of an auto-plist code in post-install, for the same reason. With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=418767
Diffstat (limited to 'biology')
-rw-r--r--biology/biojava/Makefile1
-rw-r--r--biology/recombine/Makefile2
-rw-r--r--biology/seqan1/Makefile6
3 files changed, 5 insertions, 4 deletions
diff --git a/biology/biojava/Makefile b/biology/biojava/Makefile
index 45d22d8cb547..de1403f37d33 100644
--- a/biology/biojava/Makefile
+++ b/biology/biojava/Makefile
@@ -51,7 +51,6 @@ do-install:
@(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} demos ${STAGEDIR}${EXAMPLESDIR})
@${ECHO_MSG} " [ DONE ]"
-post-install:
.if !defined(BATCH)
@${ECHO_MSG} ""
@${ECHO_MSG} "Libraries installed at: ${JAVAJARDIR}"
diff --git a/biology/recombine/Makefile b/biology/recombine/Makefile
index 7889cad023b0..0cb9d919acf6 100644
--- a/biology/recombine/Makefile
+++ b/biology/recombine/Makefile
@@ -26,7 +26,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/filetran ${STAGEDIR}${PREFIX}/bin
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/recombine.txt ${STAGEDIR}${DOCSDIR}
diff --git a/biology/seqan1/Makefile b/biology/seqan1/Makefile
index d5222cac07b2..a256864ec0d9 100644
--- a/biology/seqan1/Makefile
+++ b/biology/seqan1/Makefile
@@ -3,7 +3,7 @@
PORTNAME= seqan
PORTVERSION= 1.3.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= biology
MASTER_SITES= http://ftp.seqan.de/releases/
PKGNAMESUFFIX= 1
@@ -19,12 +19,14 @@ NO_BUILD= yes
CONFLICTS= seqan-[2-9]*
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}/${PREFIX}/include/${PORTNAME}
cd ${WRKSRC} && ${COPYTREE_SHARE} ./${PORTNAME} ${STAGEDIR}/${PREFIX}/include
cd ${WRKSRC} && ${INSTALL_DATA} ./${PORTNAME}.h ${STAGEDIR}/${PREFIX}/include
-post-install:
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/docs && ${COPYTREE_SHARE} ./ ${STAGEDIR}${DOCSDIR}