aboutsummaryrefslogtreecommitdiff
path: root/comms/smstools3/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-09-26 09:09:28 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-09-26 09:09:28 +0000
commitc1234587fdb35f66cf756111a78de6653ec3a5a8 (patch)
treed9d1d3586c86693259a0f9839ffcd7c6c6665195 /comms/smstools3/Makefile
parentd4b92a5124e0dc0f948a82959c6f863a586e1868 (diff)
downloadports-c1234587fdb35f66cf756111a78de6653ec3a5a8.tar.gz
ports-c1234587fdb35f66cf756111a78de6653ec3a5a8.zip
Convert to OptionsNG
Notes
Notes: svn path=/head/; revision=304889
Diffstat (limited to 'comms/smstools3/Makefile')
-rw-r--r--comms/smstools3/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/comms/smstools3/Makefile b/comms/smstools3/Makefile
index a1f4a7018ba8..4387c7ace094 100644
--- a/comms/smstools3/Makefile
+++ b/comms/smstools3/Makefile
@@ -15,7 +15,10 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= SMS Gateway software for GSM modems and mobile phones
CONFLICTS= gnokii-[0-9]* smstools-2.* sendsms-[0-9]*
-OPTIONS= STATS "Build status and statistics support" on
+
+OPTIONS_DEFINE= STATS EXAMPLES DOCS
+OPTIONS_DEFAULT= STATS
+STATS_DESC= Build status and statistics support
WRKSRC= ${WRKDIR}/smstools3
@@ -40,7 +43,7 @@ PORTEXAMPLES= .procmailrc .qmailrc *
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_STATS)
+.if ${PORT_OPTIONS:MSTATS}
LIB_DEPENDS+= mm.14:${PORTSDIR}/devel/mm
CFLAGS+= -I${LOCALBASE}/include
.else
@@ -76,12 +79,12 @@ post-install:
fi
@${MKDIR} ${SPOOLDIR} ${LOGDIR} ${PIDDIR}
@${CHOWN} -R ${SMSD_USER}:${SMSD_GROUP} ${SPOOLDIR} ${LOGDIR} ${PIDDIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}/slideshow
@${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}/
@${INSTALL_DATA} ${WRKSRC}/doc/slideshow/* ${DOCSDIR}/slideshow
.endif
-.if !defined(NOPORTEXAMPLES)
+,if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@for file in `${FIND} ${WRKSRC}/examples -type f ! -name 'README'`; do \
${INSTALL_SCRIPT} $$file ${EXAMPLESDIR}/; \