aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2020-12-24 06:48:48 +0000
committerMark Linimon <linimon@FreeBSD.org>2020-12-24 06:48:48 +0000
commit60e81bab1848e7ba4fb8d140d29a29e2e028b76c (patch)
treecb7e3d3a8fd94537de4708f1f0b98f0530f766b2 /databases
parent6f4a8b2d6df9b3830bf0ba2e90fbe77c294f2f7b (diff)
downloadports-60e81bab1848e7ba4fb8d140d29a29e2e028b76c.tar.gz
ports-60e81bab1848e7ba4fb8d140d29a29e2e028b76c.zip
Use the most recent change from arm to fix build on riscv64.
While here, generalize the arm expression the way we usually do. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=559050
Diffstat (limited to 'databases')
-rw-r--r--databases/libcouchbase/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/databases/libcouchbase/Makefile b/databases/libcouchbase/Makefile
index 626328fee99a..24939460c84e 100644
--- a/databases/libcouchbase/Makefile
+++ b/databases/libcouchbase/Makefile
@@ -11,7 +11,6 @@ COMMENT= Multithreaded noSQL database (client and library)
LICENSE= APACHE20
BROKEN_mips64= fails to link: ld: failed to merge target specific data
-BROKEN_riscv64= fails to build: dt_modtext: libdtrace/common/dt_link.c(947): RISC-V implementation required
LIB_DEPENDS= libevent.so:devel/libevent \
libev.so:devel/libev \
@@ -25,7 +24,7 @@ CMAKE_ARGS= -DLCB_NO_TESTS=1
.include <bsd.port.pre.mk>
-.if ${ARCH} == aarch64 || ${ARCH} == armv6 || ${ARCH} == armv7
+.if ${ARCH} == aarch64 || ${ARCH:Marmv*} || ${ARCH} == riscv64
CMAKE_ARGS+= -DDTRACE:BOOL=FALSE
.endif