aboutsummaryrefslogtreecommitdiff
path: root/devel/R-cran-clipr/Makefile
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2019-07-14 03:24:54 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2019-07-14 03:24:54 +0000
commit6b1de6c019aa4057070d8a439723a38657f651f0 (patch)
tree8402311316bad9ad81f3a63d86f06a569d91879a /devel/R-cran-clipr/Makefile
parent98832d04a8e33f3aeb0fce873b583f6b52389b85 (diff)
downloadports-6b1de6c019aa4057070d8a439723a38657f651f0.tar.gz
ports-6b1de6c019aa4057070d8a439723a38657f651f0.zip
- Add new port: devel/R-cran-clipr
Simple utility functions to read from and write to the Windows, OS X, and X11 clipboards. WWW: https://cran.r-project.org/web/packages/clipr/
Notes
Notes: svn path=/head/; revision=506596
Diffstat (limited to 'devel/R-cran-clipr/Makefile')
-rw-r--r--devel/R-cran-clipr/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/devel/R-cran-clipr/Makefile b/devel/R-cran-clipr/Makefile
new file mode 100644
index 000000000000..2a706ac93662
--- /dev/null
+++ b/devel/R-cran-clipr/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= clipr
+PORTVERSION= 0.6.0
+CATEGORIES= devel
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Read and Write from the System Clipboard
+
+LICENSE= GPLv3
+
+USES= cran:auto-plist
+
+OPTIONS_DEFINE= XCLIP XSEL
+OPTIONS_DEFAULT= XCLIP
+XCLIP_DESC= Use xclip for interacting with X11 clipboard
+XSEL_DESC= Use xsel for interacting with X11 clipboard
+
+XCLIP_RUN_DEPENDS= xclip:x11/xclip
+XSEL_RUN_DEPENDS= xsel:x11/xsel-conrad
+
+.include <bsd.port.mk>