aboutsummaryrefslogtreecommitdiff
path: root/devel/R-cran-cyclocomp/Makefile
diff options
context:
space:
mode:
authorGuangyuan Yang <ygy@FreeBSD.org>2021-12-10 05:03:40 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-12-10 05:03:40 +0000
commit2b059a5078dbc68dba717dd2ddf6bd5235cea34b (patch)
treebe5bf18d298767d2f4ec56d3abda83b0fe6dbe8b /devel/R-cran-cyclocomp/Makefile
parent22d8c1a749a41e926fe47722a3692b28d6e95740 (diff)
downloadports-2b059a5078dbc68dba717dd2ddf6bd5235cea34b.tar.gz
ports-2b059a5078dbc68dba717dd2ddf6bd5235cea34b.zip
devel/R-cran-cyclocomp: New port: Cyclomatic Complexity of R Code
Diffstat (limited to 'devel/R-cran-cyclocomp/Makefile')
-rw-r--r--devel/R-cran-cyclocomp/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/devel/R-cran-cyclocomp/Makefile b/devel/R-cran-cyclocomp/Makefile
new file mode 100644
index 000000000000..8514dea2258c
--- /dev/null
+++ b/devel/R-cran-cyclocomp/Makefile
@@ -0,0 +1,23 @@
+# Created by: Guangyuan Yang <ygy@FreeBSD.org>
+
+PORTNAME= cyclocomp
+DISTVERSION= 1.1.0
+CATEGORIES= devel
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= ygy@FreeBSD.org
+COMMENT= Cyclomatic Complexity of R Code
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= R-cran-callr>0:devel/R-cran-callr \
+ R-cran-crayon>0:devel/R-cran-crayon \
+ R-cran-desc>0:devel/R-cran-desc \
+ R-cran-remotes>0:devel/R-cran-remotes \
+ R-cran-withr>0:devel/R-cran-withr
+TEST_DEPENDS= R-cran-testthat>0:devel/R-cran-testthat
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>