aboutsummaryrefslogtreecommitdiff
path: root/devel/aunit/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-07-22 17:08:18 +0000
committerJohn Marino <marino@FreeBSD.org>2016-07-22 17:08:18 +0000
commit91ca1a1d9754f49d9e42f7bf0b09b20803307afd (patch)
tree8ce57b4df4a1c382ce7f6b0e7840208adb815808 /devel/aunit/Makefile
parent326603990671d3c2578c84fe8767898bc51d11c8 (diff)
downloadports-91ca1a1d9754f49d9e42f7bf0b09b20803307afd.tar.gz
ports-91ca1a1d9754f49d9e42f7bf0b09b20803307afd.zip
Add new port devel/aunit
This is a test dependency of the upcoming AdaID port. There are existing ports that also could use Aunit but they currently work around or skip testing options. === AUnit is a set of Ada packages based on the xUnit family of unit test frameworks. It is intended as a developer's tool to facilitate confident writing and evolution of Ada software. It is purposely lightweight, as one of its main goals is to make it easy to develop and run unit tests, rather than to generate artifacts for process management. The framework supports easy composition of sets of unit tests to provide flexibility in determining what tests to run for a given purpose.
Notes
Notes: svn path=/head/; revision=418924
Diffstat (limited to 'devel/aunit/Makefile')
-rw-r--r--devel/aunit/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/aunit/Makefile b/devel/aunit/Makefile
new file mode 100644
index 000000000000..4e8241049d73
--- /dev/null
+++ b/devel/aunit/Makefile
@@ -0,0 +1,28 @@
+# Created by: John Marino <marino@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= aunit
+PORTVERSION= 2016
+CATEGORIES= devel
+MASTER_SITES= http://downloads.dragonlace.net/src/
+DISTNAME= aunit-gpl-${PORTVERSION}-src
+
+MAINTAINER= marino@FreeBSD.org
+COMMENT= Ada unit testing framework
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= gprbuild:devel/gprbuild
+
+USES= ada gmake
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|LIBDIR|MYLIBDIR|' \
+ ${WRKSRC}/lib/gnat/aunit_shared.gpr
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+post-install:
+ ${RM} -r ${STAGEDIR}${PREFIX}/lib/gnat/manifests
+
+.include <bsd.port.mk>