aboutsummaryrefslogtreecommitdiff
path: root/devel/geany
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-06-11 01:44:15 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-06-11 01:44:15 +0000
commit13fb0b92a29536c74fd1cea5b5e8e7fb8705be98 (patch)
treed21fd4ee60da4c705d6bb2d4d0222a7e7af7ef7b /devel/geany
parent52a39feebd3a360c0a4633697006081ae2024197 (diff)
downloadports-13fb0b92a29536c74fd1cea5b5e8e7fb8705be98.tar.gz
ports-13fb0b92a29536c74fd1cea5b5e8e7fb8705be98.zip
Fix port builds for architectures which remain on gcc as the default compiler.
This will primarily help powerpc64. For archs where clang is the default compiler, these changes will have no effect, as the base compiler already has these capabilities (primarily, but not exclusively, c++-11). Tested for no-harm on amd64. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=472160
Diffstat (limited to 'devel/geany')
-rw-r--r--devel/geany/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/geany/Makefile b/devel/geany/Makefile
index 053b119dfedf..e22fb1c38c0c 100644
--- a/devel/geany/Makefile
+++ b/devel/geany/Makefile
@@ -15,11 +15,11 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
+USES= compiler:c++11-lang desktop-file-utils gettext-tools gmake libtool \
+ localbase pathfix pkgconfig tar:bzip2
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_GNOME= cairo gtk20 intltool
-USES= desktop-file-utils gettext-tools gmake libtool \
- localbase pathfix pkgconfig tar:bzip2
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip