aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-hashed-storage/Makefile
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-05-15 19:06:57 +0000
committerGabor Pali <pgj@FreeBSD.org>2010-05-15 19:06:57 +0000
commita780537845fa39ced0ca9bdb7ebee281283ce8a4 (patch)
tree8ba8549a4281d7a3b65a48593b76102aeeae6453 /devel/hs-hashed-storage/Makefile
parent2611f8c27d7038935bc15354f9e083a23c24f0db (diff)
downloadports-a780537845fa39ced0ca9bdb7ebee281283ce8a4.tar.gz
ports-a780537845fa39ced0ca9bdb7ebee281283ce8a4.zip
Support code for reading and manipulating hashed file storage (where
each file and directory is associated with a cryptographic hash, for corruption-resistant storage and fast comparisons). The supported storage formats include darcs hashed pristine, a plain filesystem tree and an indexed plain tree (where the index maintains hashes of the plain files and directories). WWW: http://hackage.haskell.org/package/hashed-storage
Notes
Notes: svn path=/head/; revision=254365
Diffstat (limited to 'devel/hs-hashed-storage/Makefile')
-rw-r--r--devel/hs-hashed-storage/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/hs-hashed-storage/Makefile b/devel/hs-hashed-storage/Makefile
new file mode 100644
index 000000000000..deff1a5b20b6
--- /dev/null
+++ b/devel/hs-hashed-storage/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: hs-hashed-storage
+# Date created: May 14, 2010
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hashed-storage
+PORTVERSION= 0.5
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Hashed file storage support code
+
+CABAL_SETUP= Setup.hs
+
+USE_HACKAGE= binary dataenc mmap>=0.5 zlib
+
+OPTIONS= TEST "Build tests" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_TEST)
+CONFIGURE_ARGS+= --flags="test"
+EXECUTABLE+= hashed-storage-test
+PLIST_SUB+= MAYBE_TEST=""
+.else
+CONFIGURE_ARGS+= --flags="-test"
+PLIST_SUB+= MAYBE_TEST="@comment "
+.endif
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>