aboutsummaryrefslogtreecommitdiff
path: root/devel/ice
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-06-08 15:10:56 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-06-08 15:10:56 +0000
commitf5bd648d815748e553f84c06e65061079e325a99 (patch)
tree096cf6cac7f86e1776868eef5c01a1edaae3dee5 /devel/ice
parent6fea1151dbaa0ab565f3571235e1cbebe894ac4d (diff)
downloadports-f5bd648d815748e553f84c06e65061079e325a99.tar.gz
ports-f5bd648d815748e553f84c06e65061079e325a99.zip
Add an experimental port of ice, the Internet Communications Engine, a
modern alternative to object middleware such as CORBA. PR: 64136 Submitted by: Stefan Ehmann <shoesoft@gmx.net> Original submission by: Sergey Matveychuk <sem@ciam.ru> Thanks to: flz for reviving the PR
Notes
Notes: svn path=/head/; revision=137064
Diffstat (limited to 'devel/ice')
-rw-r--r--devel/ice/Makefile49
-rw-r--r--devel/ice/distinfo2
-rw-r--r--devel/ice/files/Make.rules.FreeBSD15
-rw-r--r--devel/ice/files/patch-Make.rules51
-rw-r--r--devel/ice/files/patch-Makefile31
-rw-r--r--devel/ice/files/patch-include::IceUtil::Config.h11
-rw-r--r--devel/ice/files/patch-src::icecpp::config.h11
-rw-r--r--devel/ice/pkg-descr5
-rw-r--r--devel/ice/pkg-plist510
9 files changed, 685 insertions, 0 deletions
diff --git a/devel/ice/Makefile b/devel/ice/Makefile
new file mode 100644
index 000000000000..f52013c1c7dc
--- /dev/null
+++ b/devel/ice/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: ice
+# Date created: 2004-02-02
+# Whom: Stefan Ehmann <shoesoft@gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Ice
+PORTVERSION= 2.1.1
+CATEGORIES= devel
+MASTER_SITES= http://www.zeroc.com/download/Ice/2.1/
+
+MAINTAINER= shoesoft@gmx.net
+COMMENT= A modern alternative to object middleware such as CORBA/COM/DCOM/COM+
+
+LIB_DEPENDS= db-4.2.2:${PORTSDIR}/databases/db42 \
+ expat.5:${PORTSDIR}/textproc/expat2
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+
+CFLAGS+= -ftemplate-depth-128 -fPIC -DPIC -Wall -D_REENTRANT ${PTHREAD_CFLAGS}
+.if defined(DEBUG)
+CFLAGS+= -g
+.else
+CFLAGS+= -DNDEBUG
+.endif
+
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500028
+BROKEN= "does not compile on systems prior to 5.x"
+.endif
+
+.if ((${ARCH} != i386) && (${ARCH} != powerpc))
+MAKE_ENV= LP64=yes
+.endif
+
+post-patch:
+ ${SED} 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g; \
+ s|%%PREFIX%%|${PREFIX}|g; \
+ s|%%DATADIR%%|${DATADIR}|g; \
+ s|%%DOCSDIR%%|${DOCSDIR}|g;' \
+ ${FILESDIR}/Make.rules.FreeBSD > ${WRKSRC}/config/Make.rules.FreeBSD
+ ${REINPLACE_CMD} 's|%%INSTALL_PROGRAM%%|${INSTALL_PROGRAM}|g; \
+ s|%%INSTALL_DATA%%|${INSTALL_DATA}|g' ${WRKSRC}/config/Make.rules
+ ${FIND} ${WRKSRC} -name Makefile -exec ${REINPLACE_CMD} 's|-lIceSSL|-lIceSSL -lIceXML|' {} \;
+
+.include <bsd.port.post.mk>
diff --git a/devel/ice/distinfo b/devel/ice/distinfo
new file mode 100644
index 000000000000..bb8cb147a821
--- /dev/null
+++ b/devel/ice/distinfo
@@ -0,0 +1,2 @@
+MD5 (Ice-2.1.1.tar.gz) = ea1fe985db84d3a30582c18b3443e6bd
+SIZE (Ice-2.1.1.tar.gz) = 1644724
diff --git a/devel/ice/files/Make.rules.FreeBSD b/devel/ice/files/Make.rules.FreeBSD
new file mode 100644
index 000000000000..4c61d61235eb
--- /dev/null
+++ b/devel/ice/files/Make.rules.FreeBSD
@@ -0,0 +1,15 @@
+mkshlib = $(CXX) -shared $(LDFLAGS) -o $(1) -Wl,-h,$(2) $(3) $(4)
+
+BASELIBS = -lIceUtil %%PTHREAD_LIBS%%
+LIBS = -lIce $(BASELIBS)
+
+ICEUTIL_OS_LIBS = %%PTHREAD_LIBS%%
+
+PLATFORM_HAS_READLINE := yes
+
+export LD_LIBRARY_PATH := $(libdir):$(LD_LIBRARY_PATH)
+
+lp64suffix =
+prefix = %%PREFIX%%
+install_slicedir = %%DATADIR%%
+install_docdir = %%DOCSDIR%%
diff --git a/devel/ice/files/patch-Make.rules b/devel/ice/files/patch-Make.rules
new file mode 100644
index 000000000000..4b642c902cbd
--- /dev/null
+++ b/devel/ice/files/patch-Make.rules
@@ -0,0 +1,51 @@
+--- config/Make.rules.orig Wed May 26 01:09:19 2004
++++ config/Make.rules Sat May 29 16:02:37 2004
+@@ -12,7 +12,7 @@
+ # if it does not exist.
+ #
+
+-prefix = /opt/Ice-$(VERSION)
++prefix = $(PREFIX)/Ice-$(VERSION)
+
+ #
+ # Define OPTIMIZE as yes if you want to build with
+@@ -91,7 +91,7 @@
+ # directory.
+ #
+
+-#DB_HOME ?= /opt/db
++DB_HOME ?= $(LOCALBASE)
+
+ #
+ # If OpenSSL is not installed in a standard location where the
+@@ -114,7 +114,7 @@
+ # installation directory.
+ #
+
+-#EXPAT_HOME ?= /opt/expat
++EXPAT_HOME ?= $(LOCALBASE)
+
+
+ #
+@@ -152,8 +152,8 @@
+ install_schemadir = $(prefix)/schema
+ install_docdir = $(prefix)/doc
+
+-INSTALL = cp -fp
+-INSTALL_PROGRAM = ${INSTALL}
++INSTALL = %%INSTALL_DATA%%
++INSTALL_PROGRAM = %%INSTALL_PROGRAM%%
+ INSTALL_LIBRARY = ${INSTALL}
+ INSTALL_DATA = ${INSTALL}
+
+@@ -203,8 +203,8 @@
+ endif
+
+ ifneq ($(DB_HOME),)
+- DB_FLAGS = -I$(DB_HOME)/include
+- DB_LIBS = -L$(DB_HOME)/$(libsubdir) -ldb_cxx
++ DB_FLAGS = -I$(DB_HOME)/include/db42
++ DB_LIBS = -L$(DB_HOME)/$(libsubdir) -ldb_cxx-4.2
+ else
+ DB_FLAGS =
+ DB_LIBS = -ldb_cxx
diff --git a/devel/ice/files/patch-Makefile b/devel/ice/files/patch-Makefile
new file mode 100644
index 000000000000..9a28e26957d5
--- /dev/null
+++ b/devel/ice/files/patch-Makefile
@@ -0,0 +1,31 @@
+--- Makefile.orig Fri May 21 16:33:04 2004
++++ Makefile Thu Jul 22 19:46:03 2004
+@@ -49,12 +49,14 @@
+ chmod a+rx $(install_slicedir) ; \
+ fi
+
++ifndef NOPORTDOCS
+ @if test ! -d $(install_docdir) ; \
+ then \
+ echo "Creating $(install_docdir)..." ; \
+ mkdir $(install_docdir) ; \
+ chmod a+rx $(install_docdir) ; \
+ fi
++endif
+
+ $(EVERYTHING)::
+ @for subdir in $(SUBDIRS); \
+@@ -67,9 +69,11 @@
+ @( cd doc && $(MAKE) ) || exit 1
+
+ install::
++ifndef NOPORTDOCS
+ @( cd doc && $(MAKE) install ) || exit 1
+- $(INSTALL) ICE_LICENSE $(prefix)
+- $(INSTALL) LICENSE $(prefix)
++ $(INSTALL) ICE_LICENSE $(install_docdir)
++ $(INSTALL) LICENSE $(install_docdir)
++endif
+
+ clean::
+ @( cd doc && $(MAKE) clean ) || exit 1
diff --git a/devel/ice/files/patch-include::IceUtil::Config.h b/devel/ice/files/patch-include::IceUtil::Config.h
new file mode 100644
index 000000000000..235ee4e818be
--- /dev/null
+++ b/devel/ice/files/patch-include::IceUtil::Config.h
@@ -0,0 +1,11 @@
+--- include/IceUtil/Config.h.orig Thu Jul 22 01:21:08 2004
++++ include/IceUtil/Config.h Tue Jul 27 16:16:48 2004
+@@ -16,7 +16,7 @@
+ // Most CPUs support only one endianness, with the notable exceptions
+ // of Itanium (IA64) and MIPS.
+ //
+-#if defined(__i386) || defined(_M_IX86) || defined (__x86_64)
++#if defined(__i386) || defined(_M_IX86) || defined (__x86_64) || defined(__alpha__)
+ # define ICE_LITTLE_ENDIAN
+ #elif defined(__sparc) || defined(__sparc__) || defined(__hppa) || defined(__ppc__) || defined(_ARCH_COM)
+ # define ICE_BIG_ENDIAN
diff --git a/devel/ice/files/patch-src::icecpp::config.h b/devel/ice/files/patch-src::icecpp::config.h
new file mode 100644
index 000000000000..edc374064fb8
--- /dev/null
+++ b/devel/ice/files/patch-src::icecpp::config.h
@@ -0,0 +1,11 @@
+--- src/icecpp/config.h.orig Wed Feb 16 21:22:23 2005
++++ src/icecpp/config.h Wed Jun 8 12:28:58 2005
+@@ -56,7 +56,7 @@
+ #define LONG_TYPE_SIZE 4
+ #if defined(_WIN32)
+ # define WCHAR_TYPE_SIZE 2
+-#elif (defined(__linux) || defined(__FreeBSD__)) && (defined(__i386) || defined(__x86_64) || defined(__sparc)) \
++#elif (defined(__linux) || defined(__FreeBSD__)) && (defined(__i386) || defined(__x86_64) || defined(__sparc) || defined(__alpha__) || defined(__powerpc__) \
+ || defined (__sun) || defined(__hpux) || defined(__APPLE__) || defined(_AIX)
+ # define WCHAR_TYPE_SIZE 4
+ #else
diff --git a/devel/ice/pkg-descr b/devel/ice/pkg-descr
new file mode 100644
index 000000000000..0987e190e34a
--- /dev/null
+++ b/devel/ice/pkg-descr
@@ -0,0 +1,5 @@
+The Internet Communications Engine (Ice) is a modern alternative to object
+middleware such as CORBA(TM) or COM/DCOM/COM+. Ice is easy to learn, yet
+provides a powerful network infrastructure for demanding technical applications.
+Ice shines where technologies such as SOAP or XML-RPC are too slow, or do not
+provide sufficient scalability or security.
diff --git a/devel/ice/pkg-plist b/devel/ice/pkg-plist
new file mode 100644
index 000000000000..a454464f851e
--- /dev/null
+++ b/devel/ice/pkg-plist
@@ -0,0 +1,510 @@
+bin/dumpdb
+bin/glacier2router
+bin/icebox
+bin/iceboxadmin
+bin/icecpp
+bin/icepackadmin
+bin/icepacknode
+bin/icepackregistry
+bin/icepatch2calc
+bin/icepatch2client
+bin/icepatch2server
+bin/icestormadmin
+bin/slice2cpp
+bin/slice2cs
+bin/slice2docbook
+bin/slice2freeze
+bin/slice2freezej
+bin/slice2java
+bin/slice2py
+bin/slice2vb
+bin/transformdb
+include/Freeze/Catalog.h
+include/Freeze/CatalogData.h
+include/Freeze/Connection.h
+include/Freeze/ConnectionF.h
+include/Freeze/DB.h
+include/Freeze/Evictor.h
+include/Freeze/EvictorF.h
+include/Freeze/EvictorStorage.h
+include/Freeze/Exception.h
+include/Freeze/Freeze.h
+include/Freeze/Index.h
+include/Freeze/Initialize.h
+include/Freeze/Map.h
+include/Freeze/Transaction.h
+include/Freeze/TransactionHolder.h
+include/Glacier2/Glacier2.h
+include/Glacier2/PermissionsVerifier.h
+include/Glacier2/PermissionsVerifierF.h
+include/Glacier2/Router.h
+include/Glacier2/RouterF.h
+include/Glacier2/Session.h
+include/Glacier2/SessionF.h
+include/Ice/Application.h
+include/Ice/BasicStream.h
+include/Ice/Buffer.h
+include/Ice/BuiltinSequences.h
+include/Ice/Communicator.h
+include/Ice/CommunicatorF.h
+include/Ice/Config.h
+include/Ice/Connection.h
+include/Ice/ConnectionF.h
+include/Ice/ConnectionFactoryF.h
+include/Ice/ConnectionIF.h
+include/Ice/ConnectionMonitorF.h
+include/Ice/Current.h
+include/Ice/Direct.h
+include/Ice/DynamicLibrary.h
+include/Ice/DynamicLibraryF.h
+include/Ice/EndpointF.h
+include/Ice/EndpointFactory.h
+include/Ice/EndpointFactoryF.h
+include/Ice/Exception.h
+include/Ice/FacetMap.h
+include/Ice/FactoryTable.h
+include/Ice/FactoryTableDef.h
+include/Ice/Functional.h
+include/Ice/Handle.h
+include/Ice/Ice.h
+include/Ice/Identity.h
+include/Ice/IdentityUtil.h
+include/Ice/Incoming.h
+include/Ice/IncomingAsync.h
+include/Ice/IncomingAsyncF.h
+include/Ice/Initialize.h
+include/Ice/InstanceF.h
+include/Ice/LocalException.h
+include/Ice/LocalObject.h
+include/Ice/LocalObjectF.h
+include/Ice/Locator.h
+include/Ice/LocatorF.h
+include/Ice/Logger.h
+include/Ice/LoggerF.h
+include/Ice/LoggerUtil.h
+include/Ice/Object.h
+include/Ice/ObjectAdapter.h
+include/Ice/ObjectAdapterF.h
+include/Ice/ObjectAdapterFactoryF.h
+include/Ice/ObjectF.h
+include/Ice/ObjectFactory.h
+include/Ice/ObjectFactoryF.h
+include/Ice/Outgoing.h
+include/Ice/OutgoingAsync.h
+include/Ice/OutgoingAsyncF.h
+include/Ice/Plugin.h
+include/Ice/PluginF.h
+include/Ice/Process.h
+include/Ice/ProcessF.h
+include/Ice/Properties.h
+include/Ice/PropertiesF.h
+include/Ice/ProtocolPluginFacade.h
+include/Ice/ProtocolPluginFacadeF.h
+include/Ice/Proxy.h
+include/Ice/ProxyF.h
+include/Ice/ProxyFactoryF.h
+include/Ice/ProxyHandle.h
+include/Ice/ReferenceF.h
+include/Ice/Router.h
+include/Ice/RouterF.h
+include/Ice/RoutingTable.h
+include/Ice/RoutingTableF.h
+include/Ice/ServantLocator.h
+include/Ice/ServantLocatorF.h
+include/Ice/ServantManagerF.h
+include/Ice/Service.h
+include/Ice/SliceChecksumDict.h
+include/Ice/SliceChecksums.h
+include/Ice/Stats.h
+include/Ice/StatsF.h
+include/Ice/Stream.h
+include/Ice/StreamF.h
+include/Ice/UserExceptionFactory.h
+include/Ice/UserExceptionFactoryF.h
+include/IceBox/IceBox.h
+include/IcePack/Admin.h
+include/IcePack/Exception.h
+include/IcePack/Query.h
+include/IcePatch2/ClientUtil.h
+include/IcePatch2/FileInfo.h
+include/IcePatch2/FileServer.h
+include/IcePatch2/Util.h
+include/IceSSL/CertificateVerifier.h
+include/IceSSL/CertificateVerifierF.h
+include/IceSSL/CertificateVerifierOpenSSL.h
+include/IceSSL/Config.h
+include/IceSSL/Exception.h
+include/IceSSL/Plugin.h
+include/IceSSL/PluginF.h
+include/IceSSL/RSACertificateGen.h
+include/IceSSL/RSACertificateGenF.h
+include/IceSSL/RSAKeyPair.h
+include/IceSSL/RSAKeyPairF.h
+include/IceSSL/RSAPrivateKey.h
+include/IceSSL/RSAPrivateKeyF.h
+include/IceSSL/RSAPublicKey.h
+include/IceSSL/RSAPublicKeyF.h
+include/IceStorm/IceStorm.h
+include/IceUtil/AbstractMutex.h
+include/IceUtil/Algorithm.h
+include/IceUtil/Base64.h
+include/IceUtil/Cache.h
+include/IceUtil/Cond.h
+include/IceUtil/Config.h
+include/IceUtil/CountDownLatch.h
+include/IceUtil/CtrlCHandler.h
+include/IceUtil/Exception.h
+include/IceUtil/Functional.h
+include/IceUtil/GC.h
+include/IceUtil/GCRecMutex.h
+include/IceUtil/GCShared.h
+include/IceUtil/Handle.h
+include/IceUtil/IceUtil.h
+include/IceUtil/InputUtil.h
+include/IceUtil/Iterator.h
+include/IceUtil/Lock.h
+include/IceUtil/MD5.h
+include/IceUtil/Monitor.h
+include/IceUtil/Mutex.h
+include/IceUtil/Options.h
+include/IceUtil/OutputUtil.h
+include/IceUtil/RWRecMutex.h
+include/IceUtil/RecMutex.h
+include/IceUtil/Shared.h
+include/IceUtil/StaticMutex.h
+include/IceUtil/StringUtil.h
+include/IceUtil/Thread.h
+include/IceUtil/ThreadException.h
+include/IceUtil/Time.h
+include/IceUtil/UUID.h
+include/IceUtil/Unicode.h
+include/IceXML/Parser.h
+include/Slice/CPlusPlusUtil.h
+include/Slice/Checksum.h
+include/Slice/CsUtil.h
+include/Slice/DotNetNames.h
+include/Slice/JavaUtil.h
+include/Slice/Parser.h
+include/Slice/Preprocessor.h
+include/Slice/PythonUtil.h
+include/Slice/VbUtil.h
+lib/libFreeze.so
+lib/libFreeze.so.2.1.1
+lib/libFreeze.so.21
+lib/libGlacier2.so
+lib/libGlacier2.so.2.1.1
+lib/libGlacier2.so.21
+lib/libIce.so
+lib/libIce.so.2.1.1
+lib/libIce.so.21
+lib/libIceBox.so
+lib/libIceBox.so.2.1.1
+lib/libIceBox.so.21
+lib/libIcePack.so
+lib/libIcePack.so.2.1.1
+lib/libIcePack.so.21
+lib/libIcePatch2.so
+lib/libIcePatch2.so.2.1.1
+lib/libIcePatch2.so.21
+lib/libIceSSL.so
+lib/libIceSSL.so.2.1.1
+lib/libIceSSL.so.21
+lib/libIceStorm.so
+lib/libIceStorm.so.2.1.1
+lib/libIceStorm.so.21
+lib/libIceStormService.so
+lib/libIceStormService.so.2.1.1
+lib/libIceStormService.so.21
+lib/libIceUtil.so
+lib/libIceUtil.so.2.1.1
+lib/libIceUtil.so.21
+lib/libIceXML.so
+lib/libIceXML.so.2.1.1
+lib/libIceXML.so.21
+lib/libSlice.so
+lib/libSlice.so.2.1.1
+lib/libSlice.so.21
+share/Ice/Freeze/CatalogData.ice
+share/Ice/Freeze/Connection.ice
+share/Ice/Freeze/ConnectionF.ice
+share/Ice/Freeze/DB.ice
+share/Ice/Freeze/Evictor.ice
+share/Ice/Freeze/EvictorF.ice
+share/Ice/Freeze/EvictorStorage.ice
+share/Ice/Freeze/Exception.ice
+share/Ice/Freeze/Transaction.ice
+share/Ice/Glacier2/PermissionsVerifier.ice
+share/Ice/Glacier2/PermissionsVerifierF.ice
+share/Ice/Glacier2/Router.ice
+share/Ice/Glacier2/RouterF.ice
+share/Ice/Glacier2/Session.ice
+share/Ice/Glacier2/SessionF.ice
+share/Ice/Ice/BuiltinSequences.ice
+share/Ice/Ice/Communicator.ice
+share/Ice/Ice/CommunicatorF.ice
+share/Ice/Ice/Connection.ice
+share/Ice/Ice/ConnectionF.ice
+share/Ice/Ice/Current.ice
+share/Ice/Ice/FacetMap.ice
+share/Ice/Ice/Identity.ice
+share/Ice/Ice/LocalException.ice
+share/Ice/Ice/Locator.ice
+share/Ice/Ice/LocatorF.ice
+share/Ice/Ice/Logger.ice
+share/Ice/Ice/LoggerF.ice
+share/Ice/Ice/ObjectAdapter.ice
+share/Ice/Ice/ObjectAdapterF.ice
+share/Ice/Ice/ObjectFactory.ice
+share/Ice/Ice/ObjectFactoryF.ice
+share/Ice/Ice/Plugin.ice
+share/Ice/Ice/PluginF.ice
+share/Ice/Ice/Process.ice
+share/Ice/Ice/ProcessF.ice
+share/Ice/Ice/Properties.ice
+share/Ice/Ice/PropertiesF.ice
+share/Ice/Ice/Router.ice
+share/Ice/Ice/RouterF.ice
+share/Ice/Ice/ServantLocator.ice
+share/Ice/Ice/ServantLocatorF.ice
+share/Ice/Ice/SliceChecksumDict.ice
+share/Ice/Ice/Stats.ice
+share/Ice/Ice/StatsF.ice
+share/Ice/IceBox/IceBox.ice
+share/Ice/IcePack/Admin.ice
+share/Ice/IcePack/Exception.ice
+share/Ice/IcePack/Query.ice
+share/Ice/IcePatch2/FileInfo.ice
+share/Ice/IcePatch2/FileServer.ice
+share/Ice/IceSSL/CertificateVerifier.ice
+share/Ice/IceSSL/CertificateVerifierF.ice
+share/Ice/IceSSL/Exception.ice
+share/Ice/IceSSL/Plugin.ice
+share/Ice/IceSSL/PluginF.ice
+share/Ice/IceStorm/IceStorm.ice
+%%PORTDOCS%%%%DOCSDIR%%/ICE_LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/c12907.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/c13.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/c15776.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/index.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/stylesheet-images/caution.gif
+%%PORTDOCS%%%%DOCSDIR%%/reference/stylesheet-images/home.gif
+%%PORTDOCS%%%%DOCSDIR%%/reference/stylesheet-images/important.gif
+%%PORTDOCS%%%%DOCSDIR%%/reference/stylesheet-images/next.gif
+%%PORTDOCS%%%%DOCSDIR%%/reference/stylesheet-images/note.gif
+%%PORTDOCS%%%%DOCSDIR%%/reference/stylesheet-images/prev.gif
+%%PORTDOCS%%%%DOCSDIR%%/reference/stylesheet-images/tip.gif
+%%PORTDOCS%%%%DOCSDIR%%/reference/stylesheet-images/toc-blank.gif
+%%PORTDOCS%%%%DOCSDIR%%/reference/stylesheet-images/toc-minus.gif
+%%PORTDOCS%%%%DOCSDIR%%/reference/stylesheet-images/toc-plus.gif
+%%PORTDOCS%%%%DOCSDIR%%/reference/stylesheet-images/up.gif
+%%PORTDOCS%%%%DOCSDIR%%/reference/stylesheet-images/warning.gif
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1002.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10125.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1014.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10173.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1022.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1030.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10309.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10317.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10407.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10443.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10621.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10644.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10655.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10666.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1067.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10676.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10686.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10696.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10706.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10767.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10777.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10793.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10807.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10844.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10854.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10865.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x10956.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1096.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1108.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1120.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1128.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11306.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11323.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11334.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11344.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11354.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11374.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11424.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11435.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11447.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11521.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11548.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11581.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11612.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11664.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11774.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11812.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11874.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x11889.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12030.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12054.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12112.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12136.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12160.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12410.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12434.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12564.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12661.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12688.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12713.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12771.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12897.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x12949.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13057.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13128.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13300.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13330.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13388.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13483.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x13767.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14058.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14210.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x14799.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15061.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15421.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15675.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x15880.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1925.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1942.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1970.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x1983.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2002.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2014.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2208.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2220.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2232.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2244.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2256.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2380.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2421.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2433.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2445.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2469.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2479.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2498.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2661.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2685.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2710.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2722.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2734.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2758.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2866.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x2972.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x3099.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x3152.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x3164.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x3176.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x3200.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x3244.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x3281.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4368.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4404.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4434.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4521.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4531.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4539.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4612.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4622.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4663.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4687.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4776.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x4840.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5208.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5265.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5289.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5301.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5369.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5449.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5642.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5650.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5672.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5756.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5792.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5813.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5841.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5877.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5894.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5906.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5918.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5930.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5945.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x5957.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6024.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6091.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6101.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6246.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6296.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6389.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6435.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x6445.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7286.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7294.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7376.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7384.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7392.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7402.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7444.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7516.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7577.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7624.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7632.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7671.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7695.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7777.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x78.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x7829.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x8146.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x8231.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x8239.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9470.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9534.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9542.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9550.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9641.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9686.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9745.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9769.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9814.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9862.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9870.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9878.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9939.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9947.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9955.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/x9999.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/reference/stylesheet-images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/reference
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm share/Ice/IceStorm
+@dirrm share/Ice/IceSSL
+@dirrm share/Ice/IcePatch2
+@dirrm share/Ice/IcePack
+@dirrm share/Ice/IceBox
+@dirrm share/Ice/Ice
+@dirrm share/Ice/Glacier2
+@dirrm share/Ice/Freeze
+@dirrm share/Ice
+@dirrm include/Slice
+@dirrm include/IceXML
+@dirrm include/IceUtil
+@dirrm include/IceStorm
+@dirrm include/IceSSL
+@dirrm include/IcePatch2
+@dirrm include/IcePack
+@dirrm include/IceBox
+@dirrm include/Ice
+@dirrm include/Glacier2
+@dirrm include/Freeze