aboutsummaryrefslogtreecommitdiff
path: root/devel/librevisa
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-03 22:52:46 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-03 22:52:46 +0000
commit3be8cb19e6c74643c9de4df0471d916b3fd7cf1e (patch)
tree1fe56c90e963da5a36fd8ede2866d0bcaa5de05b /devel/librevisa
parent308e311cfcc7d44794072e8226609d09baafc671 (diff)
downloadports-3be8cb19e6c74643c9de4df0471d916b3fd7cf1e.tar.gz
ports-3be8cb19e6c74643c9de4df0471d916b3fd7cf1e.zip
Add new port: devel/librevisa
PR: 188811 Submitted by: uffe ================================================================ VISA is a multivendor standard for interfacing test and measurement equipment. LibreVISA aims to be a compliant implementation of the VISA standard in a free software library. Currently support for targets connected via USB, exposing the USBTMC interface, and VXI-11 devices.
Notes
Notes: svn path=/head/; revision=363957
Diffstat (limited to 'devel/librevisa')
-rw-r--r--devel/librevisa/Makefile22
-rw-r--r--devel/librevisa/distinfo2
-rw-r--r--devel/librevisa/pkg-descr8
-rw-r--r--devel/librevisa/pkg-plist10
4 files changed, 42 insertions, 0 deletions
diff --git a/devel/librevisa/Makefile b/devel/librevisa/Makefile
new file mode 100644
index 000000000000..8e1a4a3ef292
--- /dev/null
+++ b/devel/librevisa/Makefile
@@ -0,0 +1,22 @@
+# Created by: Uffe Jakobsen <uffe@uffe.org>
+# $FreeBSD$
+
+PORTNAME= librevisa
+PORTVERSION= 0.0.20130412
+CATEGORIES= devel
+MASTER_SITES= http://www.librevisa.org/download/
+
+MAINTAINER= uffe@uffe.org
+COMMENT= Library for interfacing test and measurement equipment
+
+USES= gmake pathfix libtool
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+# Workaround FreeBSD 9.1+ libusb not knowing LIBUSB_CLASS_APPLICATION
+CPPFLAGS+= -DLIBUSB_CLASS_APPLICATION=0xfe
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${LOCALBASE}/lib/libvisa.so
+
+.include <bsd.port.mk>
diff --git a/devel/librevisa/distinfo b/devel/librevisa/distinfo
new file mode 100644
index 000000000000..0d7af3858020
--- /dev/null
+++ b/devel/librevisa/distinfo
@@ -0,0 +1,2 @@
+SHA256 (librevisa-0.0.20130412.tar.gz) = 183ab67e6f482842dba6a264d35a472d969e215388928e1305fcf7a187c05f2e
+SIZE (librevisa-0.0.20130412.tar.gz) = 382286
diff --git a/devel/librevisa/pkg-descr b/devel/librevisa/pkg-descr
new file mode 100644
index 000000000000..1d6e29df0f54
--- /dev/null
+++ b/devel/librevisa/pkg-descr
@@ -0,0 +1,8 @@
+VISA is a multivendor standard for interfacing test and measurement
+equipment.
+
+LibreVISA aims to be a compliant implementation of the VISA standard in
+a free software library. Currently support for targets connected via USB,
+exposing the USBTMC interface, and VXI-11 devices.
+
+WWW: http://www.librevisa.org/
diff --git a/devel/librevisa/pkg-plist b/devel/librevisa/pkg-plist
new file mode 100644
index 000000000000..d98dd1598757
--- /dev/null
+++ b/devel/librevisa/pkg-plist
@@ -0,0 +1,10 @@
+include/visa.h
+include/visatype.h
+lib/libvisa.a
+lib/libvisa.so
+lib/libvisa.so.0
+lib/libvisa.so.0.0.0
+libdata/pkgconfig/librevisa.pc
+man/man3/viClose.3visa.gz
+man/man3/viOpenDefaultRM.3visa.gz
+man/man7/visa.7visa.gz