aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-Modified
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-08-12 12:48:01 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-08-12 12:48:01 +0000
commit3a7b17911b12b557fc9c450a975d5a86e1c8303e (patch)
treec1163267eb35cfcd7d2b1680f5e16f391848e9b1 /devel/p5-File-Modified
parentb45207534f07eb7c813498681685467341d13336 (diff)
downloadports-3a7b17911b12b557fc9c450a975d5a86e1c8303e.tar.gz
ports-3a7b17911b12b557fc9c450a975d5a86e1c8303e.zip
After devel/p5-File-Temp has gained an IGNORE for PERL_LEVEL > 500800, all
these ports were broken because they always depended on it. I've rearranged all the dependencies to fit the new scheme.
Notes
Notes: svn path=/head/; revision=116026
Diffstat (limited to 'devel/p5-File-Modified')
-rw-r--r--devel/p5-File-Modified/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/p5-File-Modified/Makefile b/devel/p5-File-Modified/Makefile
index 2283ce7385ee..57a05de1fd23 100644
--- a/devel/p5-File-Modified/Makefile
+++ b/devel/p5-File-Modified/Makefile
@@ -14,8 +14,7 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module for checking intelligently if files have changed
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -24,6 +23,10 @@ MAN3= File::Modified.3
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
post-patch:
${PERL} -pi -e 's/\r\n/\n/;' -e 's/^use warnings;//' ${WRKSRC}/Modified.pm