aboutsummaryrefslogtreecommitdiff
path: root/devel/py-pip/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2009-10-12 11:59:17 +0000
committerNicola Vitale <nivit@FreeBSD.org>2009-10-12 11:59:17 +0000
commited032a989c80c2a1dda651c4f87e0b7d43a91e90 (patch)
treef74a74fa4bcb8ece8b3c3f060c8b712238d4ae75 /devel/py-pip/Makefile
parentdfabbc95ca4338d767011b24fe5af0f3402cc1d6 (diff)
downloadports-ed032a989c80c2a1dda651c4f87e0b7d43a91e90.tar.gz
ports-ed032a989c80c2a1dda651c4f87e0b7d43a91e90.zip
- Update to 0.5.1
- Install additional docs
Notes
Notes: svn path=/head/; revision=242721
Diffstat (limited to 'devel/py-pip/Makefile')
-rw-r--r--devel/py-pip/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/devel/py-pip/Makefile b/devel/py-pip/Makefile
index 839f94d1aa65..1fb0356b29a6 100644
--- a/devel/py-pip/Makefile
+++ b/devel/py-pip/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pip
-PORTVERSION= 0.4
+PORTVERSION= 0.5.1
PORTREVISION= 0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP \
@@ -16,7 +16,20 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= nivit@FreeBSD.org
COMMENT= Pip installs (Python) packages. An easy_install replacement
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+
+REINPLACE_ARGS= -i.bak -e "s/env python$$/&${PYTHON_VER}/"
+
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+post-patch:
+ ${FIND} ${WRKSRC} -type f -name "pip*" -print0 | ${XARGS} -0 ${REINPLACE_CMD}
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/docs/_build && ${COPYTREE_SHARE} . ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>