aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2021-03-15 13:46:35 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2021-03-15 13:46:35 +0000
commit4793ca029ec2541cd5d53b77d872b0dbaa1789d7 (patch)
tree55873d8dde5e2af5b1a0fbb804736cfcdc7cfb2e /devel
parentf3e7d87a927699980ee98257e422af8f74453502 (diff)
downloadports-4793ca029ec2541cd5d53b77d872b0dbaa1789d7.tar.gz
ports-4793ca029ec2541cd5d53b77d872b0dbaa1789d7.zip
Add py-hidraw 0.2.1, python interface to gather hidraw information.
Notes
Notes: svn path=/head/; revision=568457
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-hidraw/Makefile28
-rw-r--r--devel/py-hidraw/distinfo3
-rw-r--r--devel/py-hidraw/files/patch-hidraw_hidrawmodule.c13
-rw-r--r--devel/py-hidraw/pkg-descr3
5 files changed, 48 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 49fe0bb68a9d..be15ad302cb9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4489,6 +4489,7 @@
SUBDIR += py-hg-evolve
SUBDIR += py-hglib
SUBDIR += py-hgtools
+ SUBDIR += py-hidraw
SUBDIR += py-holidays
SUBDIR += py-http-prompt
SUBDIR += py-humanize
diff --git a/devel/py-hidraw/Makefile b/devel/py-hidraw/Makefile
new file mode 100644
index 000000000000..cf47df05ee64
--- /dev/null
+++ b/devel/py-hidraw/Makefile
@@ -0,0 +1,28 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= hidraw
+PORTVERSION= 0.2.1
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Python interface to gather hidraw information
+
+LICENSE= BSD2CLAUSE
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= daym
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1300000
+IGNORE= requires FreeBSD 13 or later with hidraw support
+.endif
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/hidraw/_hidraw.so
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-hidraw/distinfo b/devel/py-hidraw/distinfo
new file mode 100644
index 000000000000..511ea513b56c
--- /dev/null
+++ b/devel/py-hidraw/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1615814129
+SHA256 (daym-hidraw-0.2.1_GH0.tar.gz) = fe37c03243cf97c9e252aa3d90a6b8adc7a336c237298680a9b70fe4af32d6e1
+SIZE (daym-hidraw-0.2.1_GH0.tar.gz) = 2768
diff --git a/devel/py-hidraw/files/patch-hidraw_hidrawmodule.c b/devel/py-hidraw/files/patch-hidraw_hidrawmodule.c
new file mode 100644
index 000000000000..b4634f6289fe
--- /dev/null
+++ b/devel/py-hidraw/files/patch-hidraw_hidrawmodule.c
@@ -0,0 +1,13 @@
+--- hidraw/hidrawmodule.c.orig 2021-03-15 09:48:56 UTC
++++ hidraw/hidrawmodule.c
+@@ -1,6 +1,10 @@
+ #include <Python.h>
+ #include <sys/ioctl.h>
++#ifdef __FreeBSD__
++#include <dev/hid/hidraw.h>
++#else
+ #include <linux/hidraw.h>
++#endif
+
+ struct module_state {
+ };
diff --git a/devel/py-hidraw/pkg-descr b/devel/py-hidraw/pkg-descr
new file mode 100644
index 000000000000..e0d715a1a1ef
--- /dev/null
+++ b/devel/py-hidraw/pkg-descr
@@ -0,0 +1,3 @@
+Python interface to gather hidraw information.
+
+WWW: https://github.com/daym/hidraw/