aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-11-21 11:15:29 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-11-21 15:55:38 +0000
commitfbc1b9f699b5329282db7bf0746d2d96402b041e (patch)
treefd8941f4bf7a3cc9b3b04db83f02e9f075e8141f /emulators
parent5f7081f4b8a8b486eb94623b9dcdb675f242e7e1 (diff)
downloadports-fbc1b9f699b5329282db7bf0746d2d96402b041e.tar.gz
ports-fbc1b9f699b5329282db7bf0746d2d96402b041e.zip
emulators/yuzu: unbreak build after 33d6f548e666
In file included from src/core/debugger/debugger.cpp:8: In file included from /usr/local/include/boost/asio.hpp:69: /usr/local/include/boost/asio/co_composed.hpp:849:13: error: unknown type name 'async_operation' 849 | template <async_operation Op> | ^ /usr/local/include/boost/asio/co_composed.hpp:850:24: error: unknown type name 'Op' 850 | auto await_transform(Op&& op | ^ /usr/local/include/boost/asio/co_composed.hpp:862:17: error: unknown type name 'Op' 862 | awaitable(Op&& op, co_composed_promise& promise | ^ /usr/local/include/boost/asio/co_composed.hpp:915:7: error: unknown type name 'Op' 915 | Op&& op_; | ^ /usr/local/include/boost/asio/co_composed.hpp:869:27: error: unknown type name 'Op' 869 | : op_(static_cast<Op&&>(op)), | ^ /usr/local/include/boost/asio/co_composed.hpp:900:27: error: unknown type name 'Op' 900 | static_cast<Op&&>(static_cast<awaitable*>(p)->op_)( | ^ /usr/local/include/boost/asio/co_composed.hpp:902:55: error: template argument for template type parameter must be a type 902 | Return, completion_signature_of_t<Op>>( | ^~ /usr/local/include/boost/asio/async_result.hpp:939:20: note: template parameter is declared here 939 | template <typename T, typename... Args> | ^ In file included from src/core/debugger/debugger.cpp:8: In file included from /usr/local/include/boost/asio.hpp:69: /usr/local/include/boost/asio/co_composed.hpp:911:37: error: template argument for template type parameter must be a type 911 | completion_signature_of_t<Op>>::on_resume(promise_.result_); | ^~ /usr/local/include/boost/asio/async_result.hpp:939:20: note: template parameter is declared here 939 | template <typename T, typename... Args> | ^ In file included from src/core/debugger/debugger.cpp:8: In file included from /usr/local/include/boost/asio.hpp:69: /usr/local/include/boost/asio/co_composed.hpp:925:34: error: unknown type name 'Op' 925 | return awaitable{static_cast<Op&&>(op), *this | ^ Reported by: pkg-fallout
Diffstat (limited to 'emulators')
-rw-r--r--emulators/yuzu/files/patch-boost-1.8613
1 files changed, 13 insertions, 0 deletions
diff --git a/emulators/yuzu/files/patch-boost-1.86 b/emulators/yuzu/files/patch-boost-1.86
new file mode 100644
index 000000000000..3bfa48206734
--- /dev/null
+++ b/emulators/yuzu/files/patch-boost-1.86
@@ -0,0 +1,13 @@
+https://github.com/boostorg/asio/issues/437
+https://github.com/boostorg/asio/commit/6ca7c4726e05
+
+--- CMakeLists.txt.orig 2024-03-01 07:57:00 UTC
++++ CMakeLists.txt
+@@ -275,6 +275,7 @@ add_definitions(-DBOOST_ASIO_DISABLE_CONCEPTS)
+
+ # boost asio's concept usage doesn't play nicely with some compilers yet.
+ add_definitions(-DBOOST_ASIO_DISABLE_CONCEPTS)
++add_definitions(-Dasync_operation=typename) # XXX Remove after Boost 1.87 upgrade
+ if (MSVC)
+ add_compile_options($<$<COMPILE_LANGUAGE:CXX>:/std:c++20>)
+