aboutsummaryrefslogtreecommitdiff
path: root/ftp/bareftp
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2009-06-28 22:27:03 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2009-06-28 22:27:03 +0000
commit102d06f88b2ef57203b353456e92518c0ff0d876 (patch)
treeb3e4f35cd6b99773e8e89957297c16ad477a8c25 /ftp/bareftp
parent8efb72e82770c1f7dde8fe13a1fc18bcd487e34d (diff)
downloadports-102d06f88b2ef57203b353456e92518c0ff0d876.tar.gz
ports-102d06f88b2ef57203b353456e92518c0ff0d876.zip
bareFTP is a file transfer client written for Linux desktops, available
under the terms of the GPL license. It supports the FTP, FTPS and SSH (SFTP) protocols. bareFTP is written in pure C# for the Mono framework, using Gtk# for the user interface. WWW: http://www.bareftp.org PR: ports/135876 Submitted by: Chris Petrik <c.petrik.sosa@gmail.com>
Notes
Notes: svn path=/head/; revision=236745
Diffstat (limited to 'ftp/bareftp')
-rw-r--r--ftp/bareftp/Makefile31
-rw-r--r--ftp/bareftp/distinfo3
-rw-r--r--ftp/bareftp/pkg-descr6
-rw-r--r--ftp/bareftp/pkg-plist44
4 files changed, 84 insertions, 0 deletions
diff --git a/ftp/bareftp/Makefile b/ftp/bareftp/Makefile
new file mode 100644
index 000000000000..8ade60e82792
--- /dev/null
+++ b/ftp/bareftp/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: bareftp
+# Date created: Sat June 20, 2009
+# Whom: Chris Petrik (chris@officialunix.com)
+#
+# $FreeBSD$
+#
+
+PORTNAME= bareftp
+PORTVERSION= 0.2.3
+CATEGORIES= ftp
+MASTER_SITES= http://www.bareftp.org/release/
+
+MAINTAINER= chris@officialunix.com
+COMMENT= Ftp client made in C sharp
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --datarootdir="${PREFIX}/share" --libdir="${LOCALBASE}/lib" \
+ --localedir="${PREFIX}/share/locale" --includedir="${LOCALBASE}/include"
+
+INSTALLS_ICONS= yes
+USE_GETTEXT= yes
+USE_GNOME= gtksharp20 gnomesharp20
+USE_GMAKE= yes
+
+# TODO
+# Ugly way but configure ignore "--localedir=" fu* ;/
+pre-build:
+ @${REINPLACE_CMD} -e 's|$$(prefix)/$$(DATADIRNAME)|${PREFIX}/share|g' \
+ ${WRKSRC}/po/Makefile
+
+.include <bsd.port.mk>
diff --git a/ftp/bareftp/distinfo b/ftp/bareftp/distinfo
new file mode 100644
index 000000000000..b963df6782b2
--- /dev/null
+++ b/ftp/bareftp/distinfo
@@ -0,0 +1,3 @@
+MD5 (bareftp-0.2.3.tar.gz) = bd1cdf22f6215144945b21d693b5ab0e
+SHA256 (bareftp-0.2.3.tar.gz) = 15aa42386bd55a1a6f7f8a7e86f4b9bdf4b43aec993f60dfe77d2a8a28f1a0a6
+SIZE (bareftp-0.2.3.tar.gz) = 540962
diff --git a/ftp/bareftp/pkg-descr b/ftp/bareftp/pkg-descr
new file mode 100644
index 000000000000..4b3e939e2c35
--- /dev/null
+++ b/ftp/bareftp/pkg-descr
@@ -0,0 +1,6 @@
+bareFTP is a file transfer client written for Linux desktops, available
+under the terms of the GPL license. It supports the FTP, FTPS and SSH (SFTP)
+protocols. bareFTP is written in pure C# for the Mono framework, using Gtk#
+for the user interface.
+
+WWW: http://www.bareftp.org
diff --git a/ftp/bareftp/pkg-plist b/ftp/bareftp/pkg-plist
new file mode 100644
index 000000000000..c5e2e18717f8
--- /dev/null
+++ b/ftp/bareftp/pkg-plist
@@ -0,0 +1,44 @@
+bin/bareftp
+lib/bareftp/bareFTP.Common.Utils.dll
+lib/bareftp/bareFTP.Connection.dll
+lib/bareftp/bareFTP.Gui.Dialog.dll
+lib/bareftp/bareFTP.Gui.FileManager.dll
+lib/bareftp/bareFTP.Gui.Preferences.dll
+lib/bareftp/bareFTP.Gui.ProgressMonitor.dll
+lib/bareftp/bareFTP.Gui.dll
+lib/bareftp/bareFTP.Preferences.dll
+lib/bareftp/bareFTP.Protocol.Ftp.dll
+lib/bareftp/bareFTP.Protocol.Sftp.dll
+lib/bareftp/bareFTP.Protocol.dll
+lib/bareftp/bareftp.exe
+share/locale/ca/LC_MESSAGES/bareftp.mo
+share/locale/de/LC_MESSAGES/bareftp.mo
+share/locale/es/LC_MESSAGES/bareftp.mo
+share/locale/fr/LC_MESSAGES/bareftp.mo
+share/locale/it/LC_MESSAGES/bareftp.mo
+share/locale/nb/LC_MESSAGES/bareftp.mo
+share/locale/pt_BR/LC_MESSAGES/bareftp.mo
+share/applications/bareftp.desktop
+share/icons/hicolor/16x16/apps/bareftp.png
+share/icons/hicolor/22x22/apps/bareftp.png
+share/icons/hicolor/24x24/apps/bareftp.png
+share/icons/hicolor/32x32/apps/bareftp.png
+share/icons/hicolor/36x36/apps/bareftp.png
+share/icons/hicolor/48x48/apps/bareftp.png
+share/icons/hicolor/scalable/apps/bareftp.svg
+@dirrmtry lib/bareftp
+@dirrmtry lib
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/de/LC_MESSAGES
+@dirrmtry share/locale/es/LC_MESSAGES
+@dirrmtry share/locale/fr/LC_MESSAGES
+@dirrmtry share/locale/it/LC_MESSAGES
+@dirrmtry share/locale/nb/LC_MESSAGES
+@dirrmtry share/locale/pt_BR/LC_MESSAGES
+@dirrmtry share/locale/ca
+@dirrmtry share/locale/de
+@dirrmtry share/locale/es
+@dirrmtry share/locale/fr
+@dirrmtry share/locale/it
+@dirrmtry share/locale/nb
+@dirrmtry share/locale/pt_BR