aboutsummaryrefslogtreecommitdiff
path: root/ftp/gproftpd
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-09-15 23:53:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-09-15 23:53:42 +0000
commit9b07d9d241c2cd57d3ff762743df8c83314a8be0 (patch)
treeaff536ebb0dbe822920a111a0125b1768dc6b0d8 /ftp/gproftpd
parent95506d7ce78cc9039ebd1c5591996b42244ee595 (diff)
downloadports-9b07d9d241c2cd57d3ff762743df8c83314a8be0.tar.gz
ports-9b07d9d241c2cd57d3ff762743df8c83314a8be0.zip
GPROFTPD is an easy to use GTK+ administration tool for the proftpd standalone
server. GProftpd and Proftpd gives admins access to virtual hosting, 8 layers of security including chrooted users and encrypted transfers on both the data and/or control channels. It is ideal for both standard ftp serving and webhotels. WWW: http://gadmintools.org Notes: Thanks to beech@ for working with me on it.
Notes
Notes: svn path=/head/; revision=199533
Diffstat (limited to 'ftp/gproftpd')
-rw-r--r--ftp/gproftpd/Makefile41
-rw-r--r--ftp/gproftpd/distinfo3
-rw-r--r--ftp/gproftpd/files/crypt.h40
-rw-r--r--ftp/gproftpd/files/patch-configure.in29
-rw-r--r--ftp/gproftpd/pkg-descr7
-rw-r--r--ftp/gproftpd/pkg-plist16
6 files changed, 136 insertions, 0 deletions
diff --git a/ftp/gproftpd/Makefile b/ftp/gproftpd/Makefile
new file mode 100644
index 000000000000..9bf96f84387f
--- /dev/null
+++ b/ftp/gproftpd/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: gproftpd
+# Date created: 14 September 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gproftpd
+PORTVERSION= 8.3.2
+CATEGORIES= ftp
+MASTER_SITES= http://mange.dynalias.org/linux/gproftpd/
+
+MAINTAINER= beech@FreeBSD.org
+COMMENT= Gtk2 Frontend for proftpd daemon
+
+RUN_DEPENDS= proftpd:${PORTSDIR}/ftp/proftpd
+
+USE_GMAKE= yes
+USE_AUTOTOOLS= autoconf:261
+GNU_CONFIGURE= yes
+USE_GNOME= gtk20 pkgconfig
+
+PORTDOCS= AUTHORS README ChangeLog COPYING
+
+post-extract:
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "****** Make sure you have mod_tls and mod_radius enabled in ftp/proftpd ******"
+ @${ECHO_CMD} ""
+ @sleep 3
+ @${CP} ${FILESDIR}/crypt.h ${WRKSRC}/src/
+
+post-configure:
+ @${REINPLACE_CMD} -e "s:\<crypt.h\>:\"crypt.h\":" ${WRKSRC}/src/functions.c
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/ftp/gproftpd/distinfo b/ftp/gproftpd/distinfo
new file mode 100644
index 000000000000..9de7bf4e10ca
--- /dev/null
+++ b/ftp/gproftpd/distinfo
@@ -0,0 +1,3 @@
+MD5 (gproftpd-8.3.2.tar.gz) = 0b8a06c4972a00b912b0afa3ae6ec539
+SHA256 (gproftpd-8.3.2.tar.gz) = 6afd290ea8b68c3258f5c355144a8c6adbeb9c2c88ff85a2563916c2f1e3b468
+SIZE (gproftpd-8.3.2.tar.gz) = 605797
diff --git a/ftp/gproftpd/files/crypt.h b/ftp/gproftpd/files/crypt.h
new file mode 100644
index 000000000000..93fdc22ecd6e
--- /dev/null
+++ b/ftp/gproftpd/files/crypt.h
@@ -0,0 +1,40 @@
+/* LINTLIBRARY */
+/*
+ * Copyright (c) 1999
+ * Mark Murray. All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * THIS SOFTWARE IS PROVIDED BY MARK MURRAY AND CONTRIBUTORS ``AS IS'' AND
+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL MARK MURRAY OR CONTRIBUTORS BE LIABLE
+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ *
+ * $FreeBSD: /tmp/pcvs/ports/ftp/gproftpd/files/Attic/crypt.h,v 1.1 2007-09-15 23:53:42 miwi Exp $
+ *
+ */
+
+/* magic sizes */
+#define MD4_SIZE 16
+#define MD5_SIZE 16
+
+char *crypt_des(const char *pw, const char *salt);
+char *crypt_md5(const char *pw, const char *salt);
+char *crypt_nthash(const char *pw, const char *salt);
+char *crypt_blowfish(const char *pw, const char *salt);
+
+extern void _crypt_to64(char *s, u_long v, int n);
diff --git a/ftp/gproftpd/files/patch-configure.in b/ftp/gproftpd/files/patch-configure.in
new file mode 100644
index 000000000000..f4ad1089e490
--- /dev/null
+++ b/ftp/gproftpd/files/patch-configure.in
@@ -0,0 +1,29 @@
+--- configure.in.orig 2007-06-06 07:39:42.000000000 -0800
++++ configure.in 2007-09-15 13:12:47.000000000 -0800
+@@ -98,7 +98,7 @@
+
+
+ dnl Path to proftpd's configuration file.
+-default_proftpd_conf="/etc/proftpd.conf"
++default_proftpd_conf="${prefix}/etc/proftpd.conf"
+ test "x$PROFTPD_CONF" = x && PROFTPD_CONF=$default_proftpd_conf
+ AC_DEFINE_UNQUOTED(PROFTPD_CONF,"`eval echo "${PROFTPD_CONF}"`",[path to proftpd.conf])
+ AC_MSG_RESULT([Using configuration file: (${PROFTPD_CONF})])
+@@ -116,7 +116,7 @@
+ AC_MSG_RESULT([Using xferlog: (${XFER_LOG})])
+
+ dnl Path to the webserver root directory/gprostats html output file.
+-default_html_statistics="/var/www/html/ftp.htm"
++default_html_statistics="${prefix}/www/gproftpd/ftp.htm"
+ test "x$HTML_STATISTICS" = x && HTML_STATISTICS=$default_html_statistics
+ AC_DEFINE_UNQUOTED(HTML_STATISTICS,"`eval echo "${HTML_STATISTICS}"`",[path to generated html statistics])
+ AC_MSG_RESULT([Using html statistics output file: (${HTML_STATISTICS})])
+@@ -152,7 +152,7 @@
+ AC_MSG_RESULT([Using FTPWHO binary: (${FTPWHO_BINARY})])
+
+ dnl Path to the proc filesystem.
+-default_proc_path="/proc"
++default_proc_path="/compat/linux/proc"
+ test "x$PROC_PATH" = x && PROC_PATH=$default_proc_path
+ AC_DEFINE_UNQUOTED(PROC_PATH,"`eval echo "${PROC_PATH}"`",[Path to the proc filesystem])
+ AC_MSG_RESULT([Using Proc filesystem: (${PROC_PATH})])
diff --git a/ftp/gproftpd/pkg-descr b/ftp/gproftpd/pkg-descr
new file mode 100644
index 000000000000..503725540b9a
--- /dev/null
+++ b/ftp/gproftpd/pkg-descr
@@ -0,0 +1,7 @@
+GPROFTPD is an easy to use GTK+ administration tool for the proftpd standalone
+server. GProftpd and Proftpd gives admins access to virtual hosting, 8 layers
+of security including chrooted users and encrypted transfers on both the
+data and/or control channels. It is ideal for both standard ftp serving
+and webhotels.
+
+WWW: http://gadmintools.org
diff --git a/ftp/gproftpd/pkg-plist b/ftp/gproftpd/pkg-plist
new file mode 100644
index 000000000000..924f0ba03d07
--- /dev/null
+++ b/ftp/gproftpd/pkg-plist
@@ -0,0 +1,16 @@
+etc/gproftpd/gproftpd.pem
+etc/gproftpd/gprotls.conf
+etc/pam.d/gproftpd
+sbin/gproftpd
+sbin/gprostats
+share/pixmaps/gproftpd.png
+share/pixmaps/gproftpd/gproftpd.png
+share/pixmaps/gproftpd/gproftpd16.png
+share/pixmaps/gproftpd/gproftpd32.png
+share/pixmaps/gproftpd/gproftpd36.xpm
+share/pixmaps/gproftpd/gproftpd48.png
+share/pixmaps/gproftpd/gproftpd64.png
+@dirrm share/pixmaps/gproftpd
+@exec mkdir -p %%WWWDIR%%
+@dirrmtry %%WWWDIR%%
+@dirrm etc/gproftpd