aboutsummaryrefslogtreecommitdiff
path: root/games/atomix/Makefile
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2003-12-11 02:05:07 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2003-12-11 02:05:07 +0000
commitf0b54ef3943066bef5ac1dc5afd18a9adf102844 (patch)
treebee5f39617ffe09be9047597eea389fc4476981f /games/atomix/Makefile
parent87e836c627d5f98bbf4f0c1b76e814902d1996a0 (diff)
downloadports-f0b54ef3943066bef5ac1dc5afd18a9adf102844.tar.gz
ports-f0b54ef3943066bef5ac1dc5afd18a9adf102844.zip
Update to 1.0
Thanks to marcus@ for solving xml:lang issue.
Notes
Notes: svn path=/head/; revision=95582
Diffstat (limited to 'games/atomix/Makefile')
-rw-r--r--games/atomix/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/games/atomix/Makefile b/games/atomix/Makefile
index b6d97f0bdab0..df9e4f2757fe 100644
--- a/games/atomix/Makefile
+++ b/games/atomix/Makefile
@@ -6,17 +6,24 @@
#
PORTNAME= atomix
-PORTVERSION= 0.4.3
+PORTVERSION= 1.0
CATEGORIES= games gnome
-MASTER_SITES= http://www.informatik.uni-oldenburg.de/~pearl/download/
+MASTER_SITES= http://triq.net/~jens/download/
MAINTAINER= gnome@FreeBSD.org
COMMENT= A yet another little mind game
+USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack gnomelibs
+USE_GNOME= gnomeprefix gnomehack libgnome libgnomeui libgnomecanvas libxml2
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+USE_REINPLACE= yes
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "intltool-merge.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|mkdir $$lang or|mkdir $$lang, 0777 or| ; \
+ s|^push @INC, "/.*|push @INC, "${LOCALBASE}/share/intltool";|'
.include <bsd.port.mk>