aboutsummaryrefslogtreecommitdiff
path: root/games/flightgear-terragear/Makefile
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2018-04-05 08:50:40 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2018-04-05 08:50:40 +0000
commitfed3ef2f5f50d8d64c54d6fd33bbf3c08adb19d9 (patch)
tree85a015672d9ac7271900a68b285df2875ab90c02 /games/flightgear-terragear/Makefile
parent59e1e3ab82edf9602f83848873e585d58d03b44a (diff)
downloadports-fed3ef2f5f50d8d64c54d6fd33bbf3c08adb19d9.tar.gz
ports-fed3ef2f5f50d8d64c54d6fd33bbf3c08adb19d9.zip
New port: games/flightgear-terragear
TerraGear is a collection of tools for building scenery for the FlightGear project. Generally, the process is done in two steps: 1. Preprocess the original raw data. This chops up the data into the FG tiling scheme and saves it in a simple, intermediate format. 2. Collect all the different pieces of intermediate data and assemble them into a 3d model of the terrain. WWW: https://github.com/FlightGear/terragear PR: 223648 Submitted by: Michael Danilov <mike.d.ft402@gmail.com>
Notes
Notes: svn path=/head/; revision=466542
Diffstat (limited to 'games/flightgear-terragear/Makefile')
-rw-r--r--games/flightgear-terragear/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/games/flightgear-terragear/Makefile b/games/flightgear-terragear/Makefile
new file mode 100644
index 000000000000..450a5f8315d8
--- /dev/null
+++ b/games/flightgear-terragear/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= flightgear-terragear
+PORTVERSION= 20171007
+CATEGORIES= games
+
+MAINTAINER= mike.d.ft402@gmail.com
+COMMENT= Tools for building scenery for the FlightGear project
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libSimGearCore.a:devel/simgear
+LIB_DEPENDS= libCGAL.so:math/cgal \
+ libgdal.so:graphics/gdal \
+ libmpfr.so:math/mpfr \
+ libgmp.so:math/gmp \
+ libboost_thread.so:devel/boost-libs \
+ libboost_system.so:devel/boost-libs \
+ libboost_chrono.so:devel/boost-libs \
+ libboost_date_time.so:devel/boost-libs \
+ libboost_atomic.so:devel/boost-libs \
+ libtiff.so:graphics/tiff
+RUN_DEPENDS= ${LOCALBASE}/lib/libSimGearCore.a:devel/simgear
+
+USES= cmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= flightgear
+GH_PROJECT= terragear
+GH_TAGNAME= 5b5e5fc
+
+.include <bsd.port.mk>