aboutsummaryrefslogtreecommitdiff
path: root/games/odamex
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-07-28 06:33:37 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-07-28 06:33:37 +0000
commit75dd30796ab2383a8c5980bab8ec5a07db4154e3 (patch)
tree5148bea31d88c46a1eb7177df430135c16ea50fd /games/odamex
parent898c0cbbeeb3be5cdd4ba32c7461c8038266aa93 (diff)
downloadports-75dd30796ab2383a8c5980bab8ec5a07db4154e3.tar.gz
ports-75dd30796ab2383a8c5980bab8ec5a07db4154e3.zip
games/odamex: Fix build with Clang 6
common/d_dehacked.cpp:883:16: error: non-constant-expression cannot be narrowed from type 'uintptr_t' (aka 'unsigned int') to 'ptrdiff_t' (aka 'int') in initializer list [-Wc++11-narrowing] { "ID #", myoffsetof(mobjinfo_t,doomednum) }, ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ http://beefy11.nyi.freebsd.org/data/head-i386-default/p475044_s336572/logs/odamex-0.7.0_2.log - While here add missing libpng dependency so that it doesn't use its own bundled version
Notes
Notes: svn path=/head/; revision=475497
Diffstat (limited to 'games/odamex')
-rw-r--r--games/odamex/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/games/odamex/Makefile b/games/odamex/Makefile
index 6d6a90eb2100..42b712684d63 100644
--- a/games/odamex/Makefile
+++ b/games/odamex/Makefile
@@ -3,7 +3,7 @@
PORTNAME= odamex
PORTVERSION= 0.7.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Odamex/${PORTVERSION}
DISTNAME= odamex-src-${PORTVERSION}
@@ -14,10 +14,15 @@ COMMENT= Client/server multiplayer engine for Doom
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE
+LIB_DEPENDS= libpng.so:graphics/png
+
USE_SDL= sdl mixer
-USES= cmake dos2unix tar:bzip2
+USES= cmake compiler dos2unix tar:bzip2
DOS2UNIX_FILES= CMakeLists.txt odalaunch/CMakeLists.txt common/d_main.cpp
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
+
OPTIONS_DEFINE= DOCS LAUNCHER
LAUNCHER_DESC= Enable GUI launcher program