aboutsummaryrefslogtreecommitdiff
path: root/games/odamex
diff options
context:
space:
mode:
Diffstat (limited to 'games/odamex')
-rw-r--r--games/odamex/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/games/odamex/Makefile b/games/odamex/Makefile
index 6d6a90eb2100..42b712684d63 100644
--- a/games/odamex/Makefile
+++ b/games/odamex/Makefile
@@ -3,7 +3,7 @@
PORTNAME= odamex
PORTVERSION= 0.7.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Odamex/${PORTVERSION}
DISTNAME= odamex-src-${PORTVERSION}
@@ -14,10 +14,15 @@ COMMENT= Client/server multiplayer engine for Doom
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE
+LIB_DEPENDS= libpng.so:graphics/png
+
USE_SDL= sdl mixer
-USES= cmake dos2unix tar:bzip2
+USES= cmake compiler dos2unix tar:bzip2
DOS2UNIX_FILES= CMakeLists.txt odalaunch/CMakeLists.txt common/d_main.cpp
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
+
OPTIONS_DEFINE= DOCS LAUNCHER
LAUNCHER_DESC= Enable GUI launcher program