aboutsummaryrefslogtreecommitdiff
path: root/graphics/dcraw-m/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2014-01-14 03:25:59 +0000
committerMatthias Andree <mandree@FreeBSD.org>2014-01-14 03:25:59 +0000
commit931cc491b1456f0717be51ef2570a48a9d78c1ec (patch)
tree285998cfe8f5adc4752f41e92ee71ecc359d0679 /graphics/dcraw-m/Makefile
parentde71fae136d34f3f975c8bc03db2c1d8ce741f25 (diff)
downloadports-931cc491b1456f0717be51ef2570a48a9d78c1ec.tar.gz
ports-931cc491b1456f0717be51ef2570a48a9d78c1ec.zip
Add new dcraw-m port, a variant of dcraw that
adds auto-rotate to exported thumbnails, and also add adjustment for camera timezone offset. PR: ports/177490 Submitted by: Waitman Gobble
Notes
Notes: svn path=/head/; revision=339660
Diffstat (limited to 'graphics/dcraw-m/Makefile')
-rw-r--r--graphics/dcraw-m/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/graphics/dcraw-m/Makefile b/graphics/dcraw-m/Makefile
new file mode 100644
index 000000000000..9e9b535fee90
--- /dev/null
+++ b/graphics/dcraw-m/Makefile
@@ -0,0 +1,44 @@
+# Created by: "Waitman Gobble" <uzimac@da3m0n8t3r.com>
+# $FreeBSD$
+
+PORTNAME= dcraw-m
+PORTVERSION= 9.17
+CATEGORIES= graphics
+MASTER_SITES= https://dx.burplex.com/dcraw-m/ \
+ http://www.waitman.net/dcraw-m/
+
+MAINTAINER= waitman@waitman.net
+COMMENT= Modified Decoder for RAW files from digital cameras
+
+LIB_DEPENDS= libjasper.so:${PORTSDIR}/graphics/jasper \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ liblcms.so:${PORTSDIR}/graphics/lcms \
+ libMagickWand.so:${PORTSDIR}/graphics/ImageMagick
+
+PLIST_FILES= bin/dcraw-m
+
+OPTIONS_DEFINE= OPTIMIZE_O3 OPTIMIZE_O4
+OPTIMIZE_O3_DESC= Use O3 with clang (O4 not working)
+OPTIMIZE_O4_DESC= Use O4 with gcc
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MOPTIMIZE_O3}
+CFLAGS+= -O3
+.else
+.if ${PORT_OPTIONS:MOPTIMIZE_O4}
+CFLAGS+= -O4
+.endif
+.endif
+
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/ImageMagick
+LDFLAGS+= -L${LOCALBASE}/lib -lm -ljasper -ljpeg -llcms -lMagickWand
+
+do-build:
+ cd ${WRKSRC}/ && ${CC} -o ${PORTNAME} ${CFLAGS} ${PORTNAME}.c ${LDFLAGS}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+
+.include <bsd.port.mk>