aboutsummaryrefslogtreecommitdiff
path: root/graphics/dspdfviewer/Makefile
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2017-04-15 20:16:47 +0000
committerPhilip Paeps <philip@FreeBSD.org>2017-04-15 20:16:47 +0000
commite216e4a777f4977bacb4331fd5eb3fde40593832 (patch)
treeebcb82a51cec202b84f95112843767f7becebc3b /graphics/dspdfviewer/Makefile
parentcdc9d3ac096b44b4789e463b52ba81b2776fb302 (diff)
downloadports-e216e4a777f4977bacb4331fd5eb3fde40593832.tar.gz
ports-e216e4a777f4977bacb4331fd5eb3fde40593832.zip
Dual-screen PDF viewer for LaTeX-beamer
WWW: https://github.com/dannyedel/dspdfviewer Submitted by: Santhosh Raju <santhosh.raju-at-gmail.com>
Notes
Notes: svn path=/head/; revision=438598
Diffstat (limited to 'graphics/dspdfviewer/Makefile')
-rw-r--r--graphics/dspdfviewer/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/graphics/dspdfviewer/Makefile b/graphics/dspdfviewer/Makefile
new file mode 100644
index 000000000000..842df9e3c87d
--- /dev/null
+++ b/graphics/dspdfviewer/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= dspdfviewer
+PORTVERSION= 1.15.1
+CATEGORIES= graphics
+
+MAINTAINER= santhosh.raju@gmail.com
+COMMENT= Dual-screen PDF viewer for LaTeX-beamer
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libpoppler-qt5.so:graphics/poppler-qt5 \
+ libboost_program_options.so:devel/boost-libs
+
+BUILD_WRKSRC= ${WRKSRC}/build
+CONFIGURE_WRKSRC= ${WRKSRC}/build
+INSTALL_WRKSRC= ${WRKSRC}/build
+
+USES= cmake pkgconfig
+USE_QT5= buildtools_build core gui qmake_build linguisttools widgets xml
+CMAKE_ARGS= -DPOPPLER_LIBRARIES=${LOCALBASE}/lib/libpoppler-qt5.so -DBuildTests=OFF
+USE_LDCONFIG= yes
+
+CMAKE_VERBOSE= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= dannyedel
+GH_PROJECT= dspdfviewer
+GH_TAGNAME= v1.15.1
+
+PLIST_FILES= bin/dspdfviewer \
+ share/applications/dspdfviewer.desktop \
+ share/man/man1/dspdfviewer.1
+
+.include <bsd.port.mk>