aboutsummaryrefslogtreecommitdiff
path: root/graphics/zphoto
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-05-10 21:39:56 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-05-10 21:39:56 +0000
commit16f8154ebc76a78ccc2517af9092f18903a922ac (patch)
treefdd46511545787747a56d57f9322dd5ee1c2d13b /graphics/zphoto
parentedf87a119c4bb6bc9c6cd5bd42fc14c33ee05a14 (diff)
downloadports-16f8154ebc76a78ccc2517af9092f18903a922ac.tar.gz
ports-16f8154ebc76a78ccc2517af9092f18903a922ac.zip
upgrade to 1.0.
PR: ports/66472 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=108874
Diffstat (limited to 'graphics/zphoto')
-rw-r--r--graphics/zphoto/Makefile18
-rw-r--r--graphics/zphoto/distinfo4
-rw-r--r--graphics/zphoto/files/patch-configure6
-rw-r--r--graphics/zphoto/files/patch-zphoto.c12
-rw-r--r--graphics/zphoto/pkg-plist43
-rw-r--r--graphics/zphoto/pkg-plist.wxzphoto1
6 files changed, 48 insertions, 36 deletions
diff --git a/graphics/zphoto/Makefile b/graphics/zphoto/Makefile
index 6d74951e256d..f453101447b0 100644
--- a/graphics/zphoto/Makefile
+++ b/graphics/zphoto/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= zphoto
-PORTVERSION= 0.9
+PORTVERSION= 1.0
CATEGORIES= graphics www
MASTER_SITES= http://namazu.org/~satoru/zphoto/
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,6 +18,11 @@ LIB_DEPENDS= ming.3:${PORTSDIR}/graphics/ming \
Imlib2.2:${PORTSDIR}/graphics/imlib2 \
popt.0:${PORTSDIR}/devel/popt \
aviplay.0:${PORTSDIR}/multimedia/avifile
+.if defined (WITH_WXGTK)
+LIB_DEPENDS+= wx_gtk-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk
+.elif defined (WITH_WXGTK2)
+LIB_DEPENDS+= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2
+.endif
RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
USE_REINPLACE= yes
@@ -25,10 +30,19 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CPPFLAGS="-I${LOCALBASE}/include \
${PTHREAD_CFLAGS}"
+.if defined (WITH_WXGTK) || (WITH_WXGTK2)
+PLIST+= ${PKGDIR}/pkg-plist.wxzphoto
+.else
+CONFIGURE_ARGS= --disable-wx
+.endif
USE_GMAKE= yes
USE_XLIB= yes
post-patch:
@${REINPLACE_CMD} -e 's|<ming.h>|<ming/ming.h>|g' ${WRKSRC}/*.c ${WRKSRC}/configure
-
+.if defined (WITH_WXGTK)
+ @${REINPLACE_CMD} -e 's|wxgtk2-config||g' -e 's|wxgtk2-2.5-config||g' -e 's|wxgtk2-2.4-config||g' ${WRKSRC}/configure
+.elif defined (WITH_WXGTK2)
+ @${REINPLACE_CMD} -e 's|wx-config||g' -e 's|wxgtk-config||g' ${WRKSRC}/configure
+.endif
.include <bsd.port.mk>
diff --git a/graphics/zphoto/distinfo b/graphics/zphoto/distinfo
index 25b6454d80d5..87d6a756b9fb 100644
--- a/graphics/zphoto/distinfo
+++ b/graphics/zphoto/distinfo
@@ -1,2 +1,2 @@
-MD5 (zphoto-0.9.tar.gz) = 49831fc49878c25397f635458ea45a93
-SIZE (zphoto-0.9.tar.gz) = 150821
+MD5 (zphoto-1.0.tar.gz) = 7cba659b913468124b664bcde52efece
+SIZE (zphoto-1.0.tar.gz) = 419086
diff --git a/graphics/zphoto/files/patch-configure b/graphics/zphoto/files/patch-configure
index 77d98e263a07..81857a226640 100644
--- a/graphics/zphoto/files/patch-configure
+++ b/graphics/zphoto/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Thu Feb 26 19:09:36 2004
-+++ configure Tue Mar 2 10:21:20 2004
-@@ -3725,7 +3725,7 @@
+--- configure.orig Wed May 5 16:27:51 2004
++++ configure Wed May 5 16:44:18 2004
+@@ -4131,7 +4131,7 @@
SWFMovie_save(movie, "foo"); /* 0.2a API */
}
EOF
diff --git a/graphics/zphoto/files/patch-zphoto.c b/graphics/zphoto/files/patch-zphoto.c
deleted file mode 100644
index 6bf251887617..000000000000
--- a/graphics/zphoto/files/patch-zphoto.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- zphoto.c.orig Sat Apr 10 18:12:30 2004
-+++ zphoto.c Mon Apr 12 09:48:26 2004
-@@ -1308,8 +1308,8 @@
- fp = zphoto_efopen(file_name, "r");
-
- while (fgets(buf, BUFSIZ, fp)) {
-- buf[strcspn(buf, "\r\n")] = '\0'; /* chomp */
- char *sep, *file_name, *caption;
-+ buf[strcspn(buf, "\r\n")] = '\0'; /* chomp */
- if (buf[0] == '#')
- continue;
- if ((sep = strchr(buf, '\t'))) {
diff --git a/graphics/zphoto/pkg-plist b/graphics/zphoto/pkg-plist
index 77a493b44b1c..80674e30c911 100644
--- a/graphics/zphoto/pkg-plist
+++ b/graphics/zphoto/pkg-plist
@@ -1,24 +1,33 @@
bin/zphoto
-share/zphoto/templates/en/.photo.html
-share/zphoto/templates/en/index.html
-share/zphoto/templates/en/noflash.html
-share/zphoto/templates/en/zphoto.css
-share/zphoto/templates/ja/.photo.html
-share/zphoto/templates/ja/index.html
-share/zphoto/templates/ja/noflash.html
-share/zphoto/templates/ja/zphoto.css
-share/zphoto/templates/all/.photo.html
-share/zphoto/templates/all/zphoto.css
-share/zphoto/templates/all/index.html.en
-share/zphoto/templates/all/index.html.ja
-share/zphoto/templates/all/noflash.html.en
-share/zphoto/templates/all/noflash.html.ja
+share/zphoto/templates/default/en/.photo.html
+share/zphoto/templates/default/en/index.html
+share/zphoto/templates/default/en/noflash.html
+share/zphoto/templates/default/en/zphoto.css
+share/zphoto/templates/default/en/flash-colors.txt
+share/zphoto/templates/default/en/css-colors.txt
+share/zphoto/templates/default/ja/.photo.html
+share/zphoto/templates/default/ja/index.html
+share/zphoto/templates/default/ja/noflash.html
+share/zphoto/templates/default/ja/zphoto.css
+share/zphoto/templates/default/ja/flash-colors.txt
+share/zphoto/templates/default/ja/css-colors.txt
+share/zphoto/templates/default/all/.photo.html
+share/zphoto/templates/default/all/zphoto.css
+share/zphoto/templates/default/all/index.html.en
+share/zphoto/templates/default/all/index.html.ja
+share/zphoto/templates/default/all/noflash.html.en
+share/zphoto/templates/default/all/noflash.html.ja
+share/zphoto/templates/default/all/flash-colors.txt
+share/zphoto/templates/default/all/css-colors.txt
share/zphoto/doc/zphoto-ja.html
share/zphoto/doc/zphoto.html
share/zphoto/fonts/EfontSerifB.fdb
-@dirrm share/zphoto/templates/en
-@dirrm share/zphoto/templates/ja
-@dirrm share/zphoto/templates/all
+share/locale/ja/LC_MESSAGES/zphoto.mo
+share/locale/ja_JP.SJIS/LC_MESSAGES/zphoto.mo
+@dirrm share/zphoto/templates/default/en
+@dirrm share/zphoto/templates/default/ja
+@dirrm share/zphoto/templates/default/all
+@dirrm share/zphoto/templates/default
@dirrm share/zphoto/templates
@dirrm share/zphoto/fonts
@dirrm share/zphoto/doc
diff --git a/graphics/zphoto/pkg-plist.wxzphoto b/graphics/zphoto/pkg-plist.wxzphoto
new file mode 100644
index 000000000000..4718e842c712
--- /dev/null
+++ b/graphics/zphoto/pkg-plist.wxzphoto
@@ -0,0 +1 @@
+bin/wxzphoto