aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-09-12 12:06:59 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-09-12 12:06:59 +0000
commit0562c546655364e6a505d4cb4fcc5ed4ac1efc87 (patch)
treee8dd8e8790463c344560052b9ca6da782051a0f9 /graphics
parent641847e5ad35be34660b0e7b766396deb6c8bd9e (diff)
downloadports-0562c546655364e6a505d4cb4fcc5ed4ac1efc87.tar.gz
ports-0562c546655364e6a505d4cb4fcc5ed4ac1efc87.zip
Add h3 3.6.4
H3 is a geospatial indexing system using a hexagonal grid that can be (approximately) subdivided into finer and finer hexagonal grids, combining the benefits of a hexagonal grid with S2's hierarchical subdivisions. WWW: https://github.com/uber/h3
Notes
Notes: svn path=/head/; revision=548310
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/h3/Makefile23
-rw-r--r--graphics/h3/distinfo3
-rw-r--r--graphics/h3/files/patch-CMakeLists.txt30
-rw-r--r--graphics/h3/pkg-descr5
-rw-r--r--graphics/h3/pkg-plist18
6 files changed, 80 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index e537a58e2c49..e16d0c749e9c 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -327,6 +327,7 @@
SUBDIR += guile-cairo
SUBDIR += guilib
SUBDIR += gwenview
+ SUBDIR += h3
SUBDIR += hdr_tools
SUBDIR += heimer
SUBDIR += hiptext
diff --git a/graphics/h3/Makefile b/graphics/h3/Makefile
new file mode 100644
index 000000000000..0679d13c0663
--- /dev/null
+++ b/graphics/h3/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= h3
+PORTVERSION= 3.6.4
+DISTVERSIONPREFIX= v
+CATEGORIES= graphics
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Hexagonal hierarchical geospatial indexing system
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake
+
+CMAKE_ON= BUILD_SHARED_LIBS
+USE_CSTD= c99
+
+USE_GITHUB= yes
+GH_ACCOUNT= uber
+
+.include <bsd.port.mk>
diff --git a/graphics/h3/distinfo b/graphics/h3/distinfo
new file mode 100644
index 000000000000..82e3eb98ea92
--- /dev/null
+++ b/graphics/h3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1599729117
+SHA256 (uber-h3-v3.6.4_GH0.tar.gz) = b80c2eee2b3e645de77893e27ca149e63d3bb6bf95d33e3a384e3f390e2681bb
+SIZE (uber-h3-v3.6.4_GH0.tar.gz) = 17297475
diff --git a/graphics/h3/files/patch-CMakeLists.txt b/graphics/h3/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..c5f730f01fb0
--- /dev/null
+++ b/graphics/h3/files/patch-CMakeLists.txt
@@ -0,0 +1,30 @@
+--- CMakeLists.txt.orig 2020-06-20 00:40:07 UTC
++++ CMakeLists.txt
+@@ -274,27 +274,6 @@ elseif(NOT CLANG_TIDY_PATH)
+ "so source code linting is disabled")
+ endif()
+
+-# Docs
+-find_package(Doxygen)
+-option(ENABLE_DOCS "Enable building documentation." ON)
+-if(DOXYGEN_FOUND AND ENABLE_DOCS)
+- set_property(DIRECTORY APPEND PROPERTY ADDITIONAL_MAKE_CLEAN_FILES "${CMAKE_CURRENT_BINARY_DIR}/dev-docs/_build")
+- configure_file(dev-docs/Doxyfile.in
+- dev-docs/Doxyfile
+- ESCAPE_QUOTES
+- )
+- add_custom_target(docs
+- ALL
+- ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/dev-docs/Doxyfile
+- WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/dev-docs
+- COMMENT "Generating API documentation with Doxygen" VERBATIM
+- )
+-else()
+- add_custom_target(docs
+- echo "Doxygen was not installed when CMake was run or ENABLE_DOCS was OFF. Check that Doxygen is installed and rerun `cmake .`" VERBATIM
+- )
+-endif()
+-
+ # Metadata for bindings
+ if (WIN32)
+ add_custom_target(binding-functions
diff --git a/graphics/h3/pkg-descr b/graphics/h3/pkg-descr
new file mode 100644
index 000000000000..7cfeea6aa231
--- /dev/null
+++ b/graphics/h3/pkg-descr
@@ -0,0 +1,5 @@
+H3 is a geospatial indexing system using a hexagonal grid that can be
+(approximately) subdivided into finer and finer hexagonal grids, combining the
+benefits of a hexagonal grid with S2's hierarchical subdivisions.
+
+WWW: https://github.com/uber/h3
diff --git a/graphics/h3/pkg-plist b/graphics/h3/pkg-plist
new file mode 100644
index 000000000000..a728111eb87b
--- /dev/null
+++ b/graphics/h3/pkg-plist
@@ -0,0 +1,18 @@
+bin/geoToH3
+bin/h3ToComponents
+bin/h3ToGeo
+bin/h3ToGeoBoundary
+bin/h3ToGeoBoundaryHier
+bin/h3ToGeoHier
+bin/h3ToHier
+bin/h3ToLocalIj
+bin/hexRange
+bin/kRing
+bin/localIjToH3
+include/h3/h3api.h
+lib/cmake/h3/h3Config.cmake
+lib/cmake/h3/h3ConfigVersion.cmake
+lib/cmake/h3/h3Targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/h3/h3Targets.cmake
+lib/libh3.so
+lib/libh3.so.1