aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-02-12 21:16:50 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-02-12 21:16:50 +0000
commit7b27dc6d8a94abb7d94e41f275f07ccaed22ee37 (patch)
treef882142e443afc30a0c46fb1c54a99c6a7d6e722 /graphics
parentf49a4fe7e8da4bf199234a331f12749e1ac00c2c (diff)
downloadports-7b27dc6d8a94abb7d94e41f275f07ccaed22ee37.tar.gz
ports-7b27dc6d8a94abb7d94e41f275f07ccaed22ee37.zip
Initial import
OpenDivX decoding engine from Project Mayo Initial library numbering 0 (distfile numbering) PR: 25036
Notes
Notes: svn path=/head/; revision=38278
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/libdivxdecore-devel/Makefile26
-rw-r--r--graphics/libdivxdecore-devel/distinfo1
-rw-r--r--graphics/libdivxdecore-devel/pkg-comment1
-rw-r--r--graphics/libdivxdecore-devel/pkg-descr15
-rw-r--r--graphics/libdivxdecore-devel/pkg-plist4
-rw-r--r--graphics/libdivxdecore/Makefile26
-rw-r--r--graphics/libdivxdecore/distinfo1
-rw-r--r--graphics/libdivxdecore/pkg-comment1
-rw-r--r--graphics/libdivxdecore/pkg-descr15
-rw-r--r--graphics/libdivxdecore/pkg-plist4
11 files changed, 95 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index f66008f13492..69bc9b504909 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -104,6 +104,7 @@
SUBDIR += leafpak
SUBDIR += lfview
SUBDIR += lib3ds
+ SUBDIR += libdivxdecore
SUBDIR += libdjvu++
SUBDIR += libflash
SUBDIR += libggi
diff --git a/graphics/libdivxdecore-devel/Makefile b/graphics/libdivxdecore-devel/Makefile
new file mode 100644
index 000000000000..47221f8a47be
--- /dev/null
+++ b/graphics/libdivxdecore-devel/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: libdivxdecore
+# Date created: 03 Feb 20001
+# Whom: Mario S F Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdivxdecore
+PORTVERSION= 0.4.7
+CATEGORIES= graphics
+MASTER_SITES= http://download.projectmayo.com/dnload/divx4linux/xmps/
+
+MAINTAINER= lioux@FreeBSD.org
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+PLIST_SUB= LIB_VERSION="${LIB_VERSION}"
+
+LIB_VERSION= 0
+
+post-install:
+ @${LN} -sf ${PORTNAME}.so ${PREFIX}/lib/${PORTNAME}.so.${LIB_VERSION}
+
+.include <bsd.port.mk>
diff --git a/graphics/libdivxdecore-devel/distinfo b/graphics/libdivxdecore-devel/distinfo
new file mode 100644
index 000000000000..0d73e81cc629
--- /dev/null
+++ b/graphics/libdivxdecore-devel/distinfo
@@ -0,0 +1 @@
+MD5 (libdivxdecore-0.4.7.tar.gz) = 0defab7d519308aacfb1a0c1448341a1
diff --git a/graphics/libdivxdecore-devel/pkg-comment b/graphics/libdivxdecore-devel/pkg-comment
new file mode 100644
index 000000000000..2c7efb2d62fe
--- /dev/null
+++ b/graphics/libdivxdecore-devel/pkg-comment
@@ -0,0 +1 @@
+OpenDivX decoding engine from Project Mayo
diff --git a/graphics/libdivxdecore-devel/pkg-descr b/graphics/libdivxdecore-devel/pkg-descr
new file mode 100644
index 000000000000..9cf1a226d7d2
--- /dev/null
+++ b/graphics/libdivxdecore-devel/pkg-descr
@@ -0,0 +1,15 @@
+Decore [excerpt from OpenDivX Project Mayo site]
+
+"Decore" is our decoder core - that part of the codec that decodes
+video from DivX video bitstream into uncompressed RGB bitmaps. Its
+API is defined in decore.h. The API is another frame-in, frame-out
+scheme, you give it a chunk of OpenDivX bitstream and it comes back
+to you with an uncompressed RGB frame. Like "encore", "decore" is
+truly independent of any other code, making no system calls.
+
+"Decore" is a decoder compliant with MPEG-4 natural video, simple
+profile. It also incorporates a video postprocessor which postprocessor,
+which hides many of the artifacts inherent in low bit-rate video.
+
+
+WWW: http://www.projectmayo.com/linux/divx4linux/
diff --git a/graphics/libdivxdecore-devel/pkg-plist b/graphics/libdivxdecore-devel/pkg-plist
new file mode 100644
index 000000000000..344069f1cbb2
--- /dev/null
+++ b/graphics/libdivxdecore-devel/pkg-plist
@@ -0,0 +1,4 @@
+include/divx/decore.h
+lib/libdivxdecore.so
+lib/libdivxdecore.so.%%LIB_VERSION%%
+@dirrm include/divx
diff --git a/graphics/libdivxdecore/Makefile b/graphics/libdivxdecore/Makefile
new file mode 100644
index 000000000000..47221f8a47be
--- /dev/null
+++ b/graphics/libdivxdecore/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: libdivxdecore
+# Date created: 03 Feb 20001
+# Whom: Mario S F Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdivxdecore
+PORTVERSION= 0.4.7
+CATEGORIES= graphics
+MASTER_SITES= http://download.projectmayo.com/dnload/divx4linux/xmps/
+
+MAINTAINER= lioux@FreeBSD.org
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+PLIST_SUB= LIB_VERSION="${LIB_VERSION}"
+
+LIB_VERSION= 0
+
+post-install:
+ @${LN} -sf ${PORTNAME}.so ${PREFIX}/lib/${PORTNAME}.so.${LIB_VERSION}
+
+.include <bsd.port.mk>
diff --git a/graphics/libdivxdecore/distinfo b/graphics/libdivxdecore/distinfo
new file mode 100644
index 000000000000..0d73e81cc629
--- /dev/null
+++ b/graphics/libdivxdecore/distinfo
@@ -0,0 +1 @@
+MD5 (libdivxdecore-0.4.7.tar.gz) = 0defab7d519308aacfb1a0c1448341a1
diff --git a/graphics/libdivxdecore/pkg-comment b/graphics/libdivxdecore/pkg-comment
new file mode 100644
index 000000000000..2c7efb2d62fe
--- /dev/null
+++ b/graphics/libdivxdecore/pkg-comment
@@ -0,0 +1 @@
+OpenDivX decoding engine from Project Mayo
diff --git a/graphics/libdivxdecore/pkg-descr b/graphics/libdivxdecore/pkg-descr
new file mode 100644
index 000000000000..9cf1a226d7d2
--- /dev/null
+++ b/graphics/libdivxdecore/pkg-descr
@@ -0,0 +1,15 @@
+Decore [excerpt from OpenDivX Project Mayo site]
+
+"Decore" is our decoder core - that part of the codec that decodes
+video from DivX video bitstream into uncompressed RGB bitmaps. Its
+API is defined in decore.h. The API is another frame-in, frame-out
+scheme, you give it a chunk of OpenDivX bitstream and it comes back
+to you with an uncompressed RGB frame. Like "encore", "decore" is
+truly independent of any other code, making no system calls.
+
+"Decore" is a decoder compliant with MPEG-4 natural video, simple
+profile. It also incorporates a video postprocessor which postprocessor,
+which hides many of the artifacts inherent in low bit-rate video.
+
+
+WWW: http://www.projectmayo.com/linux/divx4linux/
diff --git a/graphics/libdivxdecore/pkg-plist b/graphics/libdivxdecore/pkg-plist
new file mode 100644
index 000000000000..344069f1cbb2
--- /dev/null
+++ b/graphics/libdivxdecore/pkg-plist
@@ -0,0 +1,4 @@
+include/divx/decore.h
+lib/libdivxdecore.so
+lib/libdivxdecore.so.%%LIB_VERSION%%
+@dirrm include/divx