aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-08-07 08:08:15 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-08-07 08:12:37 +0000
commit8252bf7bd5a92e6bf5b11a9785625e8b1fca19f8 (patch)
tree61f9ddefef827bee77a52d70e68e4f7f42e27f8d /graphics
parentde6064a1368a5d7986a0e050de996b468542c4ca (diff)
downloadports-8252bf7bd5a92e6bf5b11a9785625e8b1fca19f8.tar.gz
ports-8252bf7bd5a92e6bf5b11a9785625e8b1fca19f8.zip
graphics/sswf: prepare for freetype2 update
- freetype2 will no longer ship freetype-config (which was a pkg-config wrapper) in the near future -- use pkg-config to gather the required flags. PR: 251512
Diffstat (limited to 'graphics')
-rw-r--r--graphics/sswf/Makefile2
-rw-r--r--graphics/sswf/files/patch-configure13
2 files changed, 15 insertions, 0 deletions
diff --git a/graphics/sswf/Makefile b/graphics/sswf/Makefile
index 14bc992c7535..40dceeb8a830 100644
--- a/graphics/sswf/Makefile
+++ b/graphics/sswf/Makefile
@@ -29,6 +29,8 @@ OPTIONS_DEFINE= DEBUG
DEBUG_CONFIGURE_OFF= --disable-debug --disable-yydebug
+BINARY_ALIAS= freetype-config=true
+
.include <bsd.port.pre.mk>
.if empty(ICONV_LIB)
diff --git a/graphics/sswf/files/patch-configure b/graphics/sswf/files/patch-configure
new file mode 100644
index 000000000000..5a00dfb7b7a3
--- /dev/null
+++ b/graphics/sswf/files/patch-configure
@@ -0,0 +1,13 @@
+--- configure.orig 2021-08-07 08:00:57 UTC
++++ configure
+@@ -22421,8 +22421,8 @@ fi
+ if test "x$FREETYPE_CONFIG" != "xno" ; then
+ { echo "$as_me:$LINENO: checking for freetype libraries" >&5
+ echo $ECHO_N "checking for freetype libraries... $ECHO_C" >&6; }
+- FREETYPE_LIBS=`$FREETYPE_CONFIG --libs`
+- FREETYPE_CFLAGS=`$FREETYPE_CONFIG --cflags`
++ FREETYPE_LIBS=`pkg-config freetype2 --libs`
++ FREETYPE_CFLAGS=`pkg-config freetype2 --cflags`
+ { echo "$as_me:$LINENO: result: $FREETYPE_LIBS" >&5
+ echo "${ECHO_T}$FREETYPE_LIBS" >&6; }
+ fi