aboutsummaryrefslogtreecommitdiff
path: root/japanese/mimekit/Makefile
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>2004-07-27 05:35:57 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>2004-07-27 05:35:57 +0000
commitd6057a7a29513b685fc8c56dfc42550372e300c1 (patch)
tree97f6a41761ea36712939e176e70169c83f6ac5a8 /japanese/mimekit/Makefile
parentf276a222e88e630ca22a46b52b3d80b35bc78bbd (diff)
downloadports-d6057a7a29513b685fc8c56dfc42550372e300c1.tar.gz
ports-d6057a7a29513b685fc8c56dfc42550372e300c1.zip
Upgrade, and use mimekit included in the delegate8.9.6-pre11 distribution.
This source contains the patch submitted in PR/28995. PR: 28995 Submitted by: amagai@nue.org While I'm at this: * Better handling for portdocs. * Define do-install: instead of patching the distributed Makefile. * Bump the version to 1.9, since I found that version in the mimekit/Makefile. Don't know since when this was version 1.9. * Update the master site.
Notes
Notes: svn path=/head/; revision=114842
Diffstat (limited to 'japanese/mimekit/Makefile')
-rw-r--r--japanese/mimekit/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/japanese/mimekit/Makefile b/japanese/mimekit/Makefile
index 1271847e5c60..351d41ce72a5 100644
--- a/japanese/mimekit/Makefile
+++ b/japanese/mimekit/Makefile
@@ -6,21 +6,31 @@
#
PORTNAME= mimekit
-PORTVERSION= 1.8
+PORTVERSION= 1.9
CATEGORIES= japanese devel mail
-MASTER_SITES= ftp://ftp.etl.go.jp/pub/DeleGate/
-DISTNAME= delegate6.1.19
+MASTER_SITES= ftp://ftp.delegate.org/pub/DeleGate/
+DISTNAME= delegate8.9.6-pre11
MAINTAINER= max@FreeBSD.org
COMMENT= Library to handle messages with MIME-encoded headers
WRKSRC= ${WRKDIR}/${DISTNAME}/mimekit
+.if !defined(NOPORTDOCS)
+PORTDOCS= README README-LIB README-PGP
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/deMime ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/enMime ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/libmimekit.a ${PREFIX}/lib
+ ${RANLIB} ${PREFIX}/lib/libmimekit.a
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/mimekit
- ${INSTALL_DATA} ${WRKSRC}/README.LIB ${PREFIX}/share/doc/mimekit
- ${INSTALL_DATA} ${WRKSRC}/README.PGP ${PREFIX}/share/doc/mimekit
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
+.endfor
.endif
.include <bsd.port.mk>