aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-langpack/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-30 22:14:10 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-30 22:14:10 +0000
commit4671731e5cccdf750284d0adc5505800ca5d32ec (patch)
treea71ff5f31c575a546200b59b240dc23e436b4112 /java/eclipse-langpack/Makefile
parent8cb7d5a29a51f1def07f81e20b869a930fd13c08 (diff)
downloadports-4671731e5cccdf750284d0adc5505800ca5d32ec.tar.gz
ports-4671731e5cccdf750284d0adc5505800ca5d32ec.zip
Stage java/eclipse-langpack
PR: 193088 Submitted by: turutani (Kyoto)
Notes
Notes: svn path=/head/; revision=366685
Diffstat (limited to 'java/eclipse-langpack/Makefile')
-rw-r--r--java/eclipse-langpack/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/java/eclipse-langpack/Makefile b/java/eclipse-langpack/Makefile
index 27770cda503d..582185143a9c 100644
--- a/java/eclipse-langpack/Makefile
+++ b/java/eclipse-langpack/Makefile
@@ -23,15 +23,13 @@ USES= zip
NO_WRKSUBDIR= yes
PLIST= ${WRKDIR}/pkg-plist
-NO_STAGE= yes
do-build:
@${RM} -f ${PLIST}
@${TOUCH} ${PLIST}
- @(cd ${WRKSRC}; ${FIND} eclipse -type f) | ${SORT} | ${SED} -e 's,^eclipse,lib/eclipse,' > ${PLIST}
+ (cd ${WRKSRC}; ${FIND} eclipse -type f) | ${SORT} | ${SED} -e 's,^eclipse,lib/eclipse,' > ${PLIST}
@${CAT} ${.CURDIR}/pkg-plist >> ${PLIST}
do-install:
- @${SETENV} ${SH} ${FILESDIR}/install.sh ${WRKSRC} \
- ${PREFIX} ${SHAREOWN} ${SHAREGRP} 0755 0644
+ ${SETENV} ${SH} ${FILESDIR}/install.sh ${WRKSRC} ${STAGEDIR}${PREFIX}
.include <bsd.port.mk>