aboutsummaryrefslogtreecommitdiff
path: root/lang/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2011-05-19 13:54:39 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2011-05-19 13:54:39 +0000
commitd14dec2ee2ca6e901cde51d5666b0d5d3b67d7bb (patch)
tree52a1c3a5d94e5302fb7773c250f8ebf295c62568 /lang/Makefile
parentaf3d859e515119a5e7ffa854a054434528a73170 (diff)
downloadports-d14dec2ee2ca6e901cde51d5666b0d5d3b67d7bb.tar.gz
ports-d14dec2ee2ca6e901cde51d5666b0d5d3b67d7bb.zip
There are a lot of XSS, a security hole typically found in web
applications, caused by incorrect (or lack of) JavaScript escaping. This module is aimed to provide a secure JavaScript escaping to avoid XSS with JavaScript values. The escaping routine JavaScript::Value::Escape provides escapes q!"!, q!'!, q!&!, q!=!, q!-!, q!+!, q!;!, q!<!, q!>!, q!/!, q!\! and control characters to JavaScript unicode entities like "\u0026". WWW: http://search.cpan.org/dist/JavaScript-Value-Escape/
Notes
Notes: svn path=/head/; revision=274317
Diffstat (limited to 'lang/Makefile')
-rw-r--r--lang/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 64af218e3bb3..08a96db0cba7 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -213,6 +213,7 @@
SUBDIR += p5-JavaScript
SUBDIR += p5-JavaScript-SpiderMonkey
SUBDIR += p5-JavaScript-Squish
+ SUBDIR += p5-JavaScript-Value-Escape
SUBDIR += p5-List-MoreUtils
SUBDIR += p5-Modern-Perl
SUBDIR += p5-Parse-Perl