aboutsummaryrefslogtreecommitdiff
path: root/lang/gforth/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2003-05-06 08:53:15 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2003-05-06 08:53:15 +0000
commite28fda86c6281b3ee8983d01f24d8f6c09d2c2d3 (patch)
tree8bbc2a7cae10aef8afc11c22942df838a732c20d /lang/gforth/Makefile
parent4a43bd9dd9343909eb1a75aa9d067c783466b996 (diff)
downloadports-e28fda86c6281b3ee8983d01f24d8f6c09d2c2d3.tar.gz
ports-e28fda86c6281b3ee8983d01f24d8f6c09d2c2d3.zip
Upgrade to 0.6.1.
PR: ports/51764 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=80243
Diffstat (limited to 'lang/gforth/Makefile')
-rw-r--r--lang/gforth/Makefile38
1 files changed, 18 insertions, 20 deletions
diff --git a/lang/gforth/Makefile b/lang/gforth/Makefile
index 3a5b2f46a839..b7ce33be0845 100644
--- a/lang/gforth/Makefile
+++ b/lang/gforth/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gforth
-PORTVERSION= 0.5.0
+PORTVERSION= 0.6.1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gforth
@@ -18,24 +18,20 @@ COMMENT= Fast and portable Forth system
#
STRIP= #none
-
USE_REINPLACE= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
ALL_TARGET= all info
-
-# PREFIX isn't honored. force it w/ prefix.
-MAKE_ARGS= prefix=${PREFIX}
+PLIST_SUB= PORTVERSION="${PORTVERSION}"
MAN1= gforth.1
# Local variables
#
-INSTALL_INFO?= install-info
-
-INFO_FILES= ${PORTNAME}.info
-INFO_DIR= ${PREFIX}/info
+DOC_FILES= AUTHORS BUGS Benchres COPYING COPYING.DOC \
+ INSTALL INSTALL.BINDIST NEWS README \
+ NEWS.vmgen README.vmgen ToDo
EMACS_FILES= gforth.el
EMACS_DIR= ${PREFIX}/share/emacs/site-lisp
@@ -43,8 +39,8 @@ EMACS_DIR= ${PREFIX}/share/emacs/site-lisp
EMPTY_FILES= siteinit.fs
FORTH_DIR= ${DATADIR}/site-forth
-EMPTY_DIRS= 4stack 6502 8086 avr c165 generic h8 \
- hppa ia64 m68k misc power shboom sparc
+EMPTY_DIRS= 4stack 6502 8086 avr c165 generic h8 hppa \
+ ia64 m68k misc power sharc shboom sparc
ARCH_DIR= ${DATADIR}/${PORTVERSION}/arch
# Post-extract
@@ -53,9 +49,7 @@ ARCH_DIR= ${DATADIR}/${PORTVERSION}/arch
post-extract: remove-info-files
remove-info-files:
-.for file in ${INFO_FILES}
- @${RM} -f ${WRKSRC}/doc/${file}*
-.endfor
+ @${RM} -f ${WRKSRC}/doc/*.info*
# Post-patch
#
@@ -70,17 +64,19 @@ patch-makefiles:
# Post-install
#
-post-install: install-info install-el \
- remove-empty-files remove-empty-dirs
+post-install: install-doc install-el remove-empty-files remove-empty-dirs
-install-info:
-.for file in ${INFO_FILES}
- @${INSTALL_INFO} ${INFO_DIR}/${file} ${INFO_DIR}/dir
+install-doc:
+.if !defined(NOPORTSDOC)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
+.endif
install-el:
.for file in ${EMACS_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${EMACS_DIR}/${file}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${EMACS_DIR}
.endfor
remove-empty-files:
@@ -94,3 +90,5 @@ remove-empty-dirs:
.endfor
.include <bsd.port.mk>
+
+CONFIGURE_TARGET:= --build=${CONFIGURE_TARGET}