aboutsummaryrefslogtreecommitdiff
path: root/lang/nml/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-07-19 11:04:13 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-07-19 11:04:13 +0000
commitf899c758a653ca8ff2f8a63aafcb2519a0b524ed (patch)
treebe6eebf3e77ddf9fcf383081091d8b8b336dd71c /lang/nml/Makefile
parent74d26774f830684ae21247061aa4bd7dabbe6527 (diff)
downloadports-f899c758a653ca8ff2f8a63aafcb2519a0b524ed.tar.gz
ports-f899c758a653ca8ff2f8a63aafcb2519a0b524ed.zip
When there is a do-install target, do not use a post-install target, do
everything at once. Sometime, rename post-install into a options helper target. I did not fix ports that were such a mess that I could not figure out what they really wanted to do. I also did not change ports that had some version of an auto-plist code in post-install, for the same reason. With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=418767
Diffstat (limited to 'lang/nml/Makefile')
-rw-r--r--lang/nml/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/lang/nml/Makefile b/lang/nml/Makefile
index dabac5cf9e2b..2eac2069544d 100644
--- a/lang/nml/Makefile
+++ b/lang/nml/Makefile
@@ -35,10 +35,6 @@ post-patch:
do-install:
${DO_MAKE_BUILD} -C ${WRKSRC} PREFIX="${STAGEDIR}${PREFIX}" ${INSTALL_TARGET}
@${REINPLACE_CMD} -i '' -e 's|${STAGEDIR}||' ${STAGEDIR}${PREFIX}/lib/nml/ld.conf
-
-post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Changes ${WRKSRC}/LICENSE ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${DATADIR}/contrib/emacs
@${MKDIR} ${STAGEDIR}${DATADIR}/contrib/vim
${INSTALL_DATA} ${WRKSRC}/contrib/emacs/* ${STAGEDIR}${DATADIR}/contrib/emacs
@@ -47,4 +43,8 @@ post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/$i
.endfor
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Changes ${WRKSRC}/LICENSE ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>