aboutsummaryrefslogtreecommitdiff
path: root/lang/ocaml
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-04-11 13:23:05 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-04-11 13:23:05 +0000
commitc6762e80516b169cd71a8d7e68d0ed5b308f7e55 (patch)
treef23cbb8b9252353d844bff7e183b8b588e997854 /lang/ocaml
parent3b03d918066c823f39536b8d108d1145c833a3dd (diff)
downloadports-c6762e80516b169cd71a8d7e68d0ed5b308f7e55.tar.gz
ports-c6762e80516b169cd71a8d7e68d0ed5b308f7e55.zip
- Update lang/ocaml to 3.11.0. [1]
- Fix devel/cil build with 3.11.0 by using proper object file name - Fix devel/deputy build with 3.11.0 by using proper object file name - Fix lang/mtasc. Ocamlp4 syntax has changed and usage of ';' as delimiters is not allowed now. - Fix usage message in lang/mtasc. - Implement a FreeBSD specific code for retriving the executable path in lang/mtasc. - Update devel/omake to 0.9.8.5. - Fix devel/omake compilation with 3.11 by dropping an unused reference from the code. - Fix www/geneweb build with 3.11 by not emitting errors for warnings. - Fix print/advi build. [2] - Update lang/cduce to 0.5.3 (this fixes build with ocaml 3.11.0). PR: ports/130845 [1] [2] (based on) Submitted by: Hirohisa Yamaguchi <umq@ueo.co.jp> [1], Tsurutani Naoki <turutani@scphys.kyoto-u.ac.jp> [2]
Notes
Notes: svn path=/head/; revision=232098
Diffstat (limited to 'lang/ocaml')
-rw-r--r--lang/ocaml/Makefile15
-rw-r--r--lang/ocaml/distinfo6
-rw-r--r--lang/ocaml/files/mann1
-rw-r--r--lang/ocaml/files/patch-camlp4-man_Makefile10
-rw-r--r--lang/ocaml/files/patch-configure17
-rw-r--r--lang/ocaml/files/patch-stdlib_Makefile12
-rw-r--r--lang/ocaml/pkg-plist20
7 files changed, 42 insertions, 39 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index 2cc85c6a0e80..58c1d8ef4d43 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ocaml
-PORTVERSION= 3.10.2
-PORTREVISION= 1
+PORTVERSION= 3.11.0
CATEGORIES= lang
MASTER_SITES= http://caml.inria.fr/distrib/${DISTNAME:R}/ \
ftp://ftp.inria.fr/INRIA/caml-light/${DISTNAME:R}/ \
@@ -22,6 +21,7 @@ COMMENT?= The Objective Caml compiler and programming environment
USE_BZIP2= yes
REINPLACE_ARGS= -i ""
HAS_CONFIGURE= yes
+USE_LDCONFIG= yes
ALL_TARGET= world.opt
STRIP=
@@ -70,14 +70,13 @@ SFX= -notk
CONFLICTS+= ocaml-[0-9]* ocaml-nox11-[0-9]*
CONFIGURE_ARGS+=-no-tk
.else
+USE_TK= 84+
+.include "${PORTSDIR}/Mk/bsd.tcl.mk"
PLIST_SUB+= TK=""
CONFLICTS+= ocaml-nox11-[0-9]* ocaml-notk-[0-9]*
-CONFIGURE_ARGS+=-tkdefs \
- "-I${LOCALBASE}/include/tcl8.4 -I${LOCALBASE}/include/tk8.4 ${THR_CPP}"\
- -tklibs "-L${LOCALBASE}/lib ${THR_LD}"
-BUILD_DEPENDS+= ${LOCALBASE}/include/tcl8.4:${PORTSDIR}/lang/tcl84 \
- ${LOCALBASE}/include/tk8.4:${PORTSDIR}/x11-toolkits/tk84
-LIB_DEPENDS+= tk84.1:${PORTSDIR}/x11-toolkits/tk84
+CONFIGURE_ARGS+= -tkdefs \
+ "-I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR} ${THR_CPP}" \
+ -tklibs "-L${LOCALBASE}/lib ${THR_LD}"
.endif
.if ${ARCH} == sparc64 || ${ARCH} == ia64
diff --git a/lang/ocaml/distinfo b/lang/ocaml/distinfo
index adbdc5c2364c..8997fbd3636f 100644
--- a/lang/ocaml/distinfo
+++ b/lang/ocaml/distinfo
@@ -1,3 +1,3 @@
-MD5 (ocaml-3.10.2.tar.bz2) = d86f8f8aa4574fa60dd6f89044580307
-SHA256 (ocaml-3.10.2.tar.bz2) = 3755a32da1a7490d47fff7838c12c754d3fcfe69d7c9ff2358704259dc477c58
-SIZE (ocaml-3.10.2.tar.bz2) = 2284860
+MD5 (ocaml-3.11.0.tar.bz2) = 6ed1c3ed660a15408362242fa8fa4668
+SHA256 (ocaml-3.11.0.tar.bz2) = 3faa9057bdac916413a5dee17180f5a8fbc7fb7589465208f72f692bddbd6776
+SIZE (ocaml-3.11.0.tar.bz2) = 2359311
diff --git a/lang/ocaml/files/mann b/lang/ocaml/files/mann
index f2f57930f306..8540f41cb8ab 100644
--- a/lang/ocaml/files/mann
+++ b/lang/ocaml/files/mann
@@ -79,3 +79,4 @@ Weak.Make.n
Weak.S.n
Weak.n
CamlinternalMod.n
+CamlinternalLazy.n
diff --git a/lang/ocaml/files/patch-camlp4-man_Makefile b/lang/ocaml/files/patch-camlp4-man_Makefile
index 2626d2574ce6..d2d090287e96 100644
--- a/lang/ocaml/files/patch-camlp4-man_Makefile
+++ b/lang/ocaml/files/patch-camlp4-man_Makefile
@@ -1,14 +1,14 @@
---- ./camlp4/man/Makefile.orig Thu Jul 3 20:14:49 2003
-+++ ./camlp4/man/Makefile Sun May 21 14:02:41 2006
+--- ./camlp4/man/Makefile.orig 2008-10-27 23:03:31.000000000 +0900
++++ ./camlp4/man/Makefile 2009-01-21 01:35:26.000000000 +0900
@@ -3,7 +3,6 @@
- include ../config/Makefile
+ include ../config/Makefile.cnf
TARGET=camlp4.1
-ALIASES=camlp4o.1 camlp4r.1 mkcamlp4.1 ocpp.1 camlp4o.opt.1 camlp4r.opt.1
- all: $(TARGET)
+ include ../config/Makefile.base
-@@ -18,10 +17,6 @@
+@@ -11,10 +10,6 @@
if test -n '$(MANDIR)'; then \
$(MKDIR) $(MANDIR)/man1 ; \
cp $(TARGET) $(MANDIR)/man1/. ; \
diff --git a/lang/ocaml/files/patch-configure b/lang/ocaml/files/patch-configure
index 3d3fc9eb03d1..12a76b7f2081 100644
--- a/lang/ocaml/files/patch-configure
+++ b/lang/ocaml/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2008-01-04 16:26:38.000000000 +0300
-+++ configure 2009-04-06 23:35:00.000000000 +0400
-@@ -79,6 +79,8 @@
+--- ./configure.orig 2008-11-07 19:34:16.000000000 +0900
++++ ./configure 2009-01-21 01:41:11.000000000 +0900
+@@ -85,6 +85,8 @@
withcurses=no;;
-no-shared-libs)
withsharedlibs=no;;
@@ -9,15 +9,15 @@
-x11include*|--x11include*)
x11_include_dir=$2; shift;;
-x11lib*|--x11lib*)
-@@ -686,6 +688,7 @@
- i386,*,gnu) profiling='prof';;
+@@ -739,6 +741,7 @@
i386,*,bsd_elf) profiling='prof';;
+ amd64,*,macosx) profiling='prof';;
i386,*,macosx) profiling='prof';;
+ *,*,freebsd) profiling='prof';;
sparc,*,solaris)
profiling='prof'
case "$nativecc" in gcc*) ;; *) cc_profile='-xpg';; esac;;
-@@ -1132,124 +1135,24 @@
+@@ -1183,127 +1186,24 @@
x11_include="not found"
x11_link="not found"
@@ -129,8 +129,11 @@
- if test $dir = /usr/lib; then
- x11_link="-lX11"
- else
-- x11_link="-L$dir -lX11"
- x11_libs="-L$dir"
+- case "$host" in
+- *-*-*bsd*) x11_link="-R$dir -L$dir -lX11";;
+- *) x11_link="-L$dir -lX11";;
+- esac
- fi
- break
- fi
diff --git a/lang/ocaml/files/patch-stdlib_Makefile b/lang/ocaml/files/patch-stdlib_Makefile
deleted file mode 100644
index 9bd92e1c2566..000000000000
--- a/lang/ocaml/files/patch-stdlib_Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./stdlib/Makefile.orig Mon Nov 29 17:53:30 2004
-+++ ./stdlib/Makefile Sun May 21 14:02:41 2006
-@@ -48,8 +48,7 @@
- rm -f std_exit.p.cmi
-
- install:
-- cp stdlib.cma std_exit.cmo *.cmi *.mli *.ml camlheader camlheader_ur \
-- $(LIBDIR)
-+ cp stdlib.cma std_exit.cmo *.cmi *.mli *.ml camlheader camlheader_ur $(LIBDIR)
-
- installopt: installopt-default installopt-$(PROFILING)
-
diff --git a/lang/ocaml/pkg-plist b/lang/ocaml/pkg-plist
index ee26a1ed5069..07c2ec076fa1 100644
--- a/lang/ocaml/pkg-plist
+++ b/lang/ocaml/pkg-plist
@@ -66,6 +66,7 @@ lib/ocaml/bigarray.cma
lib/ocaml/bigarray.cmi
lib/ocaml/bigarray.cmx
lib/ocaml/bigarray.cmxa
+lib/ocaml/bigarray.cmxs
lib/ocaml/bigarray.mli
lib/ocaml/buffer.cmi
lib/ocaml/buffer.cmx
@@ -93,6 +94,11 @@ lib/ocaml/caml/signals.h
lib/ocaml/caml/unixsupport.h
lib/ocaml/camlheader
lib/ocaml/camlheader_ur
+lib/ocaml/camlinternalLazy.cmi
+lib/ocaml/camlinternalLazy.cmx
+lib/ocaml/camlinternalLazy.ml
+lib/ocaml/camlinternalLazy.mli
+lib/ocaml/camlinternalLazy.p.cmx
lib/ocaml/camlinternalMod.cmi
lib/ocaml/camlinternalMod.cmx
lib/ocaml/camlinternalMod.ml
@@ -136,10 +142,6 @@ lib/ocaml/camlp4/Camlp4Filters/Camlp4Profiler.cmi
lib/ocaml/camlp4/Camlp4Filters/Camlp4Profiler.cmo
lib/ocaml/camlp4/Camlp4Filters/Camlp4Profiler.cmx
lib/ocaml/camlp4/Camlp4Filters/Camlp4Profiler.o
-lib/ocaml/camlp4/Camlp4Filters/Camlp4Tracer.cmi
-lib/ocaml/camlp4/Camlp4Filters/Camlp4Tracer.cmo
-lib/ocaml/camlp4/Camlp4Filters/Camlp4Tracer.cmx
-lib/ocaml/camlp4/Camlp4Filters/Camlp4Tracer.o
lib/ocaml/camlp4/Camlp4Filters/Camlp4TrashRemover.cmi
lib/ocaml/camlp4/Camlp4Filters/Camlp4TrashRemover.cmo
lib/ocaml/camlp4/Camlp4Filters/Camlp4TrashRemover.cmx
@@ -268,14 +270,18 @@ lib/ocaml/dbm.cma
lib/ocaml/dbm.cmi
lib/ocaml/dbm.cmx
lib/ocaml/dbm.cmxa
+lib/ocaml/dbm.cmxs
lib/ocaml/dbm.mli
lib/ocaml/digest.cmi
lib/ocaml/digest.cmx
lib/ocaml/digest.ml
lib/ocaml/digest.mli
lib/ocaml/digest.p.cmx
+lib/ocaml/dynlink.a
lib/ocaml/dynlink.cma
lib/ocaml/dynlink.cmi
+lib/ocaml/dynlink.cmx
+lib/ocaml/dynlink.cmxa
lib/ocaml/dynlink.mli
lib/ocaml/event.mli
lib/ocaml/expunge
@@ -305,8 +311,10 @@ lib/ocaml/genlex.p.cmx
%%X11%%lib/ocaml/graphics.cmi
%%X11%%lib/ocaml/graphics.cmx
%%X11%%lib/ocaml/graphics.cmxa
+%%X11%%lib/ocaml/graphics.cmxs
%%X11%%lib/ocaml/graphics.mli
%%X11%%lib/ocaml/graphicsX11.cmi
+%%X11%%lib/ocaml/graphicsX11.cmx
%%X11%%lib/ocaml/graphicsX11.mli
lib/ocaml/hashtbl.cmi
lib/ocaml/hashtbl.cmx
@@ -664,6 +672,7 @@ lib/ocaml/libasmrun.a
lib/ocaml/libasmrunp.a
lib/ocaml/libbigarray.a
lib/ocaml/libcamlrun.a
+lib/ocaml/libcamlrun_shared.so
%%X11%%lib/ocaml/libgraphics.a
lib/ocaml/libmldbm.a
lib/ocaml/libnums.a
@@ -711,6 +720,7 @@ lib/ocaml/num.mli
lib/ocaml/nums.a
lib/ocaml/nums.cma
lib/ocaml/nums.cmxa
+lib/ocaml/nums.cmxs
lib/ocaml/obj.cmi
lib/ocaml/obj.cmx
lib/ocaml/obj.ml
@@ -870,6 +880,7 @@ lib/ocaml/str.cma
lib/ocaml/str.cmi
lib/ocaml/str.cmx
lib/ocaml/str.cmxa
+lib/ocaml/str.cmxs
lib/ocaml/str.mli
lib/ocaml/stream.cmi
lib/ocaml/stream.cmx
@@ -926,6 +937,7 @@ lib/ocaml/unix.cma
lib/ocaml/unix.cmi
lib/ocaml/unix.cmx
lib/ocaml/unix.cmxa
+lib/ocaml/unix.cmxs
lib/ocaml/unix.mli
lib/ocaml/unixLabels.cmi
lib/ocaml/unixLabels.cmx