aboutsummaryrefslogtreecommitdiff
path: root/lang/php53
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-01-16 12:08:20 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-01-16 12:08:20 +0000
commitfce0420478a3807f2592b40b55f2061aa8e7f212 (patch)
treec61374cc4ea23c922cbc57fdd4576c085f632fba /lang/php53
parent2bb0d2253ec19fe57a4a8c8b2a15c4e4db874ecb (diff)
downloadports-fce0420478a3807f2592b40b55f2061aa8e7f212.tar.gz
ports-fce0420478a3807f2592b40b55f2061aa8e7f212.zip
Update to 5.1.2 release:
- add reflection - enable xmlreader and xmlwriter by default in php5-extensions
Notes
Notes: svn path=/head/; revision=153649
Diffstat (limited to 'lang/php53')
-rw-r--r--lang/php53/Makefile3
-rw-r--r--lang/php53/Makefile.ext12
-rw-r--r--lang/php53/distinfo6
-rw-r--r--lang/php53/files/patch-acinclude.m419
-rw-r--r--lang/php53/pkg-plist2
5 files changed, 29 insertions, 13 deletions
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index d192cdc78474..c3edd2427f86 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= php5
-PORTVERSION= 5.1.1
+PORTVERSION= 5.1.2
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
@@ -33,6 +33,7 @@ CONFIGURE_ARGS= --enable-versioning \
--disable-all \
--enable-libxml \
--with-libxml-dir=${LOCALBASE} \
+ --enable-reflection \
--enable-spl
USE_GNOME= libxml2
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index c59f4d3c035f..b5d56d805179 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -61,9 +61,6 @@ CONFIGURE_ARGS+=--enable-dom \
--with-libxml-dir=${LOCALBASE}
USE_GNOME= libxml2
-
-USE_PHP= simplexml
-USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "exif"
@@ -353,7 +350,7 @@ CONFIGURE_ARGS+=--with-xmlreader \
USE_GNOME= libxml2
-USE_PHP= xml
+USE_PHP= dom
USE_PHP_BUILD= yes
.endif
@@ -371,6 +368,13 @@ USE_PHP= xml
USE_PHP_BUILD= yes
.endif
+.if ${PHP_MODNAME} == "xmlwriter"
+CONFIGURE_ARGS+=--with-xmlwriter \
+ --with-libxml-dir=${LOCALBASE}
+
+USE_GNOME= libxml2
+.endif
+
.if ${PHP_MODNAME} == "xsl"
CONFIGURE_ARGS+=--with-xsl=${LOCALBASE}
diff --git a/lang/php53/distinfo b/lang/php53/distinfo
index 238205cbbe25..190c276dee62 100644
--- a/lang/php53/distinfo
+++ b/lang/php53/distinfo
@@ -1,3 +1,3 @@
-MD5 (php-5.1.1.tar.bz2) = 70a7c90de182d1a1901c390b844153c7
-SHA256 (php-5.1.1.tar.bz2) = 29fee6733868019bc702f7a2b54d95bd9d20d01fc9e9e6681f3d32f50b5f28cd
-SIZE (php-5.1.1.tar.bz2) = 6149470
+MD5 (php-5.1.2.tar.bz2) = 79cee17e9db85be878000a2a4198378e
+SHA256 (php-5.1.2.tar.bz2) = a18399360e1c5dcbdfed4f7215ae8fd2a5e057c24b86392392e832216aa63202
+SIZE (php-5.1.2.tar.bz2) = 6319905
diff --git a/lang/php53/files/patch-acinclude.m4 b/lang/php53/files/patch-acinclude.m4
index 925902e0e2e8..14396604f6e6 100644
--- a/lang/php53/files/patch-acinclude.m4
+++ b/lang/php53/files/patch-acinclude.m4
@@ -1,6 +1,19 @@
---- acinclude.m4.orig Tue Jul 26 00:31:07 2005
-+++ acinclude.m4 Wed Nov 16 09:30:03 2005
-@@ -1707,9 +1707,9 @@
+--- acinclude.m4.orig Sat Dec 24 12:38:05 2005
++++ acinclude.m4 Mon Jan 16 12:20:17 2006
+@@ -1021,12 +1021,6 @@
+ build to be successful.
+ ])
+ fi
+- if test "x$is_it_shared" = "x" && test "x$3" != "xtrue"; then
+- AC_MSG_ERROR([
+-You've configured extension $1, which depends on extension $2,
+-but you've either not enabled $2, or have disabled it.
+-])
+- fi
+ dnl Some systems require that we link $2 to $1 when building
+ ])
+
+@@ -2151,9 +2145,9 @@
test -z "$PHP_IMAP_SSL" && PHP_IMAP_SSL=no
dnl Fallbacks for different configure options
diff --git a/lang/php53/pkg-plist b/lang/php53/pkg-plist
index e66190e08479..a2fb357af332 100644
--- a/lang/php53/pkg-plist
+++ b/lang/php53/pkg-plist
@@ -56,7 +56,6 @@ include/php/Zend/zend_objects_API.h
include/php/Zend/zend_operators.h
include/php/Zend/zend_ptr_stack.h
include/php/Zend/zend_qsort.h
-include/php/Zend/zend_reflection_api.h
include/php/Zend/zend_stack.h
include/php/Zend/zend_static_allocator.h
include/php/Zend/zend_stream.h
@@ -127,7 +126,6 @@ include/php/ext/standard/php_smart_str.h
include/php/ext/standard/php_smart_str_public.h
include/php/ext/standard/php_standard.h
include/php/ext/standard/php_string.h
-include/php/ext/standard/php_sunfuncs.h
include/php/ext/standard/php_type.h
include/php/ext/standard/php_uuencode.h
include/php/ext/standard/php_var.h