aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby16
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-09-06 22:46:12 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-09-06 22:46:12 +0000
commit988a074d1ffb00e86ff5491f15032326ef9f9fd9 (patch)
tree38ac7cecf46c966271ebcc128e5281d810da24db /lang/ruby16
parentaddcb1c0ade81b9e97793e1f2d26e81e9ca981af (diff)
downloadports-988a074d1ffb00e86ff5491f15032326ef9f9fd9.tar.gz
ports-988a074d1ffb00e86ff5491f15032326ef9f9fd9.zip
Make coexistence support almost perfect except for bin/ruby and
man/man1/ruby.1 symlinks.)
Notes
Notes: svn path=/head/; revision=32352
Diffstat (limited to 'lang/ruby16')
-rw-r--r--lang/ruby16/Makefile12
-rw-r--r--lang/ruby16/pkg-plist4
2 files changed, 11 insertions, 5 deletions
diff --git a/lang/ruby16/Makefile b/lang/ruby16/Makefile
index d69dc5b26316..9efd00c39ddd 100644
--- a/lang/ruby16/Makefile
+++ b/lang/ruby16/Makefile
@@ -18,7 +18,8 @@ MAINTAINER= yasuf@bsdclub.org
USE_AUTOCONF= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-shared
-MAN1= ${RUBY_NAME}.1
+MAN1= ruby${_RUBY_SUFFIX}.1
+MLINKS= ruby${_RUBY_SUFFIX}.1 ruby.1
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
@@ -32,7 +33,6 @@ XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
.if !empty(RUBY_SUFFIX)
CONFIGURE_ARGS+= --program-suffix="${RUBY_SUFFIX}"
-MLINKS= ${RUBY_NAME}.1 ruby.1
.endif
.if ${OSVERSION} >= 400014
@@ -46,7 +46,13 @@ post-patch:
post-install:
strip ${RUBY}
- ${LN} -fs ${RUBY} ${PREFIX}/ruby
+.if empty(RUBY_SUFFIX)
+ ${MV} ${RUBY} ${RUBY}${_RUBY_SUFFIX}
+ ${LN} -fs ${RUBY}${_RUBY_SUFFIX} ${RUBY}
+ ${MV} ${PREFIX}/man/man1/ruby.1 ${PREFIX}/man/man1/ruby${_RUBY_SUFFIX}.1
+.else
+ ${LN} -fs ${RUBY} ${PREFIX}/bin/ruby
+.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}
diff --git a/lang/ruby16/pkg-plist b/lang/ruby16/pkg-plist
index 28525df2d3b7..e547d5f73aa9 100644
--- a/lang/ruby16/pkg-plist
+++ b/lang/ruby16/pkg-plist
@@ -1,6 +1,6 @@
bin/irb
-bin/%%RUBY_NAME%%
-@unexec if [ -f %D/bin/ruby ]; then rm %D/bin/ruby; fi
+bin/ruby
+bin/ruby%%_RUBY_SUFFIX%%
lib/lib%%RUBY_NAME%%.so
lib/lib%%RUBY_NAME%%.so.%%RUBY_SHLIBVER%%
%%RUBY_ARCHLIBDIR%%/config.h