aboutsummaryrefslogtreecommitdiff
path: root/mail/rubygem-pony/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-08-30 21:49:13 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-08-30 21:49:13 +0000
commitb19aebac9bafbd4d02fcdad83dd5c256143e6731 (patch)
treeaf8a2b8d02ab8d5e458d8f9e0b4e9d1e6e0e555a /mail/rubygem-pony/Makefile
parent63e560a5d7b6f2ec431ade7a3c54052b40b42f57 (diff)
downloadports-b19aebac9bafbd4d02fcdad83dd5c256143e6731.tar.gz
ports-b19aebac9bafbd4d02fcdad83dd5c256143e6731.zip
The express way to send mail from Ruby.
Send email in one command: Pony.mail(:to => 'someone@example.com', :body => 'hello') Pony uses /usr/sbin/sendmail to send mail if it is available, otherwise it uses SMTP to localhost. Also, you may need rubygem-smtp_tls if you want to send via tls/ssl and are using ruby < 1.8.7 WWW: http://github.com/benprew/pony PR: ports/150116 Submitted by: Eric Freeman <freebsdports at chillibear.com>
Notes
Notes: svn path=/head/; revision=260220
Diffstat (limited to 'mail/rubygem-pony/Makefile')
-rw-r--r--mail/rubygem-pony/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/mail/rubygem-pony/Makefile b/mail/rubygem-pony/Makefile
new file mode 100644
index 000000000000..8ba7ed76e177
--- /dev/null
+++ b/mail/rubygem-pony/Makefile
@@ -0,0 +1,22 @@
+# Ports collection makefile for: rubygem-pony
+# Date created: 30 Aug 2010
+# Whom: Eric Freeman <freebsdports@chillibear.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pony
+PORTVERSION= 1.0
+CATEGORIES= mail rubygems
+MASTER_SITES= RG
+
+MAINTAINER= freebsdports@chillibear.com
+COMMENT= The express way to send mail from Ruby
+
+RUN_DEPENDS= rubygem-mail>=2.0:${PORTSDIR}/mail/rubygem-mail
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>