aboutsummaryrefslogtreecommitdiff
path: root/math/hs-syfco
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-10-29 07:06:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-10-29 07:08:34 +0000
commit65be57f92214852ef03b5d1a3eba15f3adc11ee9 (patch)
tree1e6557ab7b11defe733f9dd5f1be695244d7560d /math/hs-syfco
parenta7b9d7c999984c4d96ed750c12421a5ca7f9833e (diff)
downloadports-65be57f92214852ef03b5d1a3eba15f3adc11ee9.tar.gz
ports-65be57f92214852ef03b5d1a3eba15f3adc11ee9.zip
math/hs-syfco: New port: Synthesis Format Conversion Tool
Diffstat (limited to 'math/hs-syfco')
-rw-r--r--math/hs-syfco/Makefile30
-rw-r--r--math/hs-syfco/distinfo13
-rw-r--r--math/hs-syfco/files/patch-src_lib_Reader.hs11
-rw-r--r--math/hs-syfco/files/patch-syfco.cabal36
-rw-r--r--math/hs-syfco/pkg-descr8
5 files changed, 98 insertions, 0 deletions
diff --git a/math/hs-syfco/Makefile b/math/hs-syfco/Makefile
new file mode 100644
index 000000000000..00f3a2e14f19
--- /dev/null
+++ b/math/hs-syfco/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= syfco
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1-34
+DISTVERSIONSUFFIX= -g0f0f6a6
+CATEGORIES= math lang haskell
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Synthesis Format Conversion Tool
+WWW= https://github.com/reactive-systems/syfco
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cabal
+
+USE_GITHUB= yes
+GH_ACCOUNT= reactive-systems
+
+USE_CABAL= convertible-1.1.1.1 \
+ old-locale-1.0.0.7_2 \
+ old-time-1.1.0.3_2
+CABAL_FLAGS= -relocatable
+
+CABAL_EXECUTABLES= syfco
+CABAL_WRAPPER_SCRIPTS= ${CABAL_EXECUTABLES}
+
+PLIST_FILES= bin/syfco \
+ libexec/cabal/syfco
+
+.include <bsd.port.mk>
diff --git a/math/hs-syfco/distinfo b/math/hs-syfco/distinfo
new file mode 100644
index 000000000000..dd6db4111d1a
--- /dev/null
+++ b/math/hs-syfco/distinfo
@@ -0,0 +1,13 @@
+TIMESTAMP = 1666983297
+SHA256 (cabal/convertible-1.1.1.1/convertible-1.1.1.1.tar.gz) = 991ebd70e413dc7314d3d34fddaa1ad34a837aea48cb8117e1b323f403348cef
+SIZE (cabal/convertible-1.1.1.1/convertible-1.1.1.1.tar.gz) = 14071
+SHA256 (cabal/old-locale-1.0.0.7/old-locale-1.0.0.7.tar.gz) = dbaf8bf6b888fb98845705079296a23c3f40ee2f449df7312f7f7f1de18d7b50
+SIZE (cabal/old-locale-1.0.0.7/old-locale-1.0.0.7.tar.gz) = 3384
+SHA256 (cabal/old-locale-1.0.0.7/revision/2.cabal) = fa998be2c7e00cd26a6e9075bea790caaf3932caa3e9497ad69bc20380dd6911
+SIZE (cabal/old-locale-1.0.0.7/revision/2.cabal) = 1071
+SHA256 (cabal/old-time-1.1.0.3/old-time-1.1.0.3.tar.gz) = 1ccb158b0f7851715d36b757c523b026ca1541e2030d02239802ba39b4112bc1
+SIZE (cabal/old-time-1.1.0.3/old-time-1.1.0.3.tar.gz) = 74219
+SHA256 (cabal/old-time-1.1.0.3/revision/2.cabal) = c91fbb3ee73d20ccd015842b30f1f29a304893ebe0ae3128b7bbc13d5bb0d4c8
+SIZE (cabal/old-time-1.1.0.3/revision/2.cabal) = 1328
+SHA256 (cabal/reactive-systems-syfco-v1.1-34-g0f0f6a6_GH0.tar.gz) = 24786fa3d792187ecfefe5674b675f64faa1172f9dfec348d595507706872a06
+SIZE (cabal/reactive-systems-syfco-v1.1-34-g0f0f6a6_GH0.tar.gz) = 105621
diff --git a/math/hs-syfco/files/patch-src_lib_Reader.hs b/math/hs-syfco/files/patch-src_lib_Reader.hs
new file mode 100644
index 000000000000..8f23d4384726
--- /dev/null
+++ b/math/hs-syfco/files/patch-src_lib_Reader.hs
@@ -0,0 +1,11 @@
+--- src/lib/Reader.hs.orig 2022-10-28 19:22:32 UTC
++++ src/lib/Reader.hs
+@@ -102,7 +102,7 @@ fromTLSF str =
+ inferTypes >>=
+
+ -- lift reader specification to global specification
+- \(s @ RD.Specification {..}) -> return
++ \(s@RD.Specification {..}) -> return
+ Specification
+ { source = str
+ , title = fst title
diff --git a/math/hs-syfco/files/patch-syfco.cabal b/math/hs-syfco/files/patch-syfco.cabal
new file mode 100644
index 000000000000..b1a57f934ab7
--- /dev/null
+++ b/math/hs-syfco/files/patch-syfco.cabal
@@ -0,0 +1,36 @@
+--- syfco.cabal.orig 2022-10-28 18:55:24 UTC
++++ syfco.cabal
+@@ -22,12 +22,12 @@ library
+ -Wall -Wno-name-shadowing
+
+ build-depends:
+- base >=4.7 && <4.13
+- , array >=0.5 && <0.6
+- , containers >=0.5 && <0.7
+- , mtl >=2.2 && <2.3
+- , parsec >=3.1 && <3.2
+- , transformers >= 0.4 && <0.6
++ base >=4.7
++ , array >=0.5
++ , containers >=0.5
++ , mtl >=2.2
++ , parsec >=3.1
++ , transformers >= 0.4
+ , convertible >= 1.1
+
+ exposed-modules:
+@@ -106,10 +106,10 @@ executable syfco
+
+ build-depends:
+ syfco
+- , base >=4.7 && <4.13
+- , directory >=1.2 && <1.4
+- , parsec >=3.1 && <3.2
+- , convertible >= 1.1
++ , base >=4.7
++ , directory >=1.2
++ , parsec >=3.1
++ , convertible >= 1.0.0
+
+ other-modules:
+ Arguments
diff --git a/math/hs-syfco/pkg-descr b/math/hs-syfco/pkg-descr
new file mode 100644
index 000000000000..9b6403a5f2cb
--- /dev/null
+++ b/math/hs-syfco/pkg-descr
@@ -0,0 +1,8 @@
+The tool interprets the high level constructs of TLSF 1.1 (functions, sets, ...)
+and supports the transformation of the specification to Linear Temporal Logic
+(LTL) in different output formats. The tool has been designed to be modular with
+respect to the supported output formats and semantics. Furthermore, the tool
+allows to identify and manipulate parameters, targets and semantics of a
+specification on the fly. This is especially thought to be useful for
+comparative studies, as they are for example needed in the Synthesis
+Competition.