aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-econometrics/Makefile
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2019-10-19 23:18:42 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2019-10-19 23:18:42 +0000
commit5865df0737bd26b9b4a56d1951abe04b14934721 (patch)
treee225cb5ce0c96321f0eba4071fec669c2d32258f /math/octave-forge-econometrics/Makefile
parent8fdc8f0432e47a6db13aefcbdd9abc547819c09f (diff)
downloadports-5865df0737bd26b9b4a56d1951abe04b14934721.tar.gz
ports-5865df0737bd26b9b4a56d1951abe04b14934721.zip
- Resurrect math/octave-forge-econometrics.
- Update to 1.1.2. - Change default of ECONOMETRICS in math/octave-forge to on. - Bump port revision for math/octave-forge.
Notes
Notes: svn path=/head/; revision=514858
Diffstat (limited to 'math/octave-forge-econometrics/Makefile')
-rw-r--r--math/octave-forge-econometrics/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/math/octave-forge-econometrics/Makefile b/math/octave-forge-econometrics/Makefile
new file mode 100644
index 000000000000..0c8759abd404
--- /dev/null
+++ b/math/octave-forge-econometrics/Makefile
@@ -0,0 +1,28 @@
+# Created by: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+# $FreeBSD$
+
+PORTNAME= octave-forge-econometrics
+PORTVERSION= 1.1.2
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+RUN_DEPENDS+= ${TARBALLS_DIR}/optim.tar.gz:math/octave-forge-optim
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+post-build:
+ ${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>