aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-tisean/Makefile
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2016-01-13 03:47:11 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2016-01-13 03:47:11 +0000
commitac82ab059117fd64b788e531870d5f4b6d0d8d4f (patch)
tree61fb583c831544e6de5fc0080b9772666399f147 /math/octave-forge-tisean/Makefile
parent3da75467c686058c5ee66b5447231fc1b7720bdf (diff)
downloadports-ac82ab059117fd64b788e531870d5f4b6d0d8d4f.tar.gz
ports-ac82ab059117fd64b788e531870d5f4b6d0d8d4f.zip
- New port math/octave-forge-tisean.
The octave-forge package is the result of The GNU Octave Repositry project, which is intended to be a central location for custom scripts, functions and extensions for GNU Octave. contains the source for all the functions plus build and install scripts.
Notes
Notes: svn path=/head/; revision=406003
Diffstat (limited to 'math/octave-forge-tisean/Makefile')
-rw-r--r--math/octave-forge-tisean/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/math/octave-forge-tisean/Makefile b/math/octave-forge-tisean/Makefile
new file mode 100644
index 000000000000..cd68acc029d9
--- /dev/null
+++ b/math/octave-forge-tisean/Makefile
@@ -0,0 +1,30 @@
+# Created by: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+# $FreeBSD$
+
+PORTNAME= octave-forge-tisean
+PORTVERSION= 0.2.3
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+
+RUN_DEPENDS+= ${TARBALLS_DIR}/signal.tar.gz:${PORTSDIR}/math/octave-forge-signal
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+GNU_CONFIGURE= yes
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>