aboutsummaryrefslogtreecommitdiff
path: root/math/octave/files
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2009-08-03 11:20:23 +0000
committerMaho Nakata <maho@FreeBSD.org>2009-08-03 11:20:23 +0000
commita20304db7274af3a4b70ce4fd0691181f4450492 (patch)
treecb4f6b7feefa30c622f173bbe51488d4ee8dacb9 /math/octave/files
parentceea2c6bec9cc18df17cb1cd55b04caa41c81aad (diff)
downloadports-a20304db7274af3a4b70ce4fd0691181f4450492.tar.gz
ports-a20304db7274af3a4b70ce4fd0691181f4450492.zip
Update to 3.2.2.
Notes
Notes: svn path=/head/; revision=238814
Diffstat (limited to 'math/octave/files')
-rw-r--r--math/octave/files/patch-configure.in15
-rw-r--r--math/octave/files/patch-scripts+pkg+pkg.m14
-rw-r--r--math/octave/files/patch-src+Makefile.in13
3 files changed, 22 insertions, 20 deletions
diff --git a/math/octave/files/patch-configure.in b/math/octave/files/patch-configure.in
new file mode 100644
index 000000000000..10530030c0da
--- /dev/null
+++ b/math/octave/files/patch-configure.in
@@ -0,0 +1,15 @@
+--- configure.in~ 2008-07-22 10:30:06.000000000 +0900
++++ configure.in 2008-09-22 15:04:07.000000000 +0900
+@@ -855,9 +855,10 @@
+ ### Checks for BLAS and LAPACK libraries:
+ # (Build subdirectories of libcruft if they aren't found on the system.)
+ sinclude(acx_blas.m4)
+-sinclude(acx_blas_f77_func.m4)
++#sinclude(acx_blas_f77_func.m4)
+ sinclude(acx_lapack.m4)
+-ACX_BLAS_WITH_F77_FUNC([], [BLAS_DIR="blas"])
++ACX_BLAS([], [BLAS_DIR="blas"])
++#ACX_BLAS_WITH_F77_FUNC([], [BLAS_DIR="blas"])
+ ACX_LAPACK([BLAS_LIBS="$LAPACK_LIBS $BLAS_LIBS"], [LAPACK_DIR="lapack"])
+ AC_SUBST(BLAS_DIR)
+ AC_SUBST(LAPACK_DIR)
diff --git a/math/octave/files/patch-scripts+pkg+pkg.m b/math/octave/files/patch-scripts+pkg+pkg.m
index 1e46e7eab91d..ec414d29ebf6 100644
--- a/math/octave/files/patch-scripts+pkg+pkg.m
+++ b/math/octave/files/patch-scripts+pkg+pkg.m
@@ -1,11 +1,11 @@
---- scripts/pkg/pkg.m~ 2009-04-09 17:26:54.000000000 +0900
-+++ scripts/pkg/pkg.m 2009-04-09 17:27:14.000000000 +0900
-@@ -1242,7 +1242,7 @@
- ## make
+--- scripts/pkg/pkg.m~ 2009-07-27 18:31:53.000000000 +0900
++++ scripts/pkg/pkg.m 2009-07-27 18:32:52.000000000 +0900
+@@ -1247,7 +1247,7 @@
+ ## Make.
if (exist (fullfile (src, "Makefile"), "file"))
- [status, output] = shell (strcat ("export INSTALLDIR=\"", desc.dir,
-- "\"; make -C '", src, "'"));
-+ "\"; gmake -C '", src, "'"));
+ [status, output] = shell (cstrcat ("export INSTALLDIR=\"", desc.dir,
+- "\"; make -C '", src, "'"));
++ "\"; gmake -C '", src, "'"));
if (status != 0)
rm_rf (desc.dir);
error ("'make' returned the following error: %s", output);
diff --git a/math/octave/files/patch-src+Makefile.in b/math/octave/files/patch-src+Makefile.in
deleted file mode 100644
index 5da6b5d58a88..000000000000
--- a/math/octave/files/patch-src+Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
-for gendoc part, http://gcc.gnu.org/bugzilla/show_bug.cgi?id=30423
-
---- src/Makefile.in.orig Sat Sep 30 03:20:15 2006
-+++ src/Makefile.in Wed Jan 10 19:26:54 2007
-@@ -313,7 +313,7 @@
- $(OCTAVE_LIBS) \
- $(LEXLIB) $(UMFPACK_LIBS) $(AMD_LIBS) $(COLAMD_LIBS) \
- $(CHOLMOD_LIBS) $(CCOLAMD_LIBS) $(CXSPARSE_LIBS) $(BLAS_LIBS) \
-- $(FFTW_LIBS) $(LIBS) $(FLIBS)
-+ $(FFTW_LIBS) $(LIBS) $(FLIBS) -lcamd
-
- stmp-pic: pic
- @if [ -f stmp-pic ]; then \